~ubuntu-branches/ubuntu/trusty/rzip/trusty

« back to all changes in this revision

Viewing changes to debian/patches/70hardeningflags.diff

  • Committer: Package Import Robot
  • Author(s): Daniel Echeverry, Daniel Echeverry, Ryan Kavanagh
  • Date: 2013-08-14 21:46:23 UTC
  • Revision ID: package-import@ubuntu.com-20130814214623-mg509vadanivmp8g
Tags: 2.1-2
[ Daniel Echeverry ]
* QA upload.
* Switch compat level 4 to 9.
* Switch to dpkg-source 3.0 (quilt) format. Closes: #664444
* Add debian/watch
* debian/control
  + Set QA team as Maintainer
  + Remove dpatch in B-D
  + Add ${misc:Depends}. Closes: #715176
  + Add Homepage field
  + Bump Standards-Version to 3.9.4
  + Bump debhelper to 9 in B-D
* debian/patches
  + Add 60fix_manpage.diff
    + Fix hyphen-used-as-minus-sign lintian warning
    + Fix some typos. Closes: #355835
  + Add description in 50fhs.patch
  + Add 70hardeningflags.diff
    + Add CPPFLAGS, CFLAGS and LDFLAGS to use hardening flags
* debian/copyright
  + Update to DEP5 copyright format 1.0
* debian/rules
  + Use new-style dh format
* Add debian/rzip.clean
  + Clean up generate and build files

[ Ryan Kavanagh ]
* Remove Makefile and config.h on clean

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Add CPPFLAGS, CFLAGS and LDFLAGS to use hardening flags
 
2
Forwarded: No
 
3
Author: Daniel Echeverry <epsilon77@gmail.com>
 
4
Last-Update: 2013-08-25
 
5
--- a/Makefile.in
 
6
+++ b/Makefile.in
 
7
@@ -24,7 +24,7 @@ OBJS= rzip.o runzip.o main.o stream.o ut
 
8
 
 
9
 # note that the -I. is needed to handle config.h when using VPATH
 
10
 .c.o:
 
11
-       $(CC) -I. -I$(srcdir) $(CFLAGS) -c $< -o $@
 
12
+       $(CC) -I. -I$(srcdir) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
 
13
 
 
14
 all: rzip
 
15
 
 
16
@@ -39,7 +39,7 @@ install: all
 
17
        ln ${INSTALL_MAN}/man1/rzip.1 ${INSTALL_MAN}/man1/runzip.1
 
18
 
 
19
 rzip: $(OBJS)
 
20
-       $(CC) $(CFLAGS) -o rzip $(OBJS) $(LIBS)
 
21
+       $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o rzip $(OBJS) $(LIBS)
 
22
 
 
23
 rzip.1: rzip.yo
 
24
        yodl2man -o rzip.1 rzip.yo