~ubuntu-branches/ubuntu/utopic/sip-tester/utopic

« back to all changes in this revision

Viewing changes to debian/patches/enable-gsl.patch

  • Committer: Package Import Robot
  • Author(s): Mark Purcell, Paul Belanger, Mark Purcell
  • Date: 2011-11-03 21:56:17 UTC
  • mfrom: (1.1.7)
  • Revision ID: package-import@ubuntu.com-20111103215617-nnxicj1oto9e8ix5
Tags: 1:3.2-1
[ Paul Belanger ]
* New Upstream Release (Closes: #623915).
* Switch to dpkg-source 3.0 (quilt) format
* Building with PCAP play.
* Switch back to Debhelper.
* debian/patches/spelling-error-in-binary: Fix lintian warning

[ Mark Purcell ]
* Drop pabs from Uploaders: at his request
* fix debhelper-overrides-need-versioned-build-depends
* fix description-synopsis-starts-with-article

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff -Nur -x '*.orig' -x '*~' sip-tester-3.1//local.mk sip-tester-3.1.new//local.mk
2
 
--- sip-tester-3.1//local.mk    2008-01-12 06:53:48.000000000 +1100
3
 
+++ sip-tester-3.1.new//local.mk        2010-06-14 13:30:21.000000000 +1000
 
1
--- a/local.mk
 
2
+++ b/local.mk
4
3
@@ -2,3 +2,7 @@
5
4
 #  EXTRACPPFLAGS=-DHAVE_GSL -I`if test -f /usr/local/lib/libgsl.so; then echo /usr/local; else echo ./ext; fi;`/include
6
5
 #  EXTRACFLAGS=-DHAVE_GSL -I`if test -f /usr/local/lib/libgsl.so; then echo /usr/local; else echo ./ext; fi;`/include
9
8
+EXTRACFLAGS=-DHAVE_GSL `pkg-config --include gsl`
10
9
+EXTRALIBS=`pkg-config --libs gsl`
11
10
+
12
 
diff -Nur -x '*.orig' -x '*~' sip-tester-3.1//scenario.cpp sip-tester-3.1.new//scenario.cpp
13
 
--- sip-tester-3.1//scenario.cpp        2008-03-29 07:13:47.000000000 +1100
14
 
+++ sip-tester-3.1.new//scenario.cpp    2010-06-14 13:31:58.000000000 +1000
15
 
@@ -28,11 +28,9 @@
 
11
--- a/scenario.cpp
 
12
+++ b/scenario.cpp
 
13
@@ -29,11 +29,9 @@
16
14
 
17
15
 #include <stdlib.h>
18
16
 #include "sipp.hpp"
24
22
 
25
23
 /************************ Class Constructor *************************/
26
24
 
27
 
@@ -1081,7 +1079,6 @@
 
25
@@ -1115,7 +1113,6 @@ CSample *parse_distribution(bool oldstyl
28
26
     double min = xp_get_double("min", "Uniform distribution");
29
27
     double max = xp_get_double("max", "Uniform distribution");
30
28
     distribution = new CUniform(min, max);
32
30
   } else if (!strcmp(distname, "normal")) {
33
31
     double mean = xp_get_double("mean", "Normal distribution");
34
32
     double stdev = xp_get_double("stdev", "Normal distribution");
35
 
@@ -1114,16 +1111,6 @@
 
33
@@ -1148,16 +1145,6 @@ CSample *parse_distribution(bool oldstyl
36
34
     double n = xp_get_double("n", "Negative Binomial distribution");
37
35
     double p = xp_get_double("p", "Negative Binomial distribution");
38
36
     distribution = new CNegBin(n, p);
49
47
   } else {
50
48
     ERROR("Unknown distribution: %s\n", ptr);
51
49
   }
52
 
diff -Nur -x '*.orig' -x '*~' sip-tester-3.1//stat.cpp sip-tester-3.1.new//stat.cpp
53
 
--- sip-tester-3.1//stat.cpp    2008-03-28 01:56:58.000000000 +1100
54
 
+++ sip-tester-3.1.new//stat.cpp        2010-06-14 13:32:45.000000000 +1000
 
50
--- a/stat.cpp
 
51
+++ b/stat.cpp
55
52
@@ -30,11 +30,9 @@
56
53
 #include "sipp.hpp"
57
54
 #include "scenario.hpp"
64
61
 
65
62
 /*
66
63
 ** Local definitions (macros)
67
 
@@ -1673,7 +1671,6 @@
 
64
@@ -1862,7 +1860,6 @@ double CUniform::cdfInv(double percentil
68
65
   return min + (max * percentile);
69
66
 }
70
67
 
72
69
 gsl_rng *gsl_init() {
73
70
   static gsl_rng *rng = NULL;
74
71
 
75
 
@@ -1912,6 +1909,5 @@
 
72
@@ -2101,6 +2098,5 @@ int CNegBin::timeDescr(char *s, int len)
76
73
 double CNegBin::cdfInv(double percentile) {
77
74
   return 0;
78
75
 }
79
76
-#endif
80
77
 
81
78
 
82
 
diff -Nur -x '*.orig' -x '*~' sip-tester-3.1//stat.hpp sip-tester-3.1.new//stat.hpp
83
 
--- sip-tester-3.1//stat.hpp    2008-04-11 22:26:37.000000000 +1000
84
 
+++ sip-tester-3.1.new//stat.hpp        2010-06-14 13:33:06.000000000 +1000
85
 
@@ -41,11 +41,9 @@
 
79
--- a/stat.hpp
 
80
+++ b/stat.hpp
 
81
@@ -38,11 +38,9 @@
86
82
 #include <fstream>
87
83
 #include <stdio.h>
88
84
 
92
88
 #include <gsl/gsl_cdf.h>
93
89
-#endif
94
90
 
95
 
 /* MAX_RTD_INFO_LENGTH defines the number of RTD begin and end points a single
96
 
  * call can have.  If you need more than five, you can increase this number,
97
 
@@ -615,7 +613,6 @@
 
91
 #include "variables.hpp"
 
92
 
 
93
@@ -629,7 +627,6 @@ private:
98
94
        double min, max;
99
95
 };
100
96
 
102
98
 /* Normal distribution. */
103
99
 class CNormal : public CSample {
104
100
 public:
105
 
@@ -717,6 +714,5 @@
 
101
@@ -731,6 +728,5 @@ protected:
106
102
        double p, n;
107
103
        gsl_rng *rng;
108
104
 };