~ubuntu-branches/ubuntu/vivid/sslh/vivid-proposed

« back to all changes in this revision

Viewing changes to debian/patches/disable_ip_freebind_test.diff

  • Committer: Package Import Robot
  • Author(s): Guillaume Delacour
  • Date: 2014-08-07 00:06:06 UTC
  • mfrom: (1.1.6)
  • Revision ID: package-import@ubuntu.com-20140807000606-y1tg7j8i5t7d4drr
Tags: 1.16-1
* New upstream release: fix some startup problem when interfaces are not
  ready at boot time (IP_FREEBIND support when available) and can use libcap
  for transparent mode
* Enable libcap and libwrap support at build time
* Enable dpkg-buildflags: Drop hardening-wrapper Build-Depends and use
  DEB_BUILD_HARDENING instead of DEB_BUILD_MAINT_OPTIONS
* Remove old .gitignore as upstream has one too
* debian/sslh.tmpfile: Create /run/sslh for systemd as root because sslh
  write its pid before dropping privileges (Closes: #740560)
* debian/patches/disable_ip_freebind_test.diff: Remove "Can't bind address"
  upstream test because IP_FREEBIND is now enabled upstream
* debian/docs: upstream README is now README.md
* debian/rules:
  + use DESTDIR in addition of PREFIX as upstream change Makefile
* Refresh debian/patches/disable_valgrind_launch.diff due to upstream
  changes
* Stop service in case of purge (to be able to remove the user too)
* Use DEB_BUILD_OPTIONS to speed the build
* debian/patches/fixed_version.diff: Fix the version of binaries based on
  debian/changelog (instead of relying on git)
* Update Description as sslh is not only a ssl/ssh multiplexer but a
  protocol multiplexer

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Subject: With IP_FREEBIND (sslh >= 1.16), we can bind a non-existing address
 
2
Last-Update: 2014-07-15
 
3
Forwarded: http://rutschle.net/pipermail/sslh/2014-July/000527.html
 
4
 
 
5
Index: sslh/t
 
6
===================================================================
 
7
--- sslh.orig/t
 
8
+++ sslh/t
 
9
@@ -294,21 +294,6 @@ if ($RB_OPEN_PID_FILE) {
 
10
     is($code, 3, "Exit status if can't open PID file");
 
11
 }
 
12
 
 
13
-# Robustness: Can't bind address
 
14
-if ($RB_BIND_ADDRESS) {
 
15
-    print "***Test: Can't bind address\n";
 
16
-    my $sslh_pid;
 
17
-    if (!($sslh_pid = fork)) {
 
18
-        my $user = (getpwuid $<)[0]; # Run under current username
 
19
-        exec "./sslh-select -v -f -u $user --listen 74.125.39.106:9000 --ssh $ssh_address --ssl $ssl_address -P $pidfile";
 
20
-    }
 
21
-    warn "spawned $sslh_pid\n";
 
22
-    waitpid $sslh_pid, 0;
 
23
-    my $code = $? >> 8;
 
24
-    warn "exited with $code\n";
 
25
-    is($code, 1, "Exit status if can't bind address");
 
26
-}
 
27
-
 
28
 # Robustness: Can't resolve address
 
29
 if ($RB_RESOLVE_ADDRESS) {
 
30
     print "***Test: Can't resolve address\n";