~ubuntu-desktop/rhythmbox/ubuntu

« back to all changes in this revision

Viewing changes to debian/patches/01_lpi.patch

  • Committer: seb128
  • Date: 2009-08-10 12:07:55 UTC
  • Revision ID: seb128@seb128-laptop-20090810120755-e30rib1u0untn856
initial rhythmbox import

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff -Nur -x '*.orig' -x '*~' rhythmbox-0.11.6svn20090108/configure.ac rhythmbox-0.11.6svn20090108.new/configure.ac
 
2
--- rhythmbox-0.11.6svn20090108/configure.ac    2009-01-08 11:45:30.000000000 +0100
 
3
+++ rhythmbox-0.11.6svn20090108.new/configure.ac        2009-01-08 11:45:58.000000000 +0100
 
4
@@ -66,6 +66,7 @@
 
5
                  gtk+-2.0 >= $GTK_REQS                 \
 
6
                  glib-2.0 >= $GLIB_REQS                \
 
7
                  gio-2.0 >= $GLIB_REQS                 \
 
8
+          launchpad-integration         \
 
9
                  gnome-media-profiles >= $GNOME_MEDIA_PROFILES_REQS \
 
10
                  libgnomeui-2.0                        \
 
11
                  libglade-2.0                          \
 
12
diff -Nur -x '*.orig' -x '*~' rhythmbox-0.11.6svn20090108/data/ui/rhythmbox-ui.xml rhythmbox-0.11.6svn20090108.new/data/ui/rhythmbox-ui.xml
 
13
--- rhythmbox-0.11.6svn20090108/data/ui/rhythmbox-ui.xml        2009-01-08 11:23:20.000000000 +0100
 
14
+++ rhythmbox-0.11.6svn20090108.new/data/ui/rhythmbox-ui.xml    2009-01-08 11:45:32.000000000 +0100
 
15
@@ -90,6 +90,7 @@
 
16
 
 
17
     <menu name="HelpMenu" action="Help">
 
18
       <menuitem name="HelpContentsMenu" action="HelpContents"/>
 
19
+      <placeholder name="LaunchpadItems"/>
 
20
       <menuitem name="HelpAboutMenu" action="HelpAbout"/>
 
21
     </menu>
 
22
 
 
23
diff -Nur -x '*.orig' -x '*~' rhythmbox-0.11.6svn20090108/shell/rb-shell.c rhythmbox-0.11.6svn20090108.new/shell/rb-shell.c
 
24
--- rhythmbox-0.11.6svn20090108/shell/rb-shell.c        2009-01-08 11:23:20.000000000 +0100
 
25
+++ rhythmbox-0.11.6svn20090108.new/shell/rb-shell.c    2009-01-08 11:45:32.000000000 +0100
 
26
@@ -35,6 +35,7 @@
 
27
 #include <ctype.h>
 
28
 #include <stdio.h>
 
29
 #include <sys/stat.h>
 
30
+#include <launchpad-integration.h>
 
31
 
 
32
 #include <glib/gi18n.h>
 
33
 #include <gdk/gdk.h>
 
34
@@ -1238,6 +1239,10 @@
 
35
        gtk_ui_manager_ensure_update (shell->priv->ui_manager);
 
36
        gtk_window_add_accel_group (GTK_WINDOW (shell->priv->window),
 
37
                                    gtk_ui_manager_get_accel_group (shell->priv->ui_manager));
 
38
+
 
39
+       launchpad_integration_add_ui (shell->priv->ui_manager,
 
40
+                                     "/MenuBar/HelpMenu/LaunchpadItems");
 
41
+
 
42
        menubar = gtk_ui_manager_get_widget (shell->priv->ui_manager, "/MenuBar");
 
43
 
 
44
        gtk_box_pack_start (GTK_BOX (shell->priv->main_vbox), menubar, FALSE, FALSE, 0);