~ubuntu-desktop/rhythmbox/ubuntu

« back to all changes in this revision

Viewing changes to debian/patches/restore-traditional-menubar.patch

  • Committer: Sebastien Bacher
  • Date: 2016-08-24 14:51:52 UTC
  • Revision ID: seb128@ubuntu.com-20160824145152-igte0owfyg2q4ul3
* debian/patches/restore-traditional-menubar.patch:
  - include the .ui in the gresource index so it can be find, restore
    working menus under unity (lp: #1616273)

Show diffs side-by-side

added added

removed removed

Lines of Context:
12
12
 4 files changed, 251 insertions(+), 1 deletion(-)
13
13
 create mode 100644 data/ui/menubar.ui
14
14
 
15
 
diff --git a/data/ui/Makefile.am b/data/ui/Makefile.am
16
 
index cebefea..a2b89f1 100644
17
 
--- a/data/ui/Makefile.am
18
 
+++ b/data/ui/Makefile.am
 
15
Index: rhythmbox-3.4/data/ui/Makefile.am
 
16
===================================================================
 
17
--- rhythmbox-3.4.orig/data/ui/Makefile.am
 
18
+++ rhythmbox-3.4/data/ui/Makefile.am
19
19
@@ -1,6 +1,7 @@
20
20
 
21
21
 GTK_BUILDER_FILES =                                    \
24
24
        browser-popup.ui                                \
25
25
        create-playlist.ui                              \
26
26
        display-page-add-menu.ui                        \
27
 
diff --git a/data/ui/menubar.ui b/data/ui/menubar.ui
28
 
new file mode 100644
29
 
index 0000000..d4e1a84
 
27
Index: rhythmbox-3.4/data/ui/menubar.ui
 
28
===================================================================
30
29
--- /dev/null
31
 
+++ b/data/ui/menubar.ui
32
 
@@ -0,0 +1,235 @@
 
30
+++ rhythmbox-3.4/data/ui/menubar.ui
 
31
@@ -0,0 +1,236 @@
33
32
+<?xml version="1.0"?>
34
33
+<interface>
35
34
+  <menu id="menubar">
266
265
+    </submenu>
267
266
+  </menu>
268
267
+</interface>
269
 
+
270
 
diff --git a/po/POTFILES.in b/po/POTFILES.in
271
 
index ec639aa..7f8fb82 100644
272
 
--- a/po/POTFILES.in
273
 
+++ b/po/POTFILES.in
274
 
@@ -7,6 +7,7 @@ data/playlists.xml.in
 
268
Index: rhythmbox-3.4/po/POTFILES.in
 
269
===================================================================
 
270
--- rhythmbox-3.4.orig/po/POTFILES.in
 
271
+++ rhythmbox-3.4/po/POTFILES.in
 
272
@@ -8,6 +8,7 @@ data/rhythmbox.appdata.xml.in
275
273
 data/rhythmbox.desktop.in.in
276
274
 data/rhythmbox-device.desktop.in.in
277
275
 [type: gettext/glade]data/ui/app-menu.ui
279
277
 [type: gettext/glade]data/ui/browser-popup.ui
280
278
 [type: gettext/glade]data/ui/create-playlist.ui
281
279
 [type: gettext/glade]data/ui/display-page-add-menu.ui
282
 
diff --git a/shell/rb-application.c b/shell/rb-application.c
283
 
index 68e7a5e..6533087 100644
284
 
--- a/shell/rb-application.c
285
 
+++ b/shell/rb-application.c
286
 
@@ -332,6 +332,7 @@ impl_startup (GApplication *app)
 
280
Index: rhythmbox-3.4/shell/rb-application.c
 
281
===================================================================
 
282
--- rhythmbox-3.4.orig/shell/rb-application.c
 
283
+++ rhythmbox-3.4/shell/rb-application.c
 
284
@@ -342,6 +342,7 @@ impl_startup (GApplication *app)
287
285
 {
288
286
        RBApplication *rb = RB_APPLICATION (app);
289
287
        gboolean shell_shows_app_menu;
291
289
        GtkBuilder *builder;
292
290
        GMenuModel *menu;
293
291
        GtkCssProvider *provider;
294
 
@@ -361,6 +362,7 @@ impl_startup (GApplication *app)
 
292
@@ -371,6 +372,7 @@ impl_startup (GApplication *app)
295
293
 
296
294
        g_object_get (gtk_settings_get_default (),
297
295
                      "gtk-shell-shows-app-menu", &shell_shows_app_menu,
299
297
                      NULL);
300
298
 
301
299
        builder = rb_builder_load ("app-menu.ui", NULL);
302
 
@@ -371,9 +373,20 @@ impl_startup (GApplication *app)
 
300
@@ -381,9 +383,20 @@ impl_startup (GApplication *app)
303
301
        /* only set the app menu if the shell shows it; otherwise, we'll
304
302
         * stick a menu button in the toolbar.
305
303
         */
321
319
        
322
320
        g_object_unref (builder);
323
321
 
324
 
1.9.0
325
 
 
 
322
Index: rhythmbox-3.4/shell/rhythmbox.gresource.xml
 
323
===================================================================
 
324
--- rhythmbox-3.4.orig/shell/rhythmbox.gresource.xml
 
325
+++ rhythmbox-3.4/shell/rhythmbox.gresource.xml
 
326
@@ -21,6 +21,7 @@
 
327
                <file preprocess="xml-stripblanks">ui/library-toolbar.ui</file>
 
328
                <file preprocess="xml-stripblanks">ui/main-toolbar.ui</file>
 
329
                <file preprocess="xml-stripblanks">ui/media-player-properties.ui</file>
 
330
+               <file preprocess="xml-stripblanks">ui/menubar.ui</file>
 
331
                <file preprocess="xml-stripblanks">ui/missing-files-popup.ui</file>
 
332
                <file preprocess="xml-stripblanks">ui/playback-prefs.ui</file>
 
333
                <file preprocess="xml-stripblanks">ui/playlist-menu.ui</file>