~vila/ols-tests/test-tags

« back to all changes in this revision

Viewing changes to debian/control

  • Committer: Vincent Ladeuil
  • Date: 2016-07-21 15:13:13 UTC
  • Revision ID: vila+ols@canonical.com-20160721151313-u0wpeh1b3kikhzlk
Tags: ols-tests-1.0.1
ReleaseĀ 1.0.1

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Source: ols-tests
2
2
Section: python
3
3
Priority: optional
 
4
Standards-Version: 3.9.8
4
5
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
5
6
XSBC-Original-Maintainer: Vincent Ladeuil <vila+ols@canonical.com>
6
7
# Starting with ubuntu xenial, pep8 has been split between python-pep8 (module)
7
8
# and pep8 (script but for python3 !). We only need the module.
8
 
# For pyflakes, xenial split python-pyflakes and python3-pyflakes 
 
9
# For pyflakes, xenial split python-pyflakes and python3-pyflakes
9
10
Build-Depends: debhelper (>= 9),
10
11
               dh-python,
11
 
               python-pep8 | pep8 (<< 1.6.2-0.1ubuntu2),
12
 
               pyflakes (<< 1.1.0-2) | python-pyflakes (>= 1.1.0-2),
13
 
               pyflakes (<< 1.1.0-2) | python3-pyflakes (>= 1.1.0-2),
 
12
               python-pep8 | pep8,
 
13
               python3-pyflakes | pyflakes,
 
14
               python-pyflakes  | pyflakes,
14
15
               python-all,
15
16
               python-subunit,
16
17
               python-testtools,
20
21
               python3-setuptools,
21
22
               python3-subunit,
22
23
               python3-testtools,
23
 
Standards-Version: 3.9.4
24
24
 
25
25
Package: python-ols-tests
26
26
Architecture: all
27
27
# Same remark as above regarding python2 pep8
28
 
Depends: python-pep8 | pep8 (<< 1.6.2-0.1ubuntu2),
29
 
         python-pyflakes (>= 1.1.0-2) | pyflakes (<< 1.1.0-2),
 
28
Depends: python-pep8 | pep8,
 
29
         python-pyflakes | pyflakes,
30
30
         python-subunit,
31
31
         python-testtools,
32
32
         ${misc:Depends},
35
35
 
36
36
Package: python3-ols-tests
37
37
Architecture: all
38
 
# Same remark as above regarding python2 pyflakes
39
 
Depends: python3-pyflakes (>= 1.1.0-2) | pyflakes (<< 1.1.0-2),
 
38
# Either the python3 pyflakes library is its own package or it's provided as
 
39
# part of pyflakes (pyflakes3 was introduced later for the python3 script but
 
40
# we don't need nor use it)
 
41
Depends: python3-pyflakes | pyflakes,
40
42
         python3-pep8,
41
43
         python3-subunit,
42
44
         python3-testtools,