~3v1n0/ubuntu/precise/compiz/scale-hotkeys-change

« back to all changes in this revision

Viewing changes to debian/patches/fix-748840.patch

  • Committer: Bazaar Package Importer
  • Author(s): Didier Roche
  • Date: 2011-10-06 17:57:36 UTC
  • Revision ID: james.westby@ubuntu.com-20111006175736-ra3xnpa8tyy3z7vn
Tags: 1:0.9.6+bzr20110929-0ubuntu4
* debian/control:
  - don't suggest nvidia-glx, it's part of the old initial packaging
    and probably a bad hint on non nvidia system (LP: #844218)
* Cherry-pick upstream patches:
  - Windows should not automatically be focused when opened if the focus
    is on another application (LP: #748840)
  - Launcher - If a spread contains minimised windows, when the spread
    exits, the minimised windows momentarily appear on the desktop
    before disappearing (LP: #863328)
  - reproducible stacking bug in compiz (LP: #869316)
  - Click-dragging a window that's stacked above a fullscreen window will
    cause it to go underneath the fullscreen window (LP: #869919)
  - sometimes the keyboard input doesn't go to the apparently focussed
    dialog (LP: #869967)
  - Opening mumble can cause it to be stacked above the dash if you
    open the dash at the same time (LP: #865863)
  - Sometimes configure events are missed and windows move slow as a result
    (LP: #866752)
  - Workaround ubuntu desktop unity. Mouse at the left side doesn't reveal
    launcher (LP: #832150)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
=== modified file 'src/window.cpp'
 
2
Index: compiz-0.9.6+bzr20110929/src/window.cpp
 
3
===================================================================
 
4
--- compiz-0.9.6+bzr20110929.orig/src/window.cpp        2011-10-08 00:52:01.411641789 +0800
 
5
+++ compiz-0.9.6+bzr20110929/src/window.cpp     2011-10-08 00:52:15.907713677 +0800
 
6
@@ -4137,7 +4137,7 @@
 
7
             * window may not be allowed). */
 
8
            if (p && PrivateWindow::validSiblingBelow (p, this))
 
9
            {
 
10
-               p = PrivateWindow::findValidStackSiblingBelow (sibling, p);
 
11
+               p = PrivateWindow::findValidStackSiblingBelow (this, p);
 
12
 
 
13
                /* if we found a valid sibling under the active window, it's
 
14
                   our new sibling we want to stack above */