~ahasenack/ubuntu/oneiric/python-tz/day-leap-fix-885163

« back to all changes in this revision

Viewing changes to debian/patches/tzdata

  • Committer: Package Import Robot
  • Author(s): Gediminas Paulauskas
  • Date: 2011-08-23 18:14:25 UTC
  • Revision ID: package-import@ubuntu.com-20110823181425-af676e7psc5lw8m3
Tags: 2010b-1ubuntu1
* debian/patches/tzdata: remove import of pkg_resources (Closes: #599047)
* Switch to dh_python2 (LP: #831411, Closes: #617041).
* Switch to source format 3.0 (quilt)
* debian/control: build-depend on python-all (not -dev).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- pytz-2010b/pytz/__init__.py 2010-01-26 08:10:01.000000000 +0100
2
 
+++ ../trunk/pytz/__init__.py   2010-01-27 18:34:17.000000000 +0100
3
 
@@ -50,17 +50,12 @@
 
1
Index: python-tz/pytz/__init__.py
 
2
===================================================================
 
3
--- python-tz.orig/pytz/__init__.py
 
4
+++ python-tz/pytz/__init__.py
 
5
@@ -28,11 +28,6 @@ __all__ = [
 
6
 import sys, datetime, os.path, gettext
 
7
 from UserDict import DictMixin
 
8
 
 
9
-try:
 
10
-    from pkg_resources import resource_stream
 
11
-except ImportError:
 
12
-    resource_stream = None
 
13
-
 
14
 from tzinfo import AmbiguousTimeError, InvalidTimeError, NonExistentTimeError
 
15
 from tzinfo import unpickler
 
16
 from tzfile import build_tzinfo
 
17
@@ -50,17 +45,12 @@ def open_resource(name):
4
18
     Uses the pkg_resources module if available and no standard file
5
19
     found at the calculated location.
6
20
     """
7
 
+    # Patched in Debian, use the system zoninfo from the tzdata package
 
21
+    # Patched in Debian, use the system zoneinfo from the tzdata package
8
22
     name_parts = name.lstrip('/').split('/')
9
23
     for part in name_parts:
10
24
         if part == os.path.pardir or os.path.sep in part: