~allison/ubuntu/precise/gpsdrive/fix-ftbfs-mapnik

« back to all changes in this revision

Viewing changes to debian/patches/106-add-boost-links.dpatch

  • Committer: Stefano Rivera
  • Date: 2011-07-05 12:50:16 UTC
  • mfrom: (20.1.2 gpsdrive)
  • Revision ID: stefano@rivera.za.net-20110705125016-g730rzxqnv31kb1w
Tags: 2.10~pre4-6.dfsg-5ubuntu2
* debian/patches/105-fix-xcursor-check.dpatch: (Closes: #615653)
  configure.ac searched in fontconfig for a symbol defined in Xcursor
* debian/patches/106-add-boost-links.dpatch: (LP: #749273)
  link against boost-filesystem and boost-system

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## Description: requires direct link against boost {file,}system
 
3
## Origin/Author: Julian Taylor <jtaylor.debian@googlemail.com>
 
4
## Bug: https://bugs.launchpad.net/ubuntu/+source/gpsdrive/+bug/749273
 
5
## 105-add-boost-links.dpatch by Julian Taylor <jtaylor.debian@googlemail.com>
 
6
##
 
7
## All lines beginning with `## DP:' are a description of the patch.
 
8
## DP: No description.
 
9
 
 
10
@DPATCH@
 
11
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' gpsdrive~/src/Makefile.am gpsdrive/src/Makefile.am
 
12
--- gpsdrive~/src/Makefile.am   2011-07-05 13:59:11.000000000 +0200
 
13
+++ gpsdrive/src/Makefile.am    2011-07-05 14:02:23.341707820 +0200
 
14
@@ -42,7 +42,7 @@
 
15
 INCLUDES = $(DBUS_CFLAGS) -DDBUS_API_SUBJECT_TO_CHANGE=1
 
16
 endif
 
17
 
 
18
-gpsdrive_LDADD=@LIBS@ $(LIBADD_DL) 
 
19
+gpsdrive_LDADD=@LIBS@ $(LIBADD_DL) -lboost_filesystem -lboost_system
 
20
 
 
21
 PRGS =         gpsdrive.c splash.c splash.h gpsdrive_config.c gpsdrive_config.h \
 
22
        navigation.c \