~attente/rhythmbox/rhythmbox

« back to all changes in this revision

Viewing changes to debian/patches/dont_free_consumed_floating_gvariant.patch

  • Committer: Jeremy Bicha
  • Date: 2012-11-07 01:52:30 UTC
  • Revision ID: jbicha@ubuntu.com-20121107015230-trp2j7b9udunr9ep
* New upstream release (LP: #1060601)
* debian/control.in:
  - Bump minimum glib, gtk, totem-plparser, clutter, and clutter-gst
  - Drop no longer needed musicbrainz dependency
* Refreshed 09_keywords.patch
* Updated 11_fix_cd_pausing.patch with fix from git
* Dropped patches applied in new version:
  - 00git_musicbrainz5.patch
  - 08_CVE-2012-3355.patch
  - dont_free_consumed_floating_gvariant.patch
  - git_scale_click.patch
  - git_crash_during_monitor.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 0178a4fedac8e252fa4dd45012e9da0284fb2a76 Mon Sep 17 00:00:00 2001
2
 
From: Ryan Lortie <desrt@desrt.ca>
3
 
Date: Mon, 30 Jul 2012 17:07:59 +0200
4
 
Subject: [PATCH] preferences: don't free consumed floating GVariant
5
 
 
6
 
g_variant_builder_end() returns a floating reference and
7
 
g_settings_set_value() consumes it, so we should not unref it again.
8
 
 
9
 
https://bugzilla.gnome.org/show_bug.cgi?id=680842
10
 
---
11
 
 shell/rb-shell-preferences.c |    1 -
12
 
 1 file changed, 1 deletion(-)
13
 
 
14
 
Index: b/shell/rb-shell-preferences.c
15
 
===================================================================
16
 
--- a/shell/rb-shell-preferences.c
17
 
+++ b/shell/rb-shell-preferences.c
18
 
@@ -474,7 +474,6 @@
19
 
 
20
 
        g_settings_set_value (preferences->priv->source_settings, "visible-columns", v);
21
 
 
22
 
-       g_variant_unref (v);
23
 
        g_variant_builder_unref (b);
24
 
 }
25