~awstools-dev/ubuntu/quantal/iamcli/quantal

« back to all changes in this revision

Viewing changes to debian/patches/add-makefile.patch

  • Committer: Scott Moser
  • Date: 2011-11-29 03:33:55 UTC
  • Revision ID: smoser@ubuntu.com-20111129033355-1ce3bg99ibcw1ths
update make clean

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
--- /dev/null
2
2
+++ b/Makefile
3
 
@@ -0,0 +1,57 @@
 
3
@@ -0,0 +1,60 @@
4
4
+NAME = iamcli
5
5
+libdir = /usr/lib/$(NAME)
6
6
+LIBDIR = $(DESTDIR)$(libdir)
57
57
+
58
58
+clean:
59
59
+       cd "$(BINDIR)" && rm -f $(binprogs) || :
60
 
+       cd "$(LIBDIR)" && rm -Rf $(libdirs) || :
 
60
+       cd "$(LIBDIR)" && set -e && for j in $(binjars); do \
 
61
+         [ -f "$${j}" ] || continue; \
 
62
+         rm -f "$${j}" && \
 
63
+         { rmdir "$${j%/*}" || :; }; done