~bilalakhtar/ubuntu/maverick/gpsdrive/gpsdrive-fix-325288

« back to all changes in this revision

Viewing changes to debian/patches/99-autobestmap.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Andreas Putzo
  • Date: 2008-08-31 17:40:05 UTC
  • mfrom: (1.1.3 upstream) (3.1.2 lenny)
  • Revision ID: james.westby@ubuntu.com-20080831174005-0lobl48wa8zognfh
Tags: 2.10~pre4-6.dfsg-1
* Added .dfsg to version to allow a sourceful upload
  that really removes files with unknown or incompatible
  licenses (gpsfetchmap.pl, map-icons/japan, map-icons/nickw) 
  from the upstream tarball, generated using the get-orig-source
  target in debian/rules. (Closes: #497115)
* Fixed spelling error in short description of the gpsdrive-data package.
  (Closes: #494657)
* Added patch 100-fix-insecure-tempfiles.dpatch that uses mktemp 
  in geo-code to avoid symlink attacks. Thanks Moritz Muehlenhoff for
  the patch. (Closes: #496436)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 99-autobestmap.dpatch by Andreas Putzo <andreas@putzo.net>
 
3
##
 
4
## DP: The autobestmap config option is not updated when using the toggle button
 
5
## DP: in gpsdrive. Patch backported from 2.10pre5.
 
6
 
 
7
@DPATCH@
 
8
diff -urNad gpsdrive-2.10~pre4~/src/main_gui.c gpsdrive-2.10~pre4/src/main_gui.c
 
9
--- gpsdrive-2.10~pre4~/src/main_gui.c  2007-09-15 15:12:03.000000000 +0000
 
10
+++ gpsdrive-2.10~pre4/src/main_gui.c   2008-07-15 19:48:34.000000000 +0000
 
11
@@ -229,6 +229,7 @@
 
12
                gtk_label_set_text (GTK_LABEL (statusprefscale_lb), _("Auto"));
 
13
                if (mapscaler_scaler)
 
14
                        gtk_widget_set_sensitive (mapscaler_scaler, FALSE);
 
15
+        local_config.autobestmap = TRUE;
 
16
        }
 
17
        else
 
18
        {
 
19
@@ -238,6 +239,7 @@
 
20
                gtk_label_set_text (GTK_LABEL (statusprefscale_lb), sc);
 
21
                if (mapscaler_scaler)
 
22
                        gtk_widget_set_sensitive (mapscaler_scaler, TRUE);
 
23
+        local_config.autobestmap = FALSE;
 
24
        }
 
25
 
 
26
        current.needtosave = TRUE;