~bmillemathias/ubuntu/maverick/evolution-data-server/main

« back to all changes in this revision

Viewing changes to debian/patches/91_revert_formatted_adress.patch

  • Committer: Didier Roche
  • Date: 2010-08-31 09:26:04 UTC
  • Revision ID: didier.roche@canonical.com-20100831092604-370l7h5fzzbls55q
* Merge from debian unstable. Remaining changes:
  + debian/control:
    - add Vcs-Bzr tag
    - don't use libgnome
  + debian/evolution-data-server.install,
    debian/patches/45_libcamel_providers_version.patch:
    - use the upstream versioning, not a Debian-specific one
  + debian/rules:
    - don't build documentation it's shipped with the tarball
* use dh_autoreconf now, as in debian (it's in main now)
  - remove debian/patches/90_autoreconf.patch
  - change debian/rules to include it
  - build-dep in debian/control
* disable large file support, like in debian, which causes crashes
  (LP: #584536)
* 91_revert_formatted_adress.patch: removed, upstream
* New upstream bugfix release.
* debian/patches:
  - 01_make-nss-db-init-more-robust dropped, included upstream
  - 02_remove-courier-imap-workaround-breaking-rename as well.
* debian/control:
  - update standards version to 3.9.1.
* debian/*.shlibs:
  - bump shlibs to 2.30.3.
* New upstream bugfix release.
* debian/patches:
  - 01_make-nss-db-init-more-robust added.                    closes: #587849
  - 02_remove-courier-imap-workaround-breaking-rename added, fix renaming on
    courier-imap servers.
* debian/rules:
  - rename --enable-nss to -enable-ssl in configure call.
  - DEB_FIXPERMS_EXCLUDE switched to _evolution-data-server.
  - disable largefile support for now, it'll be re-enabled for squeeze+1
    cycle.                                                    closes: #588316
* debian/control:
  - update standards version to 3.9.0.
* New upstream release.
  - fix random mailbox corruption causing expunge problems.   closes: #526216
* debian/watch:
  - update rule to order hrefs correctly.
  - install some information on bug reporting
* debian/bug-presubj: warn user that she should report upstream issues
  directly to upstream bugzilla because of lack of time and manpower.
* debian/patches:
  - 01_unitialized_key, 02_fix-warning-in_source_get_uri,
    03_bump-soname-libedataserver dropped, included upstream.
  - 25_mute-debug-messages updated.
  - 45_libcamel_providers_version refreshed.
* debian/libcamel1.2-14.shlibs updated for 2.30.2.
* debian/control:
  - bump debhelper build-dep to 7.2.3 for dh_bugfiles.
  - add build-dep on gnome-pkg-tools for gnome-get-source.mk.
* Switch to 3.0 (quilt) format.
* debian/rules:
  - include gnome-get-source.mk.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From a9d0d64ab9aa61855fce0537b90fc05924bc3d85 Mon Sep 17 00:00:00 2001
2
 
From: Matthew Barnes <mbarnes@redhat.com>
3
 
Date: Mon, 21 Jun 2010 11:28:22 +0000
4
 
Subject: Revert "Bug 619347 - Return formatted address in e_destination_get_address"
5
 
 
6
 
This reverts commit db8c986c4f06f0cb57de9bfa6982b4e78f0bb32a.
7
 
 
8
 
Despite the misleading documentation, e_destination_get_address() -is-
9
 
intended to return an encoded address suitable for use in mail headers.
10
 
e_destination_get_textrep() exists for displaying destination addresses
11
 
to the user.  The Contact List Editor is apparently calling the wrong
12
 
function.
13
 
---
14
 
diff --git a/addressbook/libebook/e-destination.c b/addressbook/libebook/e-destination.c
15
 
index 00b7e76..6ed9870 100644
16
 
--- a/addressbook/libebook/e-destination.c
17
 
+++ b/addressbook/libebook/e-destination.c
18
 
@@ -881,11 +881,11 @@ e_destination_get_address (const EDestination *dest)
19
 
                                iter = g_list_next (iter);
20
 
                        }
21
 
 
22
 
-                       priv->addr = camel_address_format (CAMEL_ADDRESS (addr));
23
 
+                       priv->addr = camel_address_encode (CAMEL_ADDRESS (addr));
24
 
                } else if (priv->raw) {
25
 
 
26
 
                        if (camel_address_unformat (CAMEL_ADDRESS (addr), priv->raw)) {
27
 
-                               priv->addr = camel_address_format (CAMEL_ADDRESS (addr));
28
 
+                               priv->addr = camel_address_encode (CAMEL_ADDRESS (addr));
29
 
                        }
30
 
                } else {
31
 
                        const gchar *name, *email;
32
 
@@ -900,7 +900,7 @@ e_destination_get_address (const EDestination *dest)
33
 
                                nothing we can do here */
34
 
                                camel_address_decode (CAMEL_ADDRESS (addr), name);
35
 
 
36
 
-                       priv->addr = camel_address_format (CAMEL_ADDRESS (addr));
37
 
+                       priv->addr = camel_address_encode (CAMEL_ADDRESS (addr));
38
 
                }
39
 
 
40
 
                camel_object_unref (CAMEL_OBJECT (addr));
41
 
--
42
 
cgit v0.8.3.1