~britco/nginx/master

« back to all changes in this revision

Viewing changes to debian/patches/nginx-html5-codecs.diff

  • Committer: Bazaar Package Importer
  • Author(s): Kartik Mistry, Kartik Mistry, Michael Lustfield
  • Date: 2010-12-06 11:26:22 UTC
  • mfrom: (4.2.25 sid)
  • Revision ID: james.westby@ubuntu.com-20101206112622-fisk23hssb3e5bdh
Tags: 0.8.53-2
[Kartik Mistry]
* debian/conf/mime.types:
  + Added html5 codecs support (Closes: #605212)
* debian/conf/fastcgi_params:
  + Fixed typo (Closes: #605582)

[Michael Lustfield]
* debian/conf/nginx.conf:
  + Reduced worker_connections to 768 (Closes: #605529)
* Add an nginx site management script to nginx-doc. (Closes: #593580)
  + debian/help/examples/nginx_modsite: Added.
* debian/nginx.logrotate:
  + Added prerotate chunk for awstats. (Closes: #590098)
* debian/copyright:
  + Added Michael Lustfield
* Created nginx-doc:
  + Added 'Package: nginx-doc' section to debian/control
  + Moved debian/nginx.examples -> debian/nginx-doc.examples
  + Moved debian/nginx.docs -> debian/nginx-doc.docs

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Add html5 codecs support
2
 
Author: Bhavani Shankar <bhavi@ubuntu.com>
3
 
Bug-Ubuntu: https://bugs.launchpad.net/bugs/674224
4
 
Bug-Debian: http://bugs.debian.org/605212
5
 
 
6
 
--- nginx-0.8.53.orig/conf/mime.types
7
 
+++ nginx-0.8.53/conf/mime.types
8
 
@@ -51,6 +51,7 @@ types {
9
 
     application/x-x509-ca-cert            der pem crt;
10
 
     application/x-xpinstall               xpi;
11
 
     application/zip                       zip;
12
 
+    application/ogg                       ogx;
13
 
 
14
 
     application/octet-stream              bin exe dll;
15
 
     application/octet-stream              deb;
16
 
@@ -62,6 +63,9 @@ types {
17
 
     audio/midi                            mid midi kar;
18
 
     audio/mpeg                            mp3;
19
 
     audio/x-realaudio                     ra;
20
 
+    audio/ogg                             oga ogg spx;
21
 
+    audio/webm                            weba;
22
 
+    audio/mpeg                            m4a;
23
 
 
24
 
     video/3gpp                            3gpp 3gp;
25
 
     video/mpeg                            mpeg mpg;
26
 
@@ -71,4 +75,7 @@ types {
27
 
     video/x-ms-asf                        asx asf;
28
 
     video/x-ms-wmv                        wmv;
29
 
     video/x-msvideo                       avi;
30
 
+    video/ogg                             ogv;
31
 
+    video/webm                            webm;
32
 
+    video/mp4                             mp4;
33
 
 }