~bryce/xchat-gnome/cherrypicks

« back to all changes in this revision

Viewing changes to debian/patches/02_lpi.patch

  • Committer: Mathieu Trudel-Lapierre
  • Date: 2011-07-05 16:27:43 UTC
  • Revision ID: mathieu-tl@ubuntu.com-20110705162743-24567uyy50uf36yr
* Merge with Debian unstable, remaining changes: (LP: #773847)
  - debian/control:
    - add Build-Depends on liblaunchpad-integration-dev.
    - xchat-gnome Suggests: xchat-gnome-indicator.
  - debian/patches/02_lpi.patch: add Launchpad integration items to the help
    menu
  - debian/patches/10_xchat-gnome-close-event.patch: add events for window
    close.
  - debian/patches/04_autojoin_ubuntu_chan.patch: add the Ubuntu network
    as default selection and default to autojoining #ubuntu.
  - debian/patches/20_add_gui_focus.patch: implement GUI focus from XChat.
  - debian/patches/51_freenode_default_port_8001.patch: Drop ports 666x
    for FreeNode to workaround a possible DCC exploit.
  - debian/patches/95_apturl-support.patch: support apt://-urls.
  - debian/watch: also look for unstable versions
  - debian/xchat-gnome.gconf-defaults: Set the default enabled plugins,
    indicator, netmonitor, and notifyosd.
* debian/patches/52_no_zero_width_pixmaps.patch: dropped, applied upstream.
* debian/patches/98_ice_depends_for_eggsmclient.patch: replaced by
  01_link_libice.patch.
* debian/control: remove duplicate entry in Build-Depends for intltool.
* debian/xchat-gnome.install: also install the xchat-gnome.desktop file from
  /usr/share/applications in xchat-gnome rather than xchat-gnome-common.
  (LP: #374686)
* debian/rules: update the xchat-gnome-common binary-install target to not
  keep a duplicate copy of the xchat-gnome.desktop file.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: xchat-gnome-0.26.1/configure.ac
 
1
Index: xchat-gnome.ubuntu/configure.ac
2
2
===================================================================
3
 
--- xchat-gnome-0.26.1.orig/configure.ac        2010-12-17 15:18:38.000000000 +1100
4
 
+++ xchat-gnome-0.26.1/configure.ac     2010-12-17 15:42:33.207712001 +1100
5
 
@@ -63,6 +63,7 @@
 
3
--- xchat-gnome.ubuntu.orig/configure.ac        2011-07-05 10:28:17.000000000 -0400
 
4
+++ xchat-gnome.ubuntu/configure.ac     2011-07-05 10:29:16.915707223 -0400
 
5
@@ -64,6 +64,7 @@
6
6
                   glib-2.0 >= $GLIB_REQUIRED \
7
7
                  gio-2.0 >= $GLIB_REQUIRED \
8
8
                   gtk+-2.0 >= $GTK_REQUIRED \
9
9
+                  launchpad-integration \
10
 
                   libglade-2.0 >= $LIBGLADE_REQUIRED \
11
10
                   gconf-2.0 >= $GCONF_REQUIRED \
12
11
                  libsexy >= $LIBSEXY_REQUIRED \
13
 
Index: xchat-gnome-0.26.1/data/xchat-gnome-ui.xml
 
12
                   ])
 
13
Index: xchat-gnome.ubuntu/data/xchat-gnome-ui.xml
14
14
===================================================================
15
 
--- xchat-gnome-0.26.1.orig/data/xchat-gnome-ui.xml     2010-12-17 15:18:38.000000000 +1100
16
 
+++ xchat-gnome-0.26.1/data/xchat-gnome-ui.xml  2010-12-17 15:42:33.207712001 +1100
 
15
--- xchat-gnome.ubuntu.orig/data/xchat-gnome-ui.xml     2011-07-05 10:05:48.000000000 -0400
 
16
+++ xchat-gnome.ubuntu/data/xchat-gnome-ui.xml  2011-07-05 10:28:38.035707499 -0400
17
17
@@ -53,6 +53,7 @@
18
18
 
19
19
                <menu name="HelpMenu" action="Help">
22
22
                        <menuitem name="HelpAbout" action="HelpAbout"/>
23
23
                </menu>
24
24
 
25
 
Index: xchat-gnome-0.26.1/src/fe-gnome/main-window.c
 
25
Index: xchat-gnome.ubuntu/src/fe-gnome/main-window.c
26
26
===================================================================
27
 
--- xchat-gnome-0.26.1.orig/src/fe-gnome/main-window.c  2010-12-17 15:18:38.000000000 +1100
28
 
+++ xchat-gnome-0.26.1/src/fe-gnome/main-window.c       2010-12-17 15:42:33.207712001 +1100
 
27
--- xchat-gnome.ubuntu.orig/src/fe-gnome/main-window.c  2011-07-05 10:06:25.000000000 -0400
 
28
+++ xchat-gnome.ubuntu/src/fe-gnome/main-window.c       2011-07-05 10:31:39.155706212 -0400
29
29
@@ -28,6 +28,7 @@
30
30
 #include <sys/types.h>
31
31
 #include <sys/stat.h>
34
34
 
35
35
 #include "about.h"
36
36
 #include "channel-list-window.h"
37
 
@@ -186,6 +187,8 @@
38
 
        /* hook up accelerators */
39
 
        gtk_window_add_accel_group (GTK_WINDOW (gui.main_window), gtk_ui_manager_get_accel_group (gui.manager));
 
37
@@ -174,6 +175,8 @@
 
38
 
 
39
        gtk_ui_manager_insert_action_group (gui.manager, gui.action_group, 0);
40
40
 
41
41
+       launchpad_integration_add_ui (gui.manager, "/ui/menubar/HelpMenu/LaunchpadItems");
42
42
+
43
 
        close = glade_xml_get_widget (gui.xml, "close discussion");
44
 
        action = gtk_action_group_get_action (gui.action_group, "DiscussionClose");
45
 
 #if GTK_CHECK_VERSION (2, 16, 0)
 
43
        menu_vbox = GTK_WIDGET (gtk_builder_get_object (gui.xml, "menu_vbox"));
 
44
        g_signal_connect (gui.manager, "add-widget", G_CALLBACK (on_add_widget), menu_vbox);
 
45