~chromium-team/chromium-browser/artful-beta

« back to all changes in this revision

Viewing changes to debian/patches/use-clang-versioned.patch

  • Committer: Olivier Tilloy
  • Date: 2017-10-17 19:50:56 UTC
  • Revision ID: olivier.tilloy@canonical.com-20171017195056-tyrtx2ltrv20v3xc
* debian/control: build against clang 5.0
* debian/patches/suppress-newer-clang-warning-flags.patch: added
* debian/patches/use-clang-versioned.patch: added

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Version paths to clang executables on artful, where the default is 4.0
 
2
Author: Olivier Tilloy <olivier.tilloy@canonical.com>
 
3
 
 
4
--- a/build/toolchain/gcc_toolchain.gni
 
5
+++ b/build/toolchain/gcc_toolchain.gni
 
6
@@ -585,11 +585,11 @@ template("clang_toolchain") {
 
7
 
 
8
   gcc_toolchain(target_name) {
 
9
     prefix = rebase_path("$clang_base_path/bin", root_build_dir)
 
10
-    cc = "$prefix/clang"
 
11
-    cxx = "$prefix/clang++"
 
12
+    cc = "$prefix/clang-5.0"
 
13
+    cxx = "$prefix/clang++-5.0"
 
14
     ld = cxx
 
15
     readelf = "${toolprefix}readelf"
 
16
-    ar = "${prefix}/llvm-ar"
 
17
+    ar = "${prefix}/llvm-ar-5.0"
 
18
     nm = "${toolprefix}nm"
 
19
 
 
20
     forward_variables_from(invoker,