~chromium-team/chromium-browser/chromium-browser.natty

« back to all changes in this revision

Viewing changes to debian/patches/webkit_rev_parser.patch

  • Committer: Micah Gersten
  • Date: 2011-10-27 05:50:16 UTC
  • Revision ID: micahg@ubuntu.com-20111027055016-v22p88na915d7ybn
Merge from chromium-browser.lucid #637
* New upstream release from the Stable Channel (LP: #881786)
  This release fixes the following security issues:
  - [86758] High CVE-2011-2845: URL bar spoof in history handling. Credit to 
    Jordi Chancel.
  - [88949] Medium CVE-2011-3875: URL bar spoof with drag+drop of URLs. Credit
    to Jordi Chancel.
  - [90217] Low CVE-2011-3876: Avoid stripping whitespace at the end of
    download filenames. Credit to Marc Novak.
  - [91218] Low CVE-2011-3877: XSS in appcache internals page. Credit to
    Google Chrome Security Team (Tom Sepez) plus independent discovery by
    Juho Nurminen.
  - [94487] Medium CVE-2011-3878: Race condition in worker process
    initialization. Credit to miaubiz.
  - [95374] Low CVE-2011-3879: Avoid redirect to chrome scheme URIs. Credit to
    Masato Kinugawa.
  - [95992] Low CVE-2011-3880: Don’t permit as a HTTP header delimiter. Credit
    to Vladimir Vorontsov, ONsec company.
  - [96047] [96885] [98053] [99512] [99750] High CVE-2011-3881: Cross-origin
    policy violations. Credit to Sergey Glazunov.
  - [96292] High CVE-2011-3882: Use-after-free in media buffer handling.
    Credit to Google Chrome Security Team (Inferno).
  - [96902] High CVE-2011-3883: Use-after-free in counter handling. Credit to
    miaubiz.
  - [97148] High CVE-2011-3884: Timing issues in DOM traversal. Credit to
    Brian Ryner of the Chromium development community.
  - [97599] [98064] [98556] [99294] [99880] [100059] High CVE-2011-3885: Stale
    style bugs leading to use-after-free. Credit to miaubiz.
  - [98773] [99167] High CVE-2011-3886: Out of bounds writes in v8. Credit to
    Christian Holler.
  - [98407] Medium CVE-2011-3887: Cookie theft with javascript URIs. Credit to
    Sergey Glazunov.
  - [99138] High CVE-2011-3888: Use-after-free with plug-in and editing.
    Credit to miaubiz.
  - [99211] High CVE-2011-3889: Heap overflow in Web Audio. Credit to miaubiz.
  - [99553] High CVE-2011-3890: Use-after-free in video source handling.
    Credit to Ami Fischman of the Chromium development community.
  - [100332] High CVE-2011-3891: Exposure of internal v8 functions. Credit to
    Steven Keuchel of the Chromium development community plus independent
    discovery by Daniel Divricean.
* Refresh patches
  - update debian/patches/dlopen_sonamed_gl.patch
  - update debian/patches/webkit_rev_parser.patch
* Disable NaCl until we figure out what to do with the private toolchain
  - update debian/rules
* Do not install the pseudo_locales files in the debs
  - update debian/rules
* Add python-simplejson to Build-depends. This is needed by NaCl even with
  NaCl disabled, so this is a temporary workaround to unbreak the build, it 
  must be fixed upstream
  - update debian/control

Show diffs side-by-side

added added

removed removed

Lines of Context:
4
4
 
5
5
Index: src/webkit/build/webkit_version.py
6
6
===================================================================
7
 
--- src.orig/webkit/build/webkit_version.py
8
 
+++ src/webkit/build/webkit_version.py
9
 
@@ -46,16 +46,25 @@
10
 
   # "svn info" tells us what we want, but third_party/WebKit does *not*
11
 
   # point at the upstream repo.  So instead we run svn info on the directory
12
 
   # containing the versioning file (which is some subdirectory of WebKit).
13
 
   version_file_dir = os.path.dirname(version_file)
14
 
   version_info = lastchange.FetchVersionInfo(
15
 
       default_lastchange=None,
16
 
       directory=os.path.join(webkit_dir, version_file_dir))
 
7
--- src.orig/webkit/build/webkit_version.py     2011-10-21 18:38:45.875141666 +0100
 
8
+++ src/webkit/build/webkit_version.py  2011-10-21 18:39:12.591141191 +0100
 
9
@@ -61,6 +61,15 @@
 
10
       directory=os.path.join(webkit_dir, version_file_dir),
 
11
       directory_regex_prior_to_src_url='webkit')
17
12
 
18
13
+  if version_info.url is None or version_info.url == 'unknown':
19
14
+    # parse the DEPS file
24
19
+    branch = os.path.basename(x.group(1)) if x else "n-a"
25
20
+    return "%s@%s" % (branch, rev)
26
21
+
27
 
   if (version_info.url.startswith(version_info.root) and
28
 
       version_info.url.endswith(version_file_dir)):
29
 
     # Now compute the real WebKit URL by stripping off the version file
30
 
     # directory from the URL we get out of version_info.
31
 
     # Further, we want to strip off the "http://svn..." from the left.
32
 
     # This is the root URL from the repository.
33
 
     webkit_url = version_info.url[len(version_info.root):-len(version_file_dir)]
34
 
     webkit_url = webkit_url.strip('/')
 
22
   if version_info.url == None:
 
23
     version_info.url = 'Unknown URL'
 
24
   version_info.url = version_info.url.strip('/')