~clint-fewbar/ubuntu/natty/php5/merge-5.3.3-3

« back to all changes in this revision

Viewing changes to debian/patches/use_embedded_timezonedb.patch

  • Committer: Bazaar Package Importer
  • Author(s): Chuck Short
  • Date: 2010-01-26 14:09:58 UTC
  • mfrom: (1.1.16 upstream) (0.3.6 sid)
  • Revision ID: james.westby@ubuntu.com-20100126140958-sos69zwa00q2nt19
Tags: 5.2.12.dfsg.1-2ubuntu1
* Merge from debian testing.  Remaining changes:
  - debian/control, debian/rules: Disable a few build dependencies and
    accompanying binary packages which we do not want to support in main:
    + firebird2-dev/php5-interbase (we have a seperate php-interbase source)
    + libc-client/php5-imap (we have a seperate php-imap source)
    + libmcrypt-dev/php5-mcrypt (seperate php-mcrypt source)
    + readline support again, now that the libedit issue is fixed.
  - debian/control: Add build dependency: libedit-dev (>= 2.9.cvs.20050518-1)
    CLI readline support.
  - debian/rules:
    + Correctly mangle PHP5_* macros for lpia
  - debian/control:
    + Rename Vcs-Browser & Vcs-Git to XS-Original-Vcs-Browser & XS-Original-Vcs-Git (LP: #323731).
  - debian/control: Move php5-suhoshin to Suggests.
  - debian/rules: Fix broken symlink for pear.
  - main/php_version.h: updated with Ubuntu version info
  - debian/patches/series: Re-enable the 033-we_WANT_libtool.patch patch
  - debian/rules, debian/source_php5.py: Install apport hook. 
* Dropped patches: CVE-2009-3557.patch and CVE-2009-3558.patch, no longer needed.

Show diffs side-by-side

added added

removed removed

Lines of Context:
8
8
r2: add filesystem trawl to set up name alias index
9
9
r1: initial revision
10
10
 
11
 
--- php.orig/ext/date/lib/parse_tz.c
12
 
+++ php/ext/date/lib/parse_tz.c
 
11
--- a/ext/date/lib/parse_tz.c
 
12
+++ b/ext/date/lib/parse_tz.c
13
13
@@ -24,6 +24,16 @@
14
14
 
15
15
 #include "timelib.h"
258
258
 
259
259
 static ttinfo* fetch_timezone_offset(timelib_tzinfo *tz, timelib_sll ts, timelib_sll *transition_time)
260
260
 {
261
 
--- php.orig/ext/date/lib/timelib.h
262
 
+++ php/ext/date/lib/timelib.h
 
261
--- a/ext/date/lib/timelib.h
 
262
+++ b/ext/date/lib/timelib.h
263
263
@@ -32,6 +32,10 @@
264
264
 
265
265
 #define TIMELIB_SPECIAL_WEEKDAY  0x01
271
271
 #ifndef LONG_MAX
272
272
 #define LONG_MAX 2147483647L
273
273
 #endif
274
 
--- php.orig/ext/date/lib/timelib.m4
275
 
+++ php/ext/date/lib/timelib.m4
 
274
--- a/ext/date/lib/timelib.m4
 
275
+++ b/ext/date/lib/timelib.m4
276
276
@@ -78,3 +78,17 @@ stdlib.h
277
277
 
278
278
 dnl Check for strtoll, atoll
291
291
+   fi
292
292
+fi
293
293
+
294
 
--- php.orig/ext/date/php_date.c
295
 
+++ php/ext/date/php_date.c
296
 
@@ -599,6 +599,11 @@ static char* guess_timezone(const timeli
297
 
        if (DATEG(default_timezone) && (strlen(DATEG(default_timezone)) > 0) && timelib_timezone_id_is_valid(DATEG(default_timezone), tzdb)) {
 
294
--- a/ext/date/php_date.c
 
295
+++ b/ext/date/php_date.c
 
296
@@ -608,6 +608,11 @@ static char* guess_timezone(const timeli
 
297
        } else if (*DATEG(default_timezone) && timelib_timezone_id_is_valid(DATEG(default_timezone), tzdb)) {
298
298
                return DATEG(default_timezone);
299
299
        }
300
300
+#ifdef TIMELIB_SYSTEM_TZID