~clint-fewbar/ubuntu/precise/php5/php5-5.4-merge

« back to all changes in this revision

Viewing changes to debian/patches/bug53323.patch

  • Committer: Package Import Robot
  • Author(s): Chuck Short
  • Date: 2011-02-22 09:46:37 UTC
  • mfrom: (1.1.20) (0.3.18 sid)
  • Revision ID: package-import@ubuntu.com-20110222094637-nlu2tvb7oqgaarl0
Tags: 5.3.5-1ubuntu1
* Merge from debian/unstable. Remaining changes:
 - debian/control:
    * Dropped firebird2.1-dev, libc-client-dev, libmcrypt-dev as it is in universe.
    * Dropped libmysqlclient15-dev, build against mysql 5.1.
    * Dropped libcurl-dev not in the archive.
    * Suggest php5-suhosin rather than recommends.
    * Dropped php5-imap, php5-interbase, php5-mcrypt since we have versions 
      already in universe.
    * Dropped libonig-dev and libqgdbm since its in universe. (will be re-added in lucid+1)
    * Dropped locales-all.
  - modulelist: Drop imap, interbase, sybase, and mcrypt.
  - debian/rules:
    * Dropped building of mcrypt, imap, and interbase.
    * Install apport hook for php5.
    * stop mysql instance on clean just in case we failed in tests

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- a/ext/pdo_firebird/firebird_driver.c
2
 
+++ b/ext/pdo_firebird/firebird_driver.c
3
 
@@ -547,7 +547,7 @@ static int firebird_handle_get_attribute
4
 
        pdo_firebird_db_handle *H = (pdo_firebird_db_handle *)dbh->driver_data;
5
 
 
6
 
        switch (attr) {
7
 
-               char tmp[200];
8
 
+               char tmp[512];
9
 
                
10
 
                case PDO_ATTR_AUTOCOMMIT:
11
 
                        ZVAL_LONG(val,dbh->auto_commit);
12
 
@@ -590,6 +590,10 @@ static int firebird_handle_get_attribute
13
 
                                ZVAL_STRING(val,tmp,1);
14
 
                                return 1;
15
 
                        }
16
 
+                       
17
 
+               case PDO_ATTR_FETCH_TABLE_NAMES:
18
 
+                       ZVAL_BOOL(val, H->fetch_table_names);
19
 
+                       return 1;
20
 
        }
21
 
        return 0;
22
 
 }