~cmiller/ubuntu/trusty/icewm/translations-cause-crash-lp447883

« back to all changes in this revision

Viewing changes to debian/patches/package_build_fixes

  • Committer: Package Import Robot
  • Author(s): Eduard Bloch
  • Date: 2013-06-29 17:59:17 UTC
  • mfrom: (14.1.4 sid)
  • Revision ID: package-import@ubuntu.com-20130629175917-6bv5fgibwzfz8ke8
Tags: 1.3.7-5
* Fixing linking arguments (libm also for Gnome parts, closes: #713632)
* Using hardening flags now, working around null pointer dereferencing in
  option parsers

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Index: icewm-1.3.7/configure
2
2
===================================================================
3
 
--- icewm-1.3.7.orig/configure  2010-10-31 15:09:40.000000000 +0100
4
 
+++ icewm-1.3.7/configure       2012-03-03 21:06:42.411282246 +0100
 
3
--- icewm-1.3.7.orig/configure  2013-06-28 18:46:58.952863752 +0200
 
4
+++ icewm-1.3.7/configure       2013-06-28 18:46:58.940864492 +0200
5
5
@@ -5958,7 +5958,7 @@
6
6
 
7
7
 
17
17
        GNOME_VER=2
18
18
-       GNOME2_CFLAGS=`pkg-config --cflags gnome-desktop-2.0 libgnomeui-2.0`
19
19
-       GNOME2_LIBS=`pkg-config --libs gnome-desktop-2.0 libgnomeui-2.0`
20
 
+  GNOME2_CFLAGS=`pkg-config --cflags gnome-desktop-2.0 gnome-vfs-2.0 libgnomeui-2.0 fontconfig`
21
 
+       GNOME2_LIBS=`pkg-config --libs gnome-desktop-2.0 gnome-vfs-2.0 libgnomeui-2.0 fontconfig`
 
20
+  GNOME2_CFLAGS="`pkg-config --cflags gnome-desktop-2.0 gnome-vfs-2.0 libgnomeui-2.0 fontconfig`"
 
21
+       GNOME2_LIBS="`pkg-config --libs gnome-desktop-2.0 gnome-vfs-2.0 libgnomeui-2.0 fontconfig` -lm"
22
22
+
23
23
 
24
24
 
46
46
 
47
47
Index: icewm-1.3.7/configure.in
48
48
===================================================================
49
 
--- icewm-1.3.7.orig/configure.in       2010-10-31 15:09:37.000000000 +0100
50
 
+++ icewm-1.3.7/configure.in    2012-03-03 21:03:44.167498349 +0100
 
49
--- icewm-1.3.7.orig/configure.in       2013-06-28 18:46:58.952863752 +0200
 
50
+++ icewm-1.3.7/configure.in    2013-06-28 18:46:58.940864492 +0200
51
51
@@ -346,9 +346,9 @@
52
52
   AC_SUBST(MSGMERGE)
53
53
   AC_SUBST(MSGFMT)
67
67
-       GNOME2_CFLAGS=`pkg-config --cflags gnome-desktop-2.0 libgnomeui-2.0`
68
68
-       GNOME2_LIBS=`pkg-config --libs gnome-desktop-2.0 libgnomeui-2.0`
69
69
+  GNOME2_CFLAGS=`pkg-config --cflags gnome-desktop-2.0 gnome-vfs-2.0 libgnomeui-2.0 fontconfig`
70
 
+       GNOME2_LIBS=`pkg-config --libs gnome-desktop-2.0 gnome-vfs-2.0 libgnomeui-2.0 fontconfig`
 
70
+       GNOME2_LIBS=`pkg-config --libs gnome-desktop-2.0 gnome-vfs-2.0 libgnomeui-2.0 fontconfig` -lm
71
71
 
72
72
        AC_DEFINE(CONFIG_GNOME_MENUS, 1, [Define to make IceWM more GNOME-friendly])
73
73
 
93
93
 AC_SUBST(TARGETS_INSTALL)
94
94
Index: icewm-1.3.7/po/Makefile.in
95
95
===================================================================
96
 
--- icewm-1.3.7.orig/po/Makefile.in     2010-10-31 15:09:37.000000000 +0100
97
 
+++ icewm-1.3.7/po/Makefile.in  2012-03-03 17:45:57.000000000 +0100
 
96
--- icewm-1.3.7.orig/po/Makefile.in     2013-06-28 18:46:58.952863752 +0200
 
97
+++ icewm-1.3.7/po/Makefile.in  2013-06-28 18:46:58.940864492 +0200
98
98
@@ -20,6 +20,7 @@
99
99
 XGETTEXT =     @XGETTEXT@
100
100
 MSGMERGE =     @MSGMERGE@
105
105
 .SUFFIXES: .po .mo
106
106
Index: icewm-1.3.7/src/WinMgr.h
107
107
===================================================================
108
 
--- icewm-1.3.7.orig/src/WinMgr.h       2010-10-31 15:09:36.000000000 +0100
109
 
+++ icewm-1.3.7/src/WinMgr.h    2012-03-03 17:45:57.000000000 +0100
 
108
--- icewm-1.3.7.orig/src/WinMgr.h       2013-06-28 18:46:58.952863752 +0200
 
109
+++ icewm-1.3.7/src/WinMgr.h    2013-06-28 18:46:58.940864492 +0200
110
110
@@ -128,7 +128,7 @@
111
111
  * this where WIN_WORKSPACE_COUNT comes into play.
112
112
  */
118
118
 #define XA_WIN_WORKSPACES "_WIN_WORKSPACES"
119
119
Index: icewm-1.3.7/src/yfont.cc
120
120
===================================================================
121
 
--- icewm-1.3.7.orig/src/yfont.cc       2010-10-31 15:09:36.000000000 +0100
122
 
+++ icewm-1.3.7/src/yfont.cc    2012-03-03 17:45:57.000000000 +0100
 
121
--- icewm-1.3.7.orig/src/yfont.cc       2013-06-28 18:46:58.952863752 +0200
 
122
+++ icewm-1.3.7/src/yfont.cc    2013-06-28 18:46:58.940864492 +0200
123
123
@@ -12,7 +12,7 @@
124
124
 
125
125
 extern ref<YFont> getXftFont(ustring name, bool antialias);
142
142
 #endif
143
143
Index: icewm-1.3.7/src/yapp.cc
144
144
===================================================================
145
 
--- icewm-1.3.7.orig/src/yapp.cc        2010-10-31 15:09:36.000000000 +0100
146
 
+++ icewm-1.3.7/src/yapp.cc     2012-03-03 21:04:45.516686141 +0100
 
145
--- icewm-1.3.7.orig/src/yapp.cc        2013-06-28 18:46:58.952863752 +0200
 
146
+++ icewm-1.3.7/src/yapp.cc     2013-06-28 18:46:58.944864245 +0200
147
147
@@ -269,7 +269,7 @@
148
148
         }
149
149
 #endif
155
155
             gettimeofday(&curtime, 0);
156
156
Index: icewm-1.3.7/src/Makefile.in
157
157
===================================================================
158
 
--- icewm-1.3.7.orig/src/Makefile.in    2010-10-31 15:09:36.000000000 +0100
159
 
+++ icewm-1.3.7/src/Makefile.in 2012-03-03 21:04:47.192609085 +0100
160
 
@@ -35,9 +35,9 @@
161
 
                 -DICEHELPIDX='"$(DOCDIR)/icewm-$(VERSION)/icewm.html"'
 
158
--- icewm-1.3.7.orig/src/Makefile.in    2013-06-28 18:46:58.952863752 +0200
 
159
+++ icewm-1.3.7/src/Makefile.in 2013-06-28 18:46:58.944864245 +0200
 
160
@@ -11,7 +11,7 @@
 
161
 
 
162
 CXX =           @CXX@
 
163
 HOSTCXX =       @HOSTCXX@
 
164
-LD =            @CXX_LINK@
 
165
+LD =            gcc
 
166
 HOSTLD =        @HOSTCXX_LINK@
 
167
 EXEEXT =        @EXEEXT@
 
168
 
 
169
@@ -32,12 +32,12 @@
 
170
                 -DICEWMBGEXE='"icewmbg$(EXEEXT)"' \
 
171
                 -DICESMEXE='"icewm-session$(EXEEXT)"' \
 
172
                 -DICEHELPEXE='"icehelp$(EXEEXT)"' \
 
173
-                -DICEHELPIDX='"$(DOCDIR)/icewm-$(VERSION)/icewm.html"'
 
174
+                -DICEHELPIDX='"$(DOCDIR)/icewm-common/icewm.html"'
162
175
 
163
176
 CXXFLAGS =      @CXXFLAGS@ $(DEBUG) $(DEFS) `pkg-config gdk-pixbuf-xlib-2.0 --cflags` \
164
177
-               @CORE_CFLAGS@ @IMAGE_CFLAGS@ @AUDIO_CFLAGS@ # `fc-config --cflags`
165
178
+               @CORE_CFLAGS@ @IMAGE_CFLAGS@ @AUDIO_CFLAGS@ -I. # `fc-config --cflags`
166
179
 LFLAGS =       @LDFLAGS@ 
167
180
-LIBS =          @LIBS@ `pkg-config gdk-pixbuf-xlib-2.0 --libs` 
168
 
+LIBS =          @LIBS@ `pkg-config gdk-pixbuf-xlib-2.0 --libs` -lfontconfig
 
181
+LIBS =          @LIBS@ `pkg-config gdk-pixbuf-xlib-2.0 --libs` -lfontconfig -lm -lsupc++
169
182
 
170
183
 CORE_LIBS =     @CORE_LIBS@ # `fc-config --libs`
171
184
 IMAGE_LIBS =    @IMAGE_LIBS@
199
212
 check: all tests
200
213
Index: icewm-1.3.7/Makefile.in
201
214
===================================================================
202
 
--- icewm-1.3.7.orig/Makefile.in        2010-10-31 15:09:37.000000000 +0100
203
 
+++ icewm-1.3.7/Makefile.in     2012-03-03 21:04:47.276605222 +0100
204
 
@@ -33,7 +33,7 @@
 
215
--- icewm-1.3.7.orig/Makefile.in        2013-06-28 18:46:58.952863752 +0200
 
216
+++ icewm-1.3.7/Makefile.in     2013-06-28 18:46:58.944864245 +0200
 
217
@@ -4,6 +4,8 @@
 
218
 # Please run 'configure' first (generate it with autogen.sh)
 
219
 ################################################################################
 
220
 
 
221
+SHELL=/bin/bash
 
222
+
 
223
 srcdir     = @srcdir@
 
224
 top_srcdir = @top_srcdir@
 
225
 
 
226
@@ -33,7 +35,7 @@
205
227
 
206
228
 ################################################################################
207
229
 
210
232
 LIBFILES    = lib/preferences lib/winoptions lib/keys \
211
233
               lib/menu lib/toolbar # lib/programs
212
234
 DOCFILES    = README BUGS CHANGES COPYING AUTHORS INSTALL VERSION icewm.lsm
213
 
@@ -46,21 +46,22 @@
 
235
@@ -46,21 +48,22 @@
214
236
 install:       @TARGETS_INSTALL@
215
237
 
216
238
 base icesound icehelp:
239
261
        rm -f *~ config.cache config.log config.status install.inc \
240
262
        sysdep.inc src/config.h \
241
263
        lib/preferences \
242
 
@@ -68,10 +69,10 @@
 
264
@@ -68,10 +71,10 @@
243
265
 
244
266
 maintainer-clean: distclean
245
267
        rm -f icewm.spec icewm.lsm Makefile configure src/config.h.in
252
274
 
253
275
 dist:  distclean docs configure
254
276
 
255
 
@@ -80,21 +81,23 @@
 
277
@@ -80,21 +83,23 @@
256
278
        @echo ------------------------------------------
257
279
        @echo "Installing binaries in $(DESTDIR)$(BINDIR)"
258
280
        @$(INSTALLDIR) "$(DESTDIR)$(BINDIR)"
279
301
                    $(INSTALLLIB) "$${pixmap}" "$(DESTDIR)$(LIBDIR)/$${xpmdir}"; \
280
302
                done; \
281
303
            fi; \
282
 
@@ -126,7 +129,7 @@
 
304
@@ -126,7 +131,7 @@
283
305
 
284
306
 install-nls: nls
285
307
        @echo ------------------------------------------