~corey.bryant/horizon/2014.1.2

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu_settings.patch

  • Committer: James Page
  • Date: 2013-10-03 12:52:18 UTC
  • mfrom: (175.1.2 horizon)
  • Revision ID: james.page@canonical.com-20131003125218-lxg82yrdl860e38m
* New upstream release candidate:
  - d/static: Refreshed static assets for 2013.2~rc1.
  - d/patches: Refreshed patches.
* debian/control: Add python-lesscpy as a suggests to optionally
  support online compression of static assets (LP: #1226674).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: horizon/openstack_dashboard/local/local_settings.py.example
2
 
===================================================================
3
 
--- horizon.orig/openstack_dashboard/local/local_settings.py.example    2013-09-06 14:01:55.315633543 -0700
4
 
+++ horizon/openstack_dashboard/local/local_settings.py.example 2013-09-06 14:01:55.307633543 -0700
5
 
@@ -4,7 +4,7 @@
 
1
--- a/openstack_dashboard/local/local_settings.py.example
 
2
+++ b/openstack_dashboard/local/local_settings.py.example
 
3
@@ -4,7 +4,7 @@ from django.utils.translation import uge
6
4
 
7
5
 from openstack_dashboard import exceptions
8
6
 
11
9
 TEMPLATE_DEBUG = DEBUG
12
10
 
13
11
 # Required for Django 1.5.
14
 
@@ -89,22 +89,16 @@
 
12
@@ -89,22 +89,16 @@ LOCAL_PATH = os.path.dirname(os.path.abs
15
13
 # requests routed to the same dashboard instance or you set the same SECRET_KEY
16
14
 # for all of them.
17
15
 from horizon.utils import secret_key
39
37
 }
40
38
 
41
39
 # Send email to the console by default
42
 
@@ -405,3 +399,24 @@
 
40
@@ -406,3 +400,24 @@ SECURITY_GROUP_RULES = {
43
41
         'to_port': '3389',
44
42
     },
45
43
 }
64
62
+# installations should have this set accordingly.  For more information
65
63
+# see https://docs.djangoproject.com/en/dev/ref/settings/.
66
64
+ALLOWED_HOSTS = '*'
67
 
Index: horizon/openstack_dashboard/settings.py
68
 
===================================================================
69
 
--- horizon.orig/openstack_dashboard/settings.py        2013-09-06 14:01:46.859633620 -0700
70
 
+++ horizon/openstack_dashboard/settings.py     2013-09-06 14:03:36.163632630 -0700
71
 
@@ -42,8 +42,7 @@
72
 
 # horizon.utils.secret_key module and its use.
73
 
 from horizon.utils import secret_key
74
 
 LOCAL_PATH = os.path.join(os.path.dirname(os.path.abspath(__file__)), 'local')
75
 
-SECRET_KEY = secret_key.generate_or_read_from_file(os.path.join(LOCAL_PATH,
76
 
-                                                   '.secret_key_store'))
77
 
+SECRET_KEY = secret_key.generate_or_read_from_file('/var/lib/openstack-dashboard/secret_key')
78
 
 
79
 
 SITE_BRANDING = 'OpenStack Dashboard'
80
 
 
 
65
--- a/openstack_dashboard/settings.py
 
66
+++ b/openstack_dashboard/settings.py
 
67
@@ -217,8 +217,7 @@ if not SECRET_KEY:
 
68
     from horizon.utils import secret_key
 
69
     LOCAL_PATH = os.path.join(os.path.dirname(os.path.abspath(__file__)),
 
70
                               'local')
 
71
-    SECRET_KEY = secret_key.generate_or_read_from_file(os.path.join(LOCAL_PATH,
 
72
-                                                       '.secret_key_store'))
 
73
+    SECRET_KEY = secret_key.generate_or_read_from_file('/var/lib/openstack-dashboard/secret_key')
 
74
 
 
75
 from openstack_dashboard import policy
 
76
 POLICY_CHECK_FUNCTION = policy.check