~cosme/ubuntu/precise/freeimage/freeimage-3.15.1

« back to all changes in this revision

Viewing changes to debian/patches/fix_ftbfs_amd64.patch

  • Committer: Bazaar Package Importer
  • Author(s): Cosme Domínguez Díaz
  • Date: 2010-07-20 13:42:15 UTC
  • mfrom: (1.1.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20100720134215-xt1454zaedv3b604
Tags: 3.13.1-0ubuntu1
* New upstream release. Closes: (LP: #607800)
 - Updated debian/freeimage-get-orig-source script.
 - Removing no longer necessary debian/patches/* and
   the patch system in debian/rules.
 - Updated debian/rules to work with the new Makefiles.
 - Drop from -O3 to -O2 and use lzma compression saves
   ~10 MB of free space. 
* lintian stuff
 - fixed debhelper-but-no-misc-depends
 - fixed ldconfig-symlink-missing-for-shlib

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Patch that fixes several problems for building on amd64. Thanks Fedora guys.
2
 
=====================================================================
3
 
--- freeimage/Source/FreeImage/PluginBMP.cpp~   2007-10-21 16:50:08.000000000 +0200
4
 
+++ freeimage/Source/FreeImage/PluginBMP.cpp    2008-03-12 23:14:51.000000000 +0100
5
 
@@ -189,6 +189,8 @@
6
 
 #endif
7
 
 }
8
 
 
9
 
+#define MIN(a, b) ( ((a) < (b))? (a):(b) )
10
 
+
11
 
 /**
12
 
 Load image pixels for 4-bit RLE compressed dib
13
 
 @param io FreeImage IO
14
 
--- freeimage/Source/Metadata/Exif.cpp~ 2007-07-17 03:28:26.000000000 +0200
15
 
+++ freeimage/Source/Metadata/Exif.cpp  2008-03-13 19:19:07.000000000 +0100
16
 
@@ -495,7 +495,7 @@
17
 
                }
18
 
 
19
 
                // remember that we've visited this directory so that we don't visit it again later
20
 
-               DWORD visited = (((DWORD)ifdp & 0xFFFF) << 16) | (DWORD)de;
21
 
+               DWORD visited = (((DWORD)((long)ifdp) & 0xFFFF) << 16) | (DWORD)de;
22
 
                if(visitedIFD.find(visited) != visitedIFD.end()) {
23
 
                        continue;
24
 
                } else {