~cyphermox/+junk/modeswitch-1.2.6-to-2.1.1

« back to all changes in this revision

Viewing changes to debian/patches/redirect_dispatcher_output.patch

  • Committer: Package Import Robot
  • Author(s): Mathieu Trudel-Lapierre
  • Date: 2012-02-09 10:43:17 UTC
  • mfrom: (17.1.5 sid)
  • Revision ID: package-import@ubuntu.com-20120209104317-xablgk0zrfn0v3wt
Tags: 1.2.3+repack0-1ubuntu1
* Merge with Debian; remaining changes:
  - debian/control: Drop the dependency on tcl and Build-Depends on
    jimsh/libjim (another tcl implementation).
  - debian/control: add libudev-dev and libpipeline-dev to Build-Depends.
  - debian/patches/dispatcher-c-rewrite.patch: rewrite the dispatcher in C,
    to be able to drop the Tcl dependencies.
* debian/patches/dispatcher-c-rewrite.patch: adapt C rewrite patch to take
  in the changes from 1.2.1-1.2.3.
* debian/patches/redirect_dispatcher_output.patch: redirect all dispatcher
  output when called from udev to /dev/null.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Mathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>
 
2
Subject: Redirect any and all dispatcher output to /dev/null
 
3
 
 
4
We really don't care about it anyway, and in some weird cases it causes the
 
5
dispatcher to crash.
 
6
 
 
7
Index: usb-modeswitch/usb_modeswitch.sh
 
8
===================================================================
 
9
--- usb-modeswitch.orig/usb_modeswitch.sh       2012-02-09 01:16:23.704164000 -0500
 
10
+++ usb-modeswitch/usb_modeswitch.sh    2012-02-09 01:19:19.952673430 -0500
 
11
@@ -68,7 +68,7 @@
 
12
                if [ "$?" = "1" ]; then
 
13
                        . /lib/udev/hotplug.functions
 
14
                        wait_for_file /usr/sbin/usb_modeswitch_dispatcher
 
15
-                       exec usb_modeswitch_dispatcher $1 $2 2>>/dev/null
 
16
+                       exec usb_modeswitch_dispatcher $1 $2 >>/dev/null 2>&1
 
17
                fi
 
18
                exit 0
 
19
                ;;
 
20
@@ -77,7 +77,7 @@
 
21
 (
 
22
        . /lib/udev/hotplug.functions
 
23
        wait_for_file /usr/sbin/usb_modeswitch_dispatcher
 
24
-       exec usb_modeswitch_dispatcher --switch-mode $1 $0 &
 
25
+       exec usb_modeswitch_dispatcher --switch-mode $1 $0 >>/dev/null 2>&1 &
 
26
        exit 0
 
27
 ) &
 
28
 exit 0