~cyphermox/network-manager/0.9.10.0

« back to all changes in this revision

Viewing changes to debian/patches/add_ofono_settings_support.patch

  • Committer: Mathieu Trudel-Lapierre
  • Date: 2014-11-18 19:44:11 UTC
  • Revision ID: mathieu-tl@ubuntu.com-20141118194411-967gl49p0hkpemhu
* Merged and renamed ofono patches:
  debian/patches/provisioning_wait_ofono_properties.patch,
  debian/patches/track_ip_settings_post_connection.patch,
  debian/patches/dont-check-secrets-for-ofono.patch,
  debian/patches/ofono_mms_support.patch:
  - 0001-wwan-add-support-for-using-oFono-as-a-modem-manager.patch: add
    support for using oFono as a modem manager alongside ModemManager.

Show diffs side-by-side

added added

removed removed

Lines of Context:
9
9
 src/settings/plugins/ofono/nm-ofono-connection.h |   54 +
10
10
 src/settings/plugins/ofono/nm-ofono.conf         |   18 
11
11
 src/settings/plugins/ofono/nm-ofono.xml          |   16 
12
 
 src/settings/plugins/ofono/parser.c              |  124 ++++
 
12
 src/settings/plugins/ofono/parser.c              |  124 +++
13
13
 src/settings/plugins/ofono/parser.h              |   33 +
14
 
 src/settings/plugins/ofono/plugin.c              |  682 +++++++++++++++++++++++
 
14
 src/settings/plugins/ofono/plugin.c              |  738 +++++++++++++++++++++++
15
15
 src/settings/plugins/ofono/plugin.h              |   53 +
16
 
 11 files changed, 1225 insertions(+)
 
16
 11 files changed, 1281 insertions(+)
17
17
 
18
18
Index: b/configure.ac
19
19
===================================================================
545
545
===================================================================
546
546
--- /dev/null
547
547
+++ b/src/settings/plugins/ofono/plugin.c
548
 
@@ -0,0 +1,682 @@
 
548
@@ -0,0 +1,738 @@
549
549
+/* -*- Mode: C; tab-width: 4; indent-tabs-mode: t; c-basic-offset: 4 -*- */
550
550
+
551
551
+/* Ofono modem settings service
1009
1009
+static GSList*
1010
1010
+SCPluginOfono_get_connections (NMSystemConfigInterface *config);
1011
1011
+
 
1012
+static void
 
1013
+GObject__get_property (GObject *object, guint prop_id,
 
1014
+                                  GValue *value, GParamSpec *pspec)
 
1015
+{
 
1016
+       NMSystemConfigInterface *self = NM_SYSTEM_CONFIG_INTERFACE (object);
 
1017
+
 
1018
+       switch (prop_id) {
 
1019
+       case NM_SYSTEM_CONFIG_INTERFACE_PROP_NAME:
 
1020
+               g_value_set_string (value, OFONO_PLUGIN_NAME);
 
1021
+               break;
 
1022
+       case NM_SYSTEM_CONFIG_INTERFACE_PROP_INFO:
 
1023
+               g_value_set_string (value, OFONO_PLUGIN_INFO);
 
1024
+               break;
 
1025
+       case NM_SYSTEM_CONFIG_INTERFACE_PROP_CAPABILITIES:
 
1026
+               g_value_set_uint (value, 0);
 
1027
+               break;
 
1028
+       case NM_SYSTEM_CONFIG_INTERFACE_PROP_HOSTNAME:
 
1029
+               g_value_set_string (value, "");
 
1030
+               break;
 
1031
+       default:
 
1032
+               G_OBJECT_WARN_INVALID_PROPERTY_ID (object, prop_id, pspec);
 
1033
+               break;
 
1034
+       }
 
1035
+}
 
1036
+
 
1037
+static void
 
1038
+GObject__set_property (GObject *object, guint prop_id,
 
1039
+                                  const GValue *value, GParamSpec *pspec)
 
1040
+{
 
1041
+       switch (prop_id) {
 
1042
+       case NM_SYSTEM_CONFIG_INTERFACE_PROP_HOSTNAME:
 
1043
+               break;
 
1044
+       default:
 
1045
+               G_OBJECT_WARN_INVALID_PROPERTY_ID (object, prop_id, pspec);
 
1046
+               break;
 
1047
+       }
 
1048
+}
 
1049
+
1012
1050
+/*  GObject */
1013
1051
+static void
1014
1052
+dispose (GObject *object);
1029
1067
+       g_type_class_add_private (req_class, sizeof (SCPluginOfonoPrivate));
1030
1068
+
1031
1069
+       object_class->dispose = dispose;
 
1070
+       object_class->get_property = GObject__get_property;
 
1071
+       object_class->set_property = GObject__set_property;
1032
1072
+
1033
1073
+       dbus_g_object_type_install_info (G_TYPE_FROM_CLASS (req_class),
1034
1074
+                                        &dbus_glib_nm_ofono_object_info);
 
1075
+
 
1076
+       g_object_class_override_property (object_class,
 
1077
+                                         NM_SYSTEM_CONFIG_INTERFACE_PROP_NAME,
 
1078
+                                         NM_SYSTEM_CONFIG_INTERFACE_NAME);
 
1079
+
 
1080
+       g_object_class_override_property (object_class,
 
1081
+                                         NM_SYSTEM_CONFIG_INTERFACE_PROP_INFO,
 
1082
+                                         NM_SYSTEM_CONFIG_INTERFACE_INFO);
 
1083
+
 
1084
+       g_object_class_override_property (object_class,
 
1085
+                                         NM_SYSTEM_CONFIG_INTERFACE_PROP_CAPABILITIES,
 
1086
+                                         NM_SYSTEM_CONFIG_INTERFACE_CAPABILITIES);
 
1087
+
 
1088
+       g_object_class_override_property (object_class,
 
1089
+                                         NM_SYSTEM_CONFIG_INTERFACE_PROP_HOSTNAME,
 
1090
+                                         NM_SYSTEM_CONFIG_INTERFACE_HOSTNAME);
1035
1091
+}
1036
1092
+
1037
1093
+static void