~cyphermox/vte/lp621927

« back to all changes in this revision

Viewing changes to debian/patches/fix-meta-modifier.patch

  • Committer: robert.ancell at canonical
  • Date: 2010-08-27 02:57:16 UTC
  • Revision ID: robert.ancell@canonical.com-20100827025716-eozcfaq443iew183
* debian/patches/fix-alt-modifier.patch:
  - Replace with upstream reversion commit c56c3c4.
* debian/patches/fix-meta-modifier.patch:
  - Take upstream commit 724195b to really fix Meta.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Behdad Esfahbod <behdad@behdad.org>
 
2
Subject: [PATCH] Really fix Bug 601926 - Don't hardcode meta to alt
 
3
 
 
4
Correct fix applied this time.  Tested, Alt is not broken by this
 
5
change.
 
6
 
 
7
Origin: http://git.gnome.org/browse/vte/commit/?id=724195be5ba53c45d650366a8e029939c20d43a4
 
8
Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/vte/+bug/619754
 
9
Bug: https://bugzilla.gnome.org/show_bug.cgi?id=601926
 
10
Last-Update: 2009-08-25
 
11
Applied-Upstream: 0.25.91, http://git.gnome.org/browse/vte/commit/?id=724195be5ba53c45d650366a8e029939c20d43a4
 
12
 
 
13
---
 
14
 configure.in |    2 +-
 
15
 src/keymap.h |    2 +-
 
16
 src/vte.c    |    7 ++++++-
 
17
 3 files changed, 8 insertions(+), 3 deletions(-)
 
18
 
 
19
diff --git a/configure.in b/configure.in
 
20
index d3b8bf9..8bc3b57 100644
 
21
--- a/configure.in
 
22
+++ b/configure.in
 
23
@@ -51,7 +51,7 @@ case "$with_gtk" in
 
24
        VTE_PC_VERSION=
 
25
        VTE_LIBRARY_SUFFIX=
 
26
        GTK_API_VERSION=2.0
 
27
-       GTK_REQUIRED=2.14.0
 
28
+       GTK_REQUIRED=2.20.0
 
29
        ;;
 
30
   3.0) VTE_API_VERSION=2.90
 
31
        VTE_API_MAJOR_VERSION=2
 
32
diff --git a/src/keymap.h b/src/keymap.h
 
33
index 3a4cefe..243e22e 100644
 
34
--- a/src/keymap.h
 
35
+++ b/src/keymap.h
 
36
@@ -27,7 +27,7 @@
 
37
 
 
38
 G_BEGIN_DECLS
 
39
 
 
40
-#define VTE_META_MASK          GDK_MOD1_MASK
 
41
+#define VTE_META_MASK          GDK_META_MASK
 
42
 #define VTE_NUMLOCK_MASK       GDK_MOD2_MASK
 
43
 
 
44
 /* Map the specified keyval/modifier setup, dependent on the mode, to either
 
45
diff --git a/src/vte.c b/src/vte.c
 
46
index abf7473..640f3b0 100644
 
47
--- a/src/vte.c
 
48
+++ b/src/vte.c
 
49
@@ -4910,8 +4910,13 @@ vte_terminal_read_modifiers (VteTerminal *terminal,
 
50
        GdkModifierType modifiers;
 
51
 
 
52
        /* Read the modifiers. */
 
53
-       if (gdk_event_get_state((GdkEvent*)event, &modifiers))
 
54
+       if (gdk_event_get_state((GdkEvent*)event, &modifiers)) {
 
55
+               GdkKeymap *keymap;
 
56
+               keymap = gdk_keymap_get_for_display (
 
57
+                               gdk_drawable_get_display (((GdkEventAny *)event)->window));
 
58
+               gdk_keymap_add_virtual_modifiers (keymap, &modifiers);
 
59
                terminal->pvt->modifiers = modifiers;
 
60
+       }
 
61
 }
 
62
 
 
63
 /* Read and handle a keypress event. */
 
64
-- 
 
65
1.7.2.2
 
66