~dani.behzi/bash-completion/bash-completion

« back to all changes in this revision

Viewing changes to debian/patches/14-add-apt-bts747094.patch

  • Committer: Package Import Robot
  • Author(s): Brian Murray
  • Date: 2015-08-12 13:29:05 UTC
  • mfrom: (49.2.2 wily)
  • Revision ID: package-import@ubuntu.com-20150812132905-ylvr1psfz8rn2msq
Tags: 1:2.1-4.1ubuntu2
* debian/patches/14-add-apt-bts747094.patch:
  - Fix add support for the new "apt" command. (LP: #1358154)
    Thanks to Simon Déziel for the initial work.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
## Description: add bash completion support for the new "apt" command
2
2
## Origin/Author: Michael Vogt <michael.vogt@ubuntu.com>
3
3
## Bug: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=747094
4
 
Index: bash-completion-2.1/b/completions/apt
 
4
Index: wily/completions/apt
5
5
===================================================================
6
6
--- /dev/null
7
 
+++ bash-completion-2.1/b/completions/apt
 
7
+++ wily/completions/apt
8
8
@@ -0,0 +1,95 @@
9
9
+# Debian apt(8) completion                             -*- shell-script -*-
10
10
+
101
101
+complete -F _apt apt
102
102
+
103
103
+# ex: ts=4 sw=4 et filetype=sh
 
104
Index: wily/completions/Makefile.am
 
105
===================================================================
 
106
--- wily.orig/completions/Makefile.am
 
107
+++ wily/completions/Makefile.am
 
108
@@ -7,6 +7,7 @@ bashcomp_DATA = a2x \
 
109
                alias \
 
110
                ant \
 
111
                apache2ctl \
 
112
+               apt \
 
113
                apt-build \
 
114
                apt-cache \
 
115
                apt-get \
 
116
Index: wily/completions/Makefile.in
 
117
===================================================================
 
118
--- wily.orig/completions/Makefile.in
 
119
+++ wily/completions/Makefile.in
 
120
@@ -178,6 +178,7 @@ bashcomp_DATA = a2x \
 
121
                alias \
 
122
                ant \
 
123
                apache2ctl \
 
124
+               apt \
 
125
                apt-build \
 
126
                apt-cache \
 
127
                apt-get \