~dannf/ubuntu/saucy/screen/lp1213278-from-debian

« back to all changes in this revision

Viewing changes to debian/patches/12kfreebsd_ctty.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): أحمد المحمودي (Ahmed El-Mahmoudy)
  • Date: 2009-06-18 07:18:37 UTC
  • mfrom: (4.1.2 squeeze)
  • Revision ID: james.westby@ubuntu.com-20090618071837-yjhjh7tupjay04um
Tags: 4.0.3-13ubuntu1
* Merge with Debian, remaining changes: (LP: #388791)
  + Add show encoding feature, using "%e" in hardstatus to show current
    encoding.  Ported from FreeBSD original by yzlin@cs.nctu.edu.tw.
    LP: #286810
  + debian/patches/56-source-file-not-found-warning.dpatch: When sourcing a
    file in a screenrc which is not found, fail more gracefully by not
    interrupting normal operation; instead, print a debug message. LP:
    #323756
  + debian/control: recommend byobu
  + Add 59-no-beep-on-write-acl.dpatch: do not beep on all displays when the
    write ACL triggers, instead report failure as done with regular screen
    command ACL failures.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 12kfreebsd_ctty.dpatch by  <hesso@pool.math.tu-berlin.de>
 
3
##
 
4
## DP: See inline documentation.
 
5
 
 
6
@DPATCH@
 
7
--- screen-4.0.3.orig/tty.sh    2009-04-10 18:15:51.923805915 +0200
 
8
+++ screen-4.0.3/tty.sh 2009-04-10 18:17:56.043804602 +0200
 
9
@@ -801,18 +801,11 @@
 
10
 
 
11
   mypid = getpid();
 
12
 
 
13
-  /* The next lines should be obsolete. Can anybody check if they
 
14
-   * are really needed on the BSD platforms?
 
15
-   *
 
16
-   * this is to avoid the message:
 
17
-   *   fgtty: Not a typewriter (25)
 
18
+  /*
 
19
+   * Under BSD we have to set the controlling terminal again explicitly.
 
20
    */
 
21
-# if defined(__osf__) || (BSD >= 199103) || defined(ISC)
 
22
-  if (separate_sids)
 
23
-    setsid();  /* should be already done */
 
24
-#  ifdef TIOCSCTTY
 
25
+# if defined(__FreeBSD_kernel__) && defined(TIOCSCTTY)
 
26
   ioctl(fd, TIOCSCTTY, (char *)0);
 
27
-#  endif
 
28
 # endif
 
29
 
 
30
 # ifdef POSIX