~darkmoon/+junk/darkstat-pkg

« back to all changes in this revision

Viewing changes to debian/patches/manpage-section-and-minus-hyphen.patch

  • Committer: Bazaar Package Importer
  • Author(s): Rene Mayorga
  • Date: 2008-10-06 21:49:52 UTC
  • mfrom: (4.1.3 intrepid)
  • Revision ID: james.westby@ubuntu.com-20081006214952-rkg8moyd6izn7q5y
Tags: 3.0.708-2
* fix workaround to --import/--export at init script
  this prevent darkstat.db being replaced. Closes: #500070
* remove debconf note about the init script inclussion
* remove checks for 2.5-1 versions
* debian/copyright
  + Add 2-clause BSD license for tree.h and host_sort.c
    and remove the note for /usr/share/common-licenses/BSD
  + add conv.c, actc.c err.c, err.h, str.c and str.h copyright stanza
* debian/init.d
  + Set Conf variables to empty string before sourcing init.cfg
* debian/postint
  + only remove DB when version is lt 3.0.707-1
* debian/templates remove upgrade-note
* debian/rules
  + made build-stamp depends on configure-stamp not configure
  + made install-stamp depends on build-stamp not build
  + use DESTDIR instead prefix at install-stamp target
* debian/README.Debian - point to the correct section on the 
  reference to the manpage

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: darkstat-3.0.708/Makefile.in
 
2
===================================================================
 
3
--- darkstat-3.0.708.orig/Makefile.in   2008-06-04 23:41:39.000000000 -0600
 
4
+++ darkstat-3.0.708/Makefile.in        2008-06-04 23:41:44.000000000 -0600
 
5
@@ -70,8 +70,6 @@
 
6
 install: darkstat
 
7
        $(INSTALL) -d $(DESTDIR)$(sbindir)
 
8
        $(INSTALL) -m 555 darkstat $(DESTDIR)$(sbindir)
 
9
-       $(INSTALL) -d $(DESTDIR)$(mandir)/man1
 
10
-       $(INSTALL) -m 444 darkstat.1 $(DESTDIR)$(mandir)/man1
 
11
 
 
12
 # Automatically generated dependencies
 
13
 acct.o: acct.c darkstat.h config.h acct.h decode.h conv.h daylog.h \
 
14
Index: darkstat-3.0.708/darkstat.1
 
15
===================================================================
 
16
--- darkstat-3.0.708.orig/darkstat.1    2008-06-04 23:41:39.000000000 -0600
 
17
+++ darkstat-3.0.708/darkstat.1 2008-06-04 23:42:35.000000000 -0600
 
18
@@ -5,52 +5,52 @@
 
19
 .\" You may use, modify and redistribute this file under the terms of the
 
20
 .\" GNU General Public License version 2. (see COPYING.GPL)
 
21
 .\"
 
22
-.TH darkstat 1 "May 2008" darkstat "User Manuals"
 
23
-.SH NAME
 
24
-darkstat v3 \- network statistics gatherer
 
25
+.TH "darkstat" "8" "May 2008" darkstat "User Manuals"
 
26
+.SH "NAME"
 
27
+darkstat \- network statistics gatherer
 
28
 .\"
 
29
 .SH SYNOPSIS
 
30
 .B darkstat
 
31
 [
 
32
-.BI \-i " interface"
 
33
+.BI -i " interface"
 
34
 ] [
 
35
-.BI \-r " file"
 
36
+.BI -r " file"
 
37
 ] [
 
38
-.BI \-\-debug
 
39
+.BI --debug
 
40
 ] [
 
41
-.BI \-\-no\-promisc
 
42
+.BI --no-promisc
 
43
 ] [
 
44
-.BI \-\-no\-dns
 
45
+.BI --no-dns
 
46
 ] [
 
47
-.BI \-p " port"
 
48
+.BI -p " port"
 
49
 ] [
 
50
-.BI \-b " bindaddr"
 
51
+.BI -b " bindaddr"
 
52
 ] [
 
53
-.BI \-f " filter"
 
54
+.BI -f " filter"
 
55
 ] [
 
56
-.BI \-l " network/netmask"
 
57
+.BI -l " network/netmask"
 
58
 ] [
 
59
-.BI \-\-chroot " dir"
 
60
+.BI --chroot " dir"
 
61
 ] [
 
62
-.BI \-\-user " username"
 
63
+.BI --user " username"
 
64
 ] [
 
65
-.BI \-\-daylog " filename"
 
66
+.BI --daylog " filename"
 
67
 ] [
 
68
-.BI \-\-import " filename"
 
69
+.BI --import " filename"
 
70
 ] [
 
71
-.BI \-\-export " filename"
 
72
+.BI --export " filename"
 
73
 ] [
 
74
-.BI \-\-pidfile " filename"
 
75
+.BI --pidfile " filename"
 
76
 ] [
 
77
-.BI \-\-hosts\-max " count"
 
78
+.BI --hosts-max " count"
 
79
 ] [
 
80
-.BI \-\-hosts\-keep " count"
 
81
+.BI --hosts-keep " count"
 
82
 ] [
 
83
-.BI \-\-ports\-max " count"
 
84
+.BI --ports-max " count"
 
85
 ] [
 
86
-.BI \-\-ports\-keep " count"
 
87
+.BI --ports-keep " count"
 
88
 ] [
 
89
-.BI \-\-highest\-port " port"
 
90
+.BI --highest-port " port"
 
91
 ]
 
92
 .\"
 
93
 .SH DESCRIPTION
 
94
@@ -64,29 +64,29 @@
 
95
 .SH OPTIONS
 
96
 .\"
 
97
 .TP
 
98
-.BI \-i " interface"
 
99
+.BI -i " interface"
 
100
 Capture traffic on the specified network interface.
 
101
 This is the only mandatory commandline argument.
 
102
 .\"
 
103
 .TP
 
104
-.BI \-r " file"
 
105
+.BI -r " file"
 
106
 Instead of capturing live traffic, read it from a
 
107
 .BR pcap (3)
 
108
 capture file.
 
109
 This is only useful for development and benchmarking.
 
110
 The
 
111
-.BI \-r
 
112
+.BI -r
 
113
 and
 
114
-.BI \-i
 
115
+.BI -i
 
116
 arguments are mutually exclusive.
 
117
 .\"
 
118
 .TP
 
119
-.BI \-\-debug
 
120
+.BI --debug
 
121
 Debugging mode: do not detach from the controlling terminal,
 
122
 stay in the foreground instead.
 
123
 .\"
 
124
 .TP
 
125
-.BI \-\-no\-promisc
 
126
+.BI --no-promisc
 
127
 Do not use promiscuous mode to capture.
 
128
 Note that an interface may already be in promiscuous mode.
 
129
 If this is a problem, use an appropriate
 
130
@@ -94,21 +94,21 @@
 
131
 filter.
 
132
 .\"
 
133
 .TP
 
134
-.BI \-\-no\-dns
 
135
+.BI --no-dns
 
136
 Do not resolve IPs to host names.
 
137
 .\"
 
138
 .TP
 
139
-.BI \-p " port"
 
140
+.BI -p " port"
 
141
 Bind the web interface to the specified port.
 
142
 The default is 667.
 
143
 .\"
 
144
 .TP
 
145
-.BI \-b " bindaddr"
 
146
+.BI -b " bindaddr"
 
147
 Bind the web interface to the specified address.
 
148
 The default is to listen on all interfaces.
 
149
 .\"
 
150
 .TP
 
151
-.BI \-f " filter"
 
152
+.BI -f " filter"
 
153
 Use the specified filter expression when capturing traffic.
 
154
 The filter syntax is beyond the scope of this manual page;
 
155
 please refer to the
 
156
@@ -116,7 +116,7 @@
 
157
 documentation.
 
158
 .\"
 
159
 .TP
 
160
-.BI \-l " network/netmask"
 
161
+.BI -l " network/netmask"
 
162
 Define a "local network" according to the network and netmask addresses.
 
163
 All traffic entering or leaving this network will be graphed, as opposed
 
164
 to the default behaviour of only graphing traffic to and from the local
 
165
@@ -129,7 +129,7 @@
 
166
 .RE
 
167
 .\"
 
168
 .TP
 
169
-.BI \-\-chroot " dir"
 
170
+.BI --chroot " dir"
 
171
 Force \fIdarkstat\fR to \fBchroot()\fR into the specified directory.
 
172
 Without this argument, a default directory will be used, which is
 
173
 determined at build time.
 
174
@@ -139,14 +139,14 @@
 
175
 For security reasons, this directory should be empty, and the user that
 
176
 \fIdarkstat\fR is running as should not have write access to it.
 
177
 
 
178
-However, if you wish to use \fB\-\-daylog\fR or \fB\-\-export\fR,
 
179
+However, if you wish to use \fB--daylog\fR or \fB--export\fR,
 
180
 \fIdarkstat\fR will need write access to the chroot.
 
181
 If you are uncomfortable with the security implications, don't
 
182
 use any functionality that requires write access.
 
183
 .RE
 
184
 .\"
 
185
 .TP
 
186
-.BI \-\-user " username"
 
187
+.BI --user " username"
 
188
 Force \fIdarkstat\fR to drop privileges to the \fBuid\fR and \fBgid\fR of
 
189
 the specified user.
 
190
 Without this argument, a default value will be used, which is set at
 
191
@@ -158,15 +158,15 @@
 
192
 .RE
 
193
 .\"
 
194
 .TP
 
195
-.BI \-\-daylog " filename"
 
196
+.BI --daylog " filename"
 
197
 .RS
 
198
 Log daily traffic statistics into the named file, relative to the
 
199
 chroot directory.
 
200
-If you wish to use \fB\-\-daylog\fR, you must first specify a
 
201
-\fB\-\-chroot\fR directory, and it must be writeable by the
 
202
+If you wish to use \fB--daylog\fR, you must first specify a
 
203
+\fB--chroot\fR directory, and it must be writeable by the
 
204
 \fIdarkstat\fR user.
 
205
 A writeable chroot has security implications; if you are uncomfortable
 
206
-with this, do not use the \fB\-\-daylog\fR functionality.
 
207
+with this, do not use the \fB--daylog\fR functionality.
 
208
 
 
209
 If the daylog argument is not specified, no logging is performed.
 
210
 
 
211
@@ -179,26 +179,26 @@
 
212
 .RE
 
213
 .\"
 
214
 .TP
 
215
-.BI \-\-import " filename"
 
216
+.BI --import " filename"
 
217
 Upon starting, import a \fIdarkstat\fR database from the named file,
 
218
 relative to the chroot directory.
 
219
-If you wish to use \fB\-\-import\fR, you must first specify a
 
220
-\fB\-\-chroot\fR directory.
 
221
+If you wish to use \fB--import\fR, you must first specify a
 
222
+\fB--chroot\fR directory.
 
223
 If the import is unsuccessful, \fIdarkstat\fR will start with an empty
 
224
 database.
 
225
 .\"
 
226
 .TP
 
227
-.BI \-\-export " filename"
 
228
+.BI --export " filename"
 
229
 On shutdown, and upon receiving SIGUSR1, export the in-memory database
 
230
 to the named file, relative to the chroot directory.
 
231
-If you wish to use \fB\-\-export\fR, you must first specify a
 
232
-\fB\-\-chroot\fR directory, and it must be writeable by the
 
233
+If you wish to use \fB--export\fR, you must first specify a
 
234
+\fB--chroot\fR directory, and it must be writeable by the
 
235
 \fIdarkstat\fR user.
 
236
 A writeable chroot has security implications - if you are uncomfortable
 
237
-with this, do not use the \fB\-\-export\fR functionality.
 
238
+with this, do not use the \fB--export\fR functionality.
 
239
 .\"
 
240
 .TP
 
241
-.BI \-\-pidfile " filename"
 
242
+.BI --pidfile " filename"
 
243
 .RS
 
244
 Creates a file containing the process ID of \fIdarkstat\fR.
 
245
 This file will be unlinked upon clean shutdown.
 
246
@@ -207,7 +207,7 @@
 
247
 
 
248
 For example, start \fIdarkstat\fR with:
 
249
 .IP
 
250
-darkstat -i fxp0 --chroot /var/run/darkstat --pidfile darkstat.pid
 
251
+darkstat \-i fxp0 \-\-chroot /var/run/darkstat \-\-pidfile darkstat.pid
 
252
 .PP
 
253
 And stop with:
 
254
 .IP
 
255
@@ -219,31 +219,31 @@
 
256
 .RE
 
257
 .\"
 
258
 .TP
 
259
-.BI \-\-hosts\-max " count"
 
260
+.BI --hosts-max " count"
 
261
 The maximum number of hosts that will be kept in the hosts table.
 
262
 This is used to limit how much accounting data will be kept in memory.
 
263
 .\"
 
264
 .TP
 
265
-.BI \-\-hosts\-keep " count"
 
266
+.BI --hosts-keep " count"
 
267
 When the hosts table hits
 
268
-.BI \-\-hosts\-max
 
269
+.BI --hosts-max
 
270
 and traffic is seen from a new host, we clean out the hosts table,
 
271
 keeping only the top
 
272
-.BI \-\-hosts\-keep
 
273
+.BI --hosts-keep
 
274
 number of hosts, sorted by total traffic.
 
275
 .\"
 
276
 .TP
 
277
-.BI \-\-ports\-max " count"
 
278
+.BI --ports-max " count"
 
279
 The maximum number of ports that will be tracked for each host.
 
280
 This is used to limit how much accounting data will be kept in memory.
 
281
 .\"
 
282
 .TP
 
283
-.BI \-\-ports\-keep " count"
 
284
+.BI --ports-keep " count"
 
285
 When a ports table fills up, this many ports are kept and the rest are
 
286
 discarded.
 
287
 .\"
 
288
 .TP
 
289
-.BI \-\-highest\-port " port"
 
290
+.BI --highest-port " port"
 
291
 Ports that are numerically higher than this will not appear in the
 
292
 per-host ports tables, although their traffic will still be accounted
 
293
 for.
 
294
@@ -256,30 +256,30 @@
 
295
 .I fxp0
 
296
 interface:
 
297
 .IP
 
298
-darkstat -i fxp0
 
299
+darkstat \-i fxp0
 
300
 .PP
 
301
 .\"
 
302
 We want to account for traffic on the Internet-facing interface,
 
303
 but only serve web pages to our private local network where we have the
 
304
 IP address 192.168.0.1:
 
305
 .IP
 
306
-darkstat -i fxp0 -b 192.168.0.1
 
307
+darkstat \-i fxp0 \-b 192.168.0.1
 
308
 .PP
 
309
 .\"
 
310
 We want to serve web pages on the standard HTTP port:
 
311
 .IP
 
312
-darkstat -i fxp0 -p 80
 
313
+darkstat \-i fxp0 \-p 80
 
314
 .PP
 
315
 .\"
 
316
 We are on Optus (cable) and don't want to account for the constant ARP
 
317
 traffic we are receiving:
 
318
 .IP
 
319
-darkstat -i fxp0 -f "not arp"
 
320
+darkstat \-i fxp0 \-f "not arp"
 
321
 .PP
 
322
 .\"
 
323
 We only want to account for SSH traffic:
 
324
 .IP
 
325
-darkstat -i fxp0 -f "port 22"
 
326
+darkstat \-i fxp0 \-f "port 22"
 
327
 .PP
 
328
 .\"
 
329
 (For a full reference on filter syntax, refer to the
 
330
@@ -292,7 +292,7 @@
 
331
 traffic entering and leaving the local network, not just the gateway
 
332
 server (which is running \fIdarkstat\fR):
 
333
 .IP
 
334
-darkstat -i fxp0 -l 192.168.1.0/255.255.255.0
 
335
+darkstat \-i fxp0 \-l 192.168.1.0/255.255.255.0
 
336
 .\"
 
337
 .SH TROUBLESHOOTING
 
338
 If you are using PPPoE (for example, on ADSL), and sniffing on
 
339
@@ -304,13 +304,13 @@
 
340
 interface that your PPPoE software provides.
 
341
 For example:
 
342
 .IP
 
343
-darkstat -i tun0
 
344
+darkstat \-i tun0
 
345
 .PP
 
346
 Or, on \fIOpenBSD\fR or \fINetBSD\fR, sniff on the
 
347
 .I pppoe
 
348
 interface:
 
349
 .IP
 
350
-darkstat -i pppoe0
 
351
+darkstat \-i pppoe0
 
352
 .PP
 
353
 .\"
 
354
 .SH SIGNALS
 
355
@@ -322,7 +322,7 @@
 
356
 .PP
 
357
 Sending the SIGUSR1 signal will cause \fIdarkstat\fR to empty out its
 
358
 in-memory database.
 
359
-If an \fB\-\-export\fR file was set, it will first save the database to
 
360
+If an \fB--export\fR file was set, it will first save the database to
 
361
 file.
 
362
 .PP
 
363
 .\"