~darkxst/gnome-settings-daemon/enable_nm

« back to all changes in this revision

Viewing changes to debian/patches/disable_three_touch_tap.patch

  • Committer: Daniel Holbach
  • Date: 2014-05-28 12:42:05 UTC
  • Revision ID: daniel.holbach@canonical.com-20140528124205-nsl4atink1jsxtq9
* Drop all Unity patches and legacy features (LP: #1318539)
  - Keep schemas for background plugin, since they are used by u-s-d
* debian/patches: Refreshed
  - git_new_screencast_keybinding.patch
  - git_xsettings_segfaults.patch
* debian/control.in: Fix lintian warnings
  - gnome-settings-daemon-schemas add ${misc:Depends}
  - gnome-settings-daemon fix binNMUable error for gnome-settings-daemon-schemas
* Bump standards to 3.9.5 (No changes)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
# Description: disable three-touch tap to click by default, it conflicts
2
 
with the unity resize handles, see that email for details:
3
 
https://lists.ubuntu.com/archives/ubuntu-desktop/2012-February/003694.html
4
 
# Forwarded: no, Ubuntu specific since it's for unity
5
 
Index: gnome-settings-daemon-3.6.1/plugins/mouse/gsd-mouse-manager.c
6
 
===================================================================
7
 
--- gnome-settings-daemon-3.6.1.orig/plugins/mouse/gsd-mouse-manager.c  2012-10-26 10:19:49.427004172 +0200
8
 
+++ gnome-settings-daemon-3.6.1/plugins/mouse/gsd-mouse-manager.c       2012-10-26 10:19:49.691004186 +0200
9
 
@@ -657,7 +657,7 @@
10
 
                 /* Set RLM mapping for 1/2/3 fingers*/
11
 
                 data[4] = (state) ? ((left_handed) ? 3 : 1) : 0;
12
 
                 data[5] = (state) ? ((left_handed) ? 1 : 3) : 0;
13
 
-                data[6] = (state) ? 2 : 0;
14
 
+                data[6] = 0; /* Disable three touch tap so gestures work */
15
 
                 XChangeDeviceProperty (GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()), xdevice, prop, XA_INTEGER, 8,
16
 
                                        PropModeReplace, data, nitems);
17
 
         }