~davewalker/xmltv/544522

« back to all changes in this revision

Viewing changes to debian/patches/11_makefile_pl_debian_changes.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Stefan Lesicnik
  • Date: 2008-08-07 07:25:45 UTC
  • mfrom: (1.2.10 upstream) (4.1.1 lenny)
  • Revision ID: james.westby@ubuntu.com-20080807072545-ttu7eljrarkzon1p
Tags: 0.5.52-1ubuntu1
* Merge from debian unstable, remaining changes: (LP: #255450)
  - Fixes multiple broken grabbers (LP: #193703)
  - Update 06_grab_no.dpatch
* Deleted 07_grab_pt.patch from debian/patches as it is now in Debian.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 10_tv_pick_cgi_docfix.patch by Chris Butler <chrisb@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Altered suffixes for manpages for Debian Perl Policy, 
 
6
## DP: Removed Lingua::EN::Numbers::Ordinate dependency not required for package
 
7
## DP: Added more modules to the list of manpages to generate
 
8
 
 
9
@DPATCH@
 
10
diff -urNad xmltv~/Makefile.PL xmltv/Makefile.PL
 
11
--- xmltv~/Makefile.PL  2008-06-21 18:13:48.000000000 +0100
 
12
+++ xmltv/Makefile.PL   2008-06-21 18:13:48.000000000 +0100
 
13
@@ -86,7 +86,10 @@
 
14
      # MakeMaker versions.
 
15
      INSTALLMAN1DIR  => "$location/share/man/man1",
 
16
      INSTALLMAN3DIR  => "$location/share/man/man3",
 
17
-     MAN3EXT         => '3',
 
18
+
 
19
+     # For Debian, the scripts will get .1p and the module will get .3pm.
 
20
+     MAN1EXT         => '1p',
 
21
+     MAN3EXT         => '3pm',
 
22
 
 
23
      # Directory to install into when making Windows binary dist.
 
24
      WINDOWS_DIST    => "xmltv-$VERSION-win32",
 
25
@@ -218,7 +221,9 @@
 
26
 #
 
27
 my %recommended
 
28
   = (
 
29
-     'Lingua::EN::Numbers::Ordinate' => 0,
 
30
+     # For Debian, we ignore this package, since only the
 
31
+     # CGI script uses it and we don't install that.
 
32
+     #'Lingua::EN::Numbers::Ordinate' => 0
 
33
      'Lingua::Preferred' => '0.2.4',
 
34
      'Term::ProgressBar' => 2.03,
 
35
      'Compress::Zlib' => 0,
 
36
@@ -1173,7 +1177,7 @@
 
37
 sub MY::manifypods {
 
38
     package MY;
 
39
     for (my $inherited = shift->SUPER::manifypods(@_)) {
 
40
-       foreach my $s (qw(Grab_XML DST Config_file Get_nice Mode Summarize Gunzip GUI Date Supplement)) {
 
41
+       foreach my $s (qw(Grab_XML DST Config_file Get_nice Mode Summarize Gunzip GUI Date Supplement ValidateGrabber Options Configure ValidateFile Configure::Writer Version PreferredMethod)) {
 
42
            s!\$\(INST_MAN3DIR\)/(?:grab::|)$s[.]\$\(MAN3EXT\)!"\$(INST_MAN3DIR)/XMLTV::$s.\$(MAN3EXT)"!;
 
43
            s!\$\(INSTALLMAN3DIR\)/$s.\$\(MAN3EXT\)!"\$(INSTALLMAN3DIR)/XMLTV::$s.\$(MAN3EXT)"!;
 
44
        }