~fossfreedom/evince/lp1670054

« back to all changes in this revision

Viewing changes to debian/patches/unity_normal_titlebar.patch

  • Committer: Sebastien Bacher
  • Date: 2015-10-27 09:59:51 UTC
  • Revision ID: seb128@ubuntu.com-20151027095951-g68y8eell8jxvw2b
  * Resynchronize on Debian including fixed PIE build (lp: #1496548), 
    remaining changes
  * debian/apparmor-profile:
  * debian/apparmor-profile.abstraction:
  * debian/evince.apport:
  * debian/evince-common.dirs:
    - Ubuntu apparmor profile
  * debian/control:
    - Build-Depend on dh-apparmor and libgrip-dev
    - Suggests on apparmor
  * debian/patches/git_sidebar_label.patch:
    - show the page label instead of page number (lp: #1506967)
  * debian/patches/traditional_menu_bar.patch:
    - use traditionnal menubars under Unity, updated to show the buttons
      in the window as well as upstream does (less change and clean
      warnings displayed on start before)
  * debian/patches/unity_normal_titlebar.patch:
    - use traditionnal titlebar out of gnome-shell
  * debian/rules:
    - install apparmor and apport files, update translations template

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
# Description: use GtkHeaderBar as decoration only under gnome-shell
2
2
# Reported as a wishlist on https://bugzilla.gnome.org/show_bug.cgi?id=736420
3
3
# The solution should probably be different from the getenv one though
4
 
Index: evince-3.16.1/shell/ev-window.c
 
4
Index: evince-3.18.1/shell/ev-window.c
5
5
===================================================================
6
 
--- evince-3.16.1.orig/shell/ev-window.c
7
 
+++ evince-3.16.1/shell/ev-window.c
8
 
@@ -6924,8 +6924,15 @@ ev_window_init (EvWindow *ev_window)
 
6
--- evince-3.18.1.orig/shell/ev-window.c
 
7
+++ evince-3.18.1/shell/ev-window.c
 
8
@@ -6796,8 +6796,15 @@ ev_window_init (EvWindow *ev_window)
9
9
 
10
10
        ev_window->priv->toolbar = ev_toolbar_new (ev_window);
11
11
        gtk_widget_set_no_show_all (ev_window->priv->toolbar, TRUE);
23
23
        gtk_widget_show (ev_window->priv->toolbar);
24
24
 
25
25
        /* Window title */
26
 
Index: evince-3.16.1/shell/ev-window-title.c
 
26
Index: evince-3.18.1/shell/ev-window-title.c
27
27
===================================================================
28
 
--- evince-3.16.1.orig/shell/ev-window-title.c
29
 
+++ evince-3.16.1/shell/ev-window-title.c
 
28
--- evince-3.18.1.orig/shell/ev-window-title.c
 
29
+++ evince-3.18.1/shell/ev-window-title.c
30
30
@@ -142,7 +142,8 @@ ev_window_title_update (EvWindowTitle *w
31
31
        switch (window_title->type) {
32
32
        case EV_WINDOW_TITLE_DOCUMENT: