~fta/democracy/miro.trunk.xul1.9

« back to all changes in this revision

Viewing changes to debian/patches/22_gutsy_uses_xine_hack.patch

  • Committer: Fabien Tassin
  • Date: 2007-10-06 22:02:34 UTC
  • Revision ID: fta@sofaraway.org-20071006220234-991yv3nc1j7r16zt
* New upstream snapshot from SVN: 20071006r5431
  - add debian/patches/22_gutsy_uses_xine_hack.patch so xine_hack
    is used in Gutsy like it is in Feisty (fixes FTBFS in
    platform/gtk-x11/xine/xine_impl.c introduced in r5415)
  - update debian/patches/series

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
---
 
2
 platform/gtk-x11/setup.py |    7 ++++++-
 
3
 1 file changed, 6 insertions(+), 1 deletion(-)
 
4
 
 
5
Index: miro-1.0~svn20071006r5431/platform/gtk-x11/setup.py
 
6
===================================================================
 
7
--- miro-1.0~svn20071006r5431.orig/platform/gtk-x11/setup.py
 
8
+++ miro-1.0~svn20071006r5431/platform/gtk-x11/setup.py
 
9
@@ -14,33 +14,38 @@
 
10
 # GNU General Public License for more details.
 
11
 #
 
12
 # You should have received a copy of the GNU General Public License
 
13
 # along with this program; if not, write to the Free Software
 
14
 # Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301 USA
 
15
 
 
16
 # This needs to be above Paths and configuration :(
 
17
 #
 
18
-# It currently looks for Debian 4.0 Etch and Ubuntu 7.04 Feisty
 
19
+# It currently looks for Debian 4.0 Etch, Ubuntu 7.04 Feisty and
 
20
+# Ubuntu 7.10 Gutsy
 
21
+
 
22
 def use_xine_hack_default():
 
23
     try:
 
24
         # Non-debian based system will throw an exception here
 
25
         f = open('/etc/debian_version')
 
26
         if f.read().strip() == '4.0': # Debian etch
 
27
             f.close()
 
28
             return True
 
29
         else:
 
30
             # Ubuntu Feisty is Debian based but lists testing/unstable
 
31
             # in /etc/debian_version, so we check /etc/issue
 
32
             f.close()
 
33
             f = open('/etc/issue')
 
34
             osname = f.read()
 
35
             if (osname.find("Ubuntu") > -1) and (osname.find("7.04")>-1):
 
36
                 f.close()
 
37
                 return True
 
38
+            if (osname.find("Ubuntu") > -1) and (osname.find("gutsy")>-1):
 
39
+                f.close()
 
40
+                return True
 
41
     except:
 
42
         pass
 
43
     return False
 
44
 
 
45
 ##############################################################################
 
46
 ## Paths and configuration                                                   ##
 
47
 ###############################################################################
 
48