~gnome3-team/gnome-keyring/ubuntu

« back to all changes in this revision

Viewing changes to debian/patches/0001-Link-directly-to-gmodule-for-the-modules-that-need-i.patch

  • Committer: Laurent Bigonville
  • Date: 2011-03-11 00:10:06 UTC
  • Revision ID: bigon@bigon.be-20110311001006-mqipfshjg0uejlns
* New upstream release
* debian/control.in:
  - Add libcap-dev as build-dependency for linux-any
  - Make gnome-keyring Depends against libcap2-bin for linux-any
* debian/gnome-keyring.postinst:
  - Set CAP_IPC_LOCK capability on gnome-keyring-daemon.
    This would permit gnome-keyring to overcome limits on locked memory
    and prevent private keys to be swapped out.
* debian/libgcr-3-0.symbols, debian/libgck0.symbols: Adjusts symbols files
* d/p/0001-Link-directly-to-gmodule-for-the-modules-that-need-i.patch:
  Drop patches, not needed anymore
* Rename debian/patches/03_use_in_xfce.patch to
  debian/patches/05_use_in_xfce.patch and also start GPG agent for Xfce
* debian/gnome-keyring.install:
  - Drop debian/tmp/usr/share/gnome-keyring/introspect,
    debian/tmp/etc/xdg/pkcs11.conf.defaults

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 595573e2c15b0ee5648cf210621e0d7db2290c56 Mon Sep 17 00:00:00 2001
2
 
From: Sjoerd Simons <sjoerd.simons@collabora.co.uk>
3
 
Date: Sat, 25 Dec 2010 17:59:39 +0100
4
 
Subject: [PATCH] Link directly to gmodule for the modules that need it
5
 
 
6
 
---
7
 
 configure.in                    |    4 ++++
8
 
 pkcs11/roots-store/Makefile.am  |    7 +++++--
9
 
 pkcs11/secret-store/Makefile.am |    4 +++-
10
 
 pkcs11/ssh-store/Makefile.am    |    4 +++-
11
 
 pkcs11/xdg-store/Makefile.am    |    4 +++-
12
 
 5 files changed, 18 insertions(+), 5 deletions(-)
13
 
 
14
 
diff --git a/configure.in b/configure.in
15
 
index 13a9018..30aa88f 100644
16
 
--- a/configure.in
17
 
+++ b/configure.in
18
 
@@ -69,6 +69,10 @@ PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.16.0)
19
 
 AC_SUBST(GLIB_CFLAGS)
20
 
 AC_SUBST(GLIB_LIBS)
21
 
 
22
 
+PKG_CHECK_MODULES(GMODULE, gmodule-no-export-2.0)
23
 
+AC_SUBST(GLIB_CFLAGS)
24
 
+AC_SUBST(GLIB_LIBS)
25
 
+
26
 
 PKG_CHECK_MODULES(GTHREAD, gthread-2.0 >= 2.8.0)
27
 
 AC_SUBST(GTHREAD_CFLAGS)
28
 
 AC_SUBST(GTHREAD_LIBS)
29
 
diff --git a/pkcs11/roots-store/Makefile.am b/pkcs11/roots-store/Makefile.am
30
 
index 1e507ca..034a463 100644
31
 
--- a/pkcs11/roots-store/Makefile.am
32
 
+++ b/pkcs11/roots-store/Makefile.am
33
 
@@ -5,7 +5,9 @@ INCLUDES = \
34
 
        -I$(top_srcdir)/pkcs11 \
35
 
        $(GOBJECT_CFLAGS) \
36
 
        $(LIBGCRYPT_CFLAGS) \
37
 
-       $(GLIB_CFLAGS)
38
 
+       $(GLIB_CFLAGS) \
39
 
+       $(GMODULE_CFLAGS)
40
 
+
41
 
 
42
 
 
43
 
 # ------------------------------------------------------------------------------
44
 
@@ -41,7 +43,8 @@ gkm_roots_store_standalone_la_LIBADD = \
45
 
        $(GOBJECT_LIBS) \
46
 
        $(GTHREAD_LIBS) \
47
 
        $(GLIB_LIBS) \
48
 
-       $(LIBGCRYPT_LIBS)
49
 
+       $(LIBGCRYPT_LIBS) \
50
 
+       $(GMODULE_LIBS)
51
 
 
52
 
 
53
 
 # -------------------------------------------------------------------------------
54
 
diff --git a/pkcs11/secret-store/Makefile.am b/pkcs11/secret-store/Makefile.am
55
 
index 1a6008c..3bb3e89 100644
56
 
--- a/pkcs11/secret-store/Makefile.am
57
 
+++ b/pkcs11/secret-store/Makefile.am
58
 
@@ -4,7 +4,8 @@ INCLUDES = \
59
 
        -I$(top_srcdir) \
60
 
        -I$(top_srcdir)/pkcs11 \
61
 
        $(GOBJECT_CFLAGS) \
62
 
-       $(GLIB_CFLAGS)
63
 
+       $(GLIB_CFLAGS) \
64
 
+       $(GMODULE_CFLAGS)
65
 
 
66
 
 # ------------------------------------------------------------------------------
67
 
 # The secret store component code
68
 
@@ -47,6 +48,7 @@ gkm_secret_store_standalone_la_LIBADD = \
69
 
        $(GOBJECT_LIBS) \
70
 
        $(GTHREAD_LIBS) \
71
 
        $(GLIB_LIBS) \
72
 
+       $(GMODULE_LIBS) \
73
 
        $(LIBGCRYPT_LIBS)
74
 
 
75
 
 # -------------------------------------------------------------------------------
76
 
diff --git a/pkcs11/ssh-store/Makefile.am b/pkcs11/ssh-store/Makefile.am
77
 
index 3626a44..811c8d4 100644
78
 
--- a/pkcs11/ssh-store/Makefile.am
79
 
+++ b/pkcs11/ssh-store/Makefile.am
80
 
@@ -5,7 +5,8 @@ INCLUDES = \
81
 
        -I$(top_srcdir)/pkcs11 \
82
 
        $(GOBJECT_CFLAGS) \
83
 
        $(LIBGCRYPT_CFLAGS) \
84
 
-       $(GLIB_CFLAGS)
85
 
+       $(GLIB_CFLAGS) \
86
 
+       $(GMODULE_CFLAGS)
87
 
 
88
 
 
89
 
 # ------------------------------------------------------------------------------
90
 
@@ -42,6 +43,7 @@ gkm_ssh_store_standalone_la_LIBADD = \
91
 
        $(GOBJECT_LIBS) \
92
 
        $(GTHREAD_LIBS) \
93
 
        $(GLIB_LIBS) \
94
 
+       $(GMODULE_LIBS) \
95
 
        $(LIBGCRYPT_LIBS)
96
 
 
97
 
 
98
 
diff --git a/pkcs11/xdg-store/Makefile.am b/pkcs11/xdg-store/Makefile.am
99
 
index 25c092a..4bdce1f 100644
100
 
--- a/pkcs11/xdg-store/Makefile.am
101
 
+++ b/pkcs11/xdg-store/Makefile.am
102
 
@@ -5,7 +5,8 @@ INCLUDES = \
103
 
        -I$(top_srcdir)/pkcs11 \
104
 
        $(GOBJECT_CFLAGS) \
105
 
        $(LIBGCRYPT_CFLAGS) \
106
 
-       $(GLIB_CFLAGS)
107
 
+       $(GLIB_CFLAGS) \
108
 
+       $(GMODULE_CFLAGS)
109
 
 
110
 
 # ------------------------------------------------------------------------------
111
 
 # The xdg-store component code
112
 
@@ -50,6 +51,7 @@ gkm_xdg_store_standalone_la_LIBADD = \
113
 
        $(GOBJECT_LIBS) \
114
 
        $(GTHREAD_LIBS) \
115
 
        $(GLIB_LIBS) \
116
 
+       $(GMODULE_LIBS) \
117
 
        $(LIBGCRYPT_LIBS)
118
 
 
119
 
 
120
 
1.7.2.3
121