~gnome3-team/gnome-terminal/ubuntu

« back to all changes in this revision

Viewing changes to debian/patches/20_add_alt_screen_toggle_ui.patch

  • Committer: Rico Tzschichholz
  • Date: 2011-03-29 16:53:34 UTC
  • Revision ID: ricotz@t-online.de-20110329165334-llxuw666wiy06ak0
* New upstream release 2.33.90
* debian/rules:
  + add --with-gtk=3.0 to configure flags
* debian/control.in:
  + update build-deps for gtk3
* debian/patches:
  + fix 01_lpi.patch
  + drop 03_libice_link.patch, is upstream 
  + deactivate 02_add_transparency_properties.patch 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Description: Hook new vte alternate screen scrolling toggle via UI
2
2
Author: ?
3
3
 
4
 
Index: gnome-terminal-2.31.90/src/gnome-terminal.schemas.in
 
4
Index: gnome-terminal-2.33.90/src/gnome-terminal.schemas.in
5
5
===================================================================
6
 
--- gnome-terminal-2.31.90.orig/src/gnome-terminal.schemas.in   2010-08-17 17:51:15.740563001 +1000
7
 
+++ gnome-terminal-2.31.90/src/gnome-terminal.schemas.in        2010-08-17 17:59:14.880563001 +1000
 
6
--- gnome-terminal-2.33.90.orig/src/gnome-terminal.schemas.in
 
7
+++ gnome-terminal-2.33.90/src/gnome-terminal.schemas.in
8
8
@@ -418,6 +418,23 @@
9
9
     </schema>
10
10
 
29
29
       <key>/schemas/apps/gnome-terminal/profiles/Default/exit_action</key>
30
30
       <applyto>/apps/gnome-terminal/profiles/Default/exit_action</applyto>
31
31
       <owner>gnome-terminal</owner>
32
 
Index: gnome-terminal-2.31.90/src/profile-editor.c
 
32
Index: gnome-terminal-2.33.90/src/profile-editor.c
33
33
===================================================================
34
 
--- gnome-terminal-2.31.90.orig/src/profile-editor.c    2010-08-17 17:55:18.610563000 +1000
35
 
+++ gnome-terminal-2.31.90/src/profile-editor.c 2010-08-17 17:59:14.880563001 +1000
36
 
@@ -289,6 +289,10 @@
 
34
--- gnome-terminal-2.33.90.orig/src/profile-editor.c
 
35
+++ gnome-terminal-2.33.90/src/profile-editor.c
 
36
@@ -279,6 +279,10 @@
37
37
     SET_SENSITIVE ("scroll-on-output-checkbutton",
38
38
                    !terminal_profile_property_locked (profile, TERMINAL_PROFILE_SCROLL_ON_OUTPUT));
39
39
 
44
44
   if (!prop_name || prop_name == I_(TERMINAL_PROFILE_EXIT_ACTION))
45
45
     SET_SENSITIVE ("exit-action-combobox",
46
46
                    !terminal_profile_property_locked (profile, TERMINAL_PROFILE_EXIT_ACTION));
47
 
@@ -897,6 +901,7 @@
 
47
@@ -899,6 +903,7 @@
48
48
   CONNECT ("scrollbar-position-combobox", TERMINAL_PROFILE_SCROLLBAR_POSITION);
49
49
   CONNECT ("scroll-on-keystroke-checkbutton", TERMINAL_PROFILE_SCROLL_ON_KEYSTROKE);
50
50
   CONNECT ("scroll-on-output-checkbutton", TERMINAL_PROFILE_SCROLL_ON_OUTPUT);
52
52
   CONNECT ("show-menubar-checkbutton", TERMINAL_PROFILE_DEFAULT_SHOW_MENUBAR);
53
53
   CONNECT ("solid-radiobutton", TERMINAL_PROFILE_BACKGROUND_TYPE);
54
54
   CONNECT ("system-font-checkbutton", TERMINAL_PROFILE_USE_SYSTEM_FONT);
55
 
Index: gnome-terminal-2.31.90/src/profile-preferences.glade
 
55
Index: gnome-terminal-2.33.90/src/profile-preferences.glade
56
56
===================================================================
57
 
--- gnome-terminal-2.31.90.orig/src/profile-preferences.glade   2010-08-17 17:51:15.750563001 +1000
58
 
+++ gnome-terminal-2.31.90/src/profile-preferences.glade        2010-08-17 17:59:14.880563001 +1000
59
 
@@ -2436,6 +2436,27 @@
 
57
--- gnome-terminal-2.33.90.orig/src/profile-preferences.glade
 
58
+++ gnome-terminal-2.33.90/src/profile-preferences.glade
 
59
@@ -2416,6 +2416,27 @@
60
60
                </packing>
61
61
              </child>
62
62
 
84
84
              <child>
85
85
                <widget class="GtkCheckButton" id="scroll-on-keystroke-checkbutton">
86
86
                  <property name="visible">True</property>
87
 
Index: gnome-terminal-2.31.90/src/terminal-profile.c
 
87
Index: gnome-terminal-2.33.90/src/terminal-profile.c
88
88
===================================================================
89
 
--- gnome-terminal-2.31.90.orig/src/terminal-profile.c  2010-08-17 17:51:15.740563001 +1000
90
 
+++ gnome-terminal-2.31.90/src/terminal-profile.c       2010-08-17 17:59:14.890563001 +1000
 
89
--- gnome-terminal-2.33.90.orig/src/terminal-profile.c
 
90
+++ gnome-terminal-2.33.90/src/terminal-profile.c
91
91
@@ -75,6 +75,7 @@
92
92
   PROP_SCROLLBAR_POSITION,
93
93
   PROP_SCROLL_ON_KEYSTROKE,
96
96
   PROP_SILENT_BELL,
97
97
   PROP_TITLE,
98
98
   PROP_TITLE_MODE,
99
 
@@ -116,6 +117,7 @@
 
99
@@ -114,6 +115,7 @@
100
100
 #define KEY_SCROLLBAR_POSITION "scrollbar_position"
101
101
 #define KEY_SCROLL_ON_KEYSTROKE "scroll_on_keystroke"
102
102
 #define KEY_SCROLL_ON_OUTPUT "scroll_on_output"
104
104
 #define KEY_SILENT_BELL "silent_bell"
105
105
 #define KEY_TITLE_MODE "title_mode"
106
106
 #define KEY_TITLE "title"
107
 
@@ -157,6 +159,7 @@
 
107
@@ -153,6 +155,7 @@
108
108
 #define DEFAULT_SCROLLBAR_POSITION    (TERMINAL_SCROLLBAR_RIGHT)
109
109
 #define DEFAULT_SCROLL_ON_KEYSTROKE   (TRUE)
110
110
 #define DEFAULT_SCROLL_ON_OUTPUT      (FALSE)
112
112
 #define DEFAULT_SILENT_BELL           (FALSE)
113
113
 #define DEFAULT_TITLE_MODE            (TERMINAL_TITLE_REPLACE)
114
114
 #define DEFAULT_TITLE                 (N_("Terminal"))
115
 
@@ -1304,6 +1307,7 @@
 
115
@@ -1299,6 +1302,7 @@
116
116
   TERMINAL_PROFILE_PROPERTY_BOOLEAN (SCROLLBACK_UNLIMITED, DEFAULT_SCROLLBACK_UNLIMITED, KEY_SCROLLBACK_UNLIMITED);
117
117
   TERMINAL_PROFILE_PROPERTY_BOOLEAN (SCROLL_ON_KEYSTROKE, DEFAULT_SCROLL_ON_KEYSTROKE, KEY_SCROLL_ON_KEYSTROKE);
118
118
   TERMINAL_PROFILE_PROPERTY_BOOLEAN (SCROLL_ON_OUTPUT, DEFAULT_SCROLL_ON_OUTPUT, KEY_SCROLL_ON_OUTPUT);
120
120
   TERMINAL_PROFILE_PROPERTY_BOOLEAN (SILENT_BELL, DEFAULT_SILENT_BELL, KEY_SILENT_BELL);
121
121
   TERMINAL_PROFILE_PROPERTY_BOOLEAN (UPDATE_RECORDS, DEFAULT_UPDATE_RECORDS, KEY_UPDATE_RECORDS);
122
122
   TERMINAL_PROFILE_PROPERTY_BOOLEAN (USE_CUSTOM_COMMAND, DEFAULT_USE_CUSTOM_COMMAND, KEY_USE_CUSTOM_COMMAND);
123
 
Index: gnome-terminal-2.31.90/src/terminal-profile.h
 
123
Index: gnome-terminal-2.33.90/src/terminal-profile.h
124
124
===================================================================
125
 
--- gnome-terminal-2.31.90.orig/src/terminal-profile.h  2010-08-17 17:51:15.740563001 +1000
126
 
+++ gnome-terminal-2.31.90/src/terminal-profile.h       2010-08-17 17:59:14.890563001 +1000
 
125
--- gnome-terminal-2.33.90.orig/src/terminal-profile.h
 
126
+++ gnome-terminal-2.33.90/src/terminal-profile.h
127
127
@@ -93,6 +93,7 @@
128
128
 #define TERMINAL_PROFILE_SCROLLBAR_POSITION     "scrollbar-position"
129
129
 #define TERMINAL_PROFILE_SCROLL_ON_KEYSTROKE    "scroll-on-keystroke"
132
132
 #define TERMINAL_PROFILE_SILENT_BELL            "silent-bell"
133
133
 #define TERMINAL_PROFILE_TITLE_MODE             "title-mode"
134
134
 #define TERMINAL_PROFILE_TITLE                  "title"
135
 
Index: gnome-terminal-2.31.90/src/terminal-screen.c
 
135
Index: gnome-terminal-2.33.90/src/terminal-screen.c
136
136
===================================================================
137
 
--- gnome-terminal-2.31.90.orig/src/terminal-screen.c   2010-08-17 17:58:51.800563000 +1000
138
 
+++ gnome-terminal-2.31.90/src/terminal-screen.c        2010-08-17 17:59:14.890563001 +1000
139
 
@@ -1029,6 +1029,9 @@
 
137
--- gnome-terminal-2.33.90.orig/src/terminal-screen.c
 
138
+++ gnome-terminal-2.33.90/src/terminal-screen.c
 
139
@@ -963,6 +963,9 @@
140
140
   if (!prop_name || prop_name == I_(TERMINAL_PROFILE_SCROLL_ON_OUTPUT))
141
141
     vte_terminal_set_scroll_on_output (vte_terminal,
142
142
                                        terminal_profile_get_property_boolean (profile, TERMINAL_PROFILE_SCROLL_ON_OUTPUT));