~hexmode/ubuntu/lucid/php5/php5.fix-php-bug-33210

« back to all changes in this revision

Viewing changes to debian/patches/119-sybase-alias.patch

  • Committer: Bazaar Package Importer
  • Author(s): Chuck Short
  • Date: 2009-11-06 01:44:25 UTC
  • mfrom: (1.1.15 upstream) (0.3.3 squeeze)
  • Revision ID: james.westby@ubuntu.com-20091106014425-5dsqjhbg303h3kfn
Tags: 5.2.11.dfsg.1-1ubuntu1
* Merge from debian testing, remaining changes:
  - debian/control, debian/rules: Disable a few build dependencies and
    accompanying, binary packages which we do not want to support in main:
    + firebird2-dev/php5-interbase (we have a seperate php-interbase source)
    + libc-client/php5-imap (we have a seperate php-imap source)
    + libmcrypt-dev/php5-mcrypt (seperate php-mycrpt source)
    + readline support again, now that the libedit issue is fixed.
  - debian/control: Add build dependency: libdedit-dev (>= 2.9.cvs.20050518-1)
    CLI readline support.
  - debian/rules:
    + Correctly mangle PHP5_* macros for lpia
  - debian/control:
    + Use libdb-4.6-dev.
    + Rename Vcs-Browser & Vcs-Git to XS-Original-Vcs-Browser & XS-Original-Vcs-Git (LP: #323731).
  - Dropped patches:
    - debian/patches/119-sybase-alias.patch: Use Debian's patch.
    - debian/patches/fix-autoconf-ftbfs.patch: Use Debian's patch
    - debian/patches/fix-zlib-decompression: Already in upstream
  - Use the default pear/install-pear-nozlib.phar in php 5.2.11
  - debian/control: Move php5-suhoshin to Suggests.
  - debian/rules: Fix broken symlink for pear.
  - Dropped dependency on autoconf2.13.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff -Naur php-5.2.6.orig/ext/mssql/php_mssql.c php-5.2.6/ext/mssql/php_mssql.c
2
 
--- php-5.2.6.orig/ext/mssql/php_mssql.c        2008-03-05 23:53:23.000000000 +0000
3
 
+++ php-5.2.6/ext/mssql/php_mssql.c     2008-06-20 14:06:35.000000000 +0000
4
 
@@ -78,6 +78,38 @@
5
 
        PHP_FE(mssql_execute,                           NULL)
6
 
        PHP_FE(mssql_free_statement,            NULL)
7
 
        PHP_FE(mssql_guid_string,                       NULL)
8
 
+#if !defined(PHP_WIN32) && !defined(HAVE_SYBASE_CT)
9
 
+        PHP_FALIAS(sybase_connect, mssql_connect,                           NULL)
10
 
+        PHP_FALIAS(sybase_pconnect, mssql_pconnect,                          NULL)
11
 
+        PHP_FALIAS(sybase_close, mssql_close,                                     NULL)
12
 
+        PHP_FALIAS(sybase_select_db, mssql_select_db,                         NULL)
13
 
+        PHP_FALIAS(sybase_query, mssql_query,                                     NULL)
14
 
+        PHP_FALIAS(sybase_fetch_batch, mssql_fetch_batch,                       NULL)
15
 
+        PHP_FALIAS(sybase_rows_affected, mssql_rows_affected,                     NULL)
16
 
+        PHP_FALIAS(sybase_free_result, mssql_free_result,                       NULL)
17
 
+        PHP_FALIAS(sybase_get_last_message, mssql_get_last_message,          NULL)
18
 
+        PHP_FALIAS(sybase_num_rows, mssql_num_rows,                          NULL)
19
 
+        PHP_FALIAS(sybase_num_fields, mssql_num_fields,                        NULL)
20
 
+        PHP_FALIAS(sybase_fetch_field, mssql_fetch_field,                       NULL)
21
 
+        PHP_FALIAS(sybase_fetch_row, mssql_fetch_row,                         NULL)
22
 
+        PHP_FALIAS(sybase_fetch_array, mssql_fetch_array,                       NULL)
23
 
+        PHP_FALIAS(sybase_fetch_assoc, mssql_fetch_assoc,                       NULL)
24
 
+        PHP_FALIAS(sybase_fetch_object, mssql_fetch_object,                      NULL)
25
 
+        PHP_FALIAS(sybase_field_length, mssql_field_length,                      NULL)
26
 
+        PHP_FALIAS(sybase_field_name, mssql_field_name,                        NULL)
27
 
+        PHP_FALIAS(sybase_field_type, mssql_field_type,                        NULL)
28
 
+        PHP_FALIAS(sybase_data_seek, mssql_data_seek,                         NULL)
29
 
+        PHP_FALIAS(sybase_field_seek, mssql_field_seek,                        NULL)
30
 
+        PHP_FALIAS(sybase_result, mssql_result,                            NULL)
31
 
+        PHP_FALIAS(sybase_next_result, mssql_next_result,                       NULL)
32
 
+        PHP_FALIAS(sybase_min_error_severity, mssql_min_error_severity,        NULL)
33
 
+        PHP_FALIAS(sybase_min_message_severity, mssql_min_message_severity,      NULL)
34
 
+        PHP_FALIAS(sybase_init, mssql_init,                                      NULL)
35
 
+        PHP_FALIAS(sybase_bind, mssql_bind,                                      third_arg_force_ref)
36
 
+        PHP_FALIAS(sybase_execute, mssql_execute,                           NULL)
37
 
+        PHP_FALIAS(sybase_free_statement, mssql_free_statement,            NULL)
38
 
+        PHP_FALIAS(sybase_guid_string, mssql_guid_string,                       NULL)
39
 
+#endif
40
 
        {NULL, NULL, NULL}
41
 
 };
42