~hexmode/ubuntu/lucid/php5/php5.fix-php-bug-33210

« back to all changes in this revision

Viewing changes to debian/patches/deprecated_freetds_check.patch

  • Committer: Bazaar Package Importer
  • Author(s): Marc Deslauriers
  • Date: 2009-11-30 14:13:45 UTC
  • mfrom: (0.3.4 sid)
  • Revision ID: james.westby@ubuntu.com-20091130141345-db35ow8gpyjqn8e0
Tags: 5.2.11.dfsg.1-2ubuntu1
* Merge from debian unstable, remaining changes:
  - debian/control, debian/rules: Disable a few build dependencies and
    accompanying binary packages which we do not want to support in main:
    + firebird2-dev/php5-interbase (we have a seperate php-interbase source)
    + libc-client/php5-imap (we have a seperate php-imap source)
    + libmcrypt-dev/php5-mcrypt (seperate php-mcrypt source)
    + readline support again, now that the libedit issue is fixed.
  - debian/control: Add build dependency: libdedit-dev (>= 2.9.cvs.20050518-1)
    CLI readline support.
  - debian/rules:
    + Correctly mangle PHP5_* macros for lpia
  - debian/control:
    + Rename Vcs-Browser & Vcs-Git to XS-Original-Vcs-Browser & XS-Original-Vcs-Git (LP: #323731).
  - debian/control: Move php5-suhoshin to Suggests.
  - debian/rules: Fix broken symlink for pear.
  - main/php_version.h: updated with Ubuntu version info
* debian/patches/series: Re-enable the 033-we_WANT_libtool.patch patch
* debian/patches/sybase-alias.patch: use the debian patch
* Dropped unapplied patches: fix_64bit_time.patch,
  fix-autoconf-ftbfs.patch, 027-readline_is_editline.patch,
  deprecated_freetds_check.patch, use-specific-libdb-version.patch,
  CVE-2008-5625.patch.
* SECURITY UPDATE: safe_mode bypass via tempam function
  - debian/patches/CVE-2009-3557.patch: check for safe_mode in
    ext/standard/file.c.
  - CVE-2009-3557
* SECURITY UPDATE: open_basedir restrictions bypass via posix_mkfifo
  - debian/patches/CVE-2009-3558.patch: check for open_basedir in
    ext/posix/posix.c.
  - CVE-2009-3558

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff -Naur php-5.2.6.orig/ext/mssql/config.m4 php-5.2.6/ext/mssql/config.m4
2
 
--- php-5.2.6.orig/ext/mssql/config.m4  2007-07-03 13:25:34.000000000 -0400
3
 
+++ php-5.2.6/ext/mssql/config.m4       2008-08-12 13:14:20.000000000 -0400
4
 
@@ -10,11 +10,11 @@
5
 
 
6
 
   if test "$PHP_MSSQL" = "yes"; then
7
 
     for i in /usr/local /usr; do
8
 
-      if test -f $i/include/tds.h; then
9
 
+      if test -f $i/include/sybdb.h; then
10
 
         FREETDS_INSTALLATION_DIR=$i
11
 
         FREETDS_INCLUDE_DIR=$i/include
12
 
         break
13
 
-      elif test -f $i/include/freetds/tds.h; then
14
 
+      elif test -f $i/include/freetds/sybdb.h; then
15
 
         FREETDS_INSTALLATION_DIR=$i
16
 
         FREETDS_INCLUDE_DIR=$i/include/freetds
17
 
         break
18
 
@@ -27,10 +27,10 @@
19
 
 
20
 
   elif test "$PHP_MSSQL" != "no"; then
21
 
 
22
 
-    if test -f $PHP_MSSQL/include/tds.h; then
23
 
+    if test -f $PHP_MSSQL/include/sybdb.h; then
24
 
       FREETDS_INSTALLATION_DIR=$PHP_MSSQL
25
 
       FREETDS_INCLUDE_DIR=$PHP_MSSQL/include
26
 
-    elif test -f $PHP_MSSQL/include/freetds/tds.h; then
27
 
+    elif test -f $PHP_MSSQL/include/freetds/sybdb.h; then
28
 
       FREETDS_INSTALLATION_DIR=$PHP_MSSQL
29
 
       FREETDS_INCLUDE_DIR=$PHP_MSSQL/include/freetds
30
 
     else
31
 
@@ -38,8 +38,8 @@
32
 
     fi
33
 
   fi  
34
 
 
35
 
-  if test ! -r "$FREETDS_INSTALLATION_DIR/$PHP_LIBDIR/libtds.a" && test ! -r "$FREETDS_INSTALLATION_DIR/$PHP_LIBDIR/libtds.so"; then
36
 
-     AC_MSG_ERROR(Could not find $FREETDS_INSTALLATION_DIR/$PHP_LIBDIR/libtds.[a|so])
37
 
+  if test ! -r "$FREETDS_INSTALLATION_DIR/$PHP_LIBDIR/libsybdb.a" && test ! -r "$FREETDS_INSTALLATION_DIR/$PHP_LIBDIR/libsybdb.so"; then
38
 
+     AC_MSG_ERROR(Could not find $FREETDS_INSTALLATION_DIR/$PHP_LIBDIR/libsybdb.[a|so])
39
 
   fi
40
 
 
41
 
   PHP_ADD_INCLUDE($FREETDS_INCLUDE_DIR)
42
 
diff -Naur php-5.2.6.orig/ext/pdo_dblib/config.m4 php-5.2.6/ext/pdo_dblib/config.m4
43
 
--- php-5.2.6.orig/ext/pdo_dblib/config.m4      2007-07-03 13:25:34.000000000 -0400
44
 
+++ php-5.2.6/ext/pdo_dblib/config.m4   2008-08-12 13:14:20.000000000 -0400
45
 
@@ -13,11 +13,11 @@
46
 
   if test "$PHP_PDO_DBLIB" = "yes"; then
47
 
 
48
 
     for i in /usr/local /usr; do
49
 
-      if test -f $i/include/tds.h; then
50
 
+      if test -f $i/include/sybdb.h; then
51
 
         PDO_FREETDS_INSTALLATION_DIR=$i
52
 
         PDO_FREETDS_INCLUDE_DIR=$i/include
53
 
         break
54
 
-      elif test -f $i/include/freetds/tds.h; then
55
 
+      elif test -f $i/include/freetds/sybdb.h; then
56
 
         PDO_FREETDS_INSTALLATION_DIR=$i
57
 
         PDO_FREETDS_INCLUDE_DIR=$i/include/freetds
58
 
         break;
59
 
@@ -30,10 +30,10 @@
60
 
 
61
 
   elif test "$PHP_PDO_DBLIB" != "no"; then
62
 
 
63
 
-    if test -f $PHP_PDO_DBLIB/include/tds.h; then
64
 
+    if test -f $PHP_PDO_DBLIB/include/sybdb.h; then
65
 
       PDO_FREETDS_INSTALLATION_DIR=$PHP_PDO_DBLIB
66
 
       PDO_FREETDS_INCLUDE_DIR=$PHP_PDO_DBLIB/include
67
 
-    elif test -f $PHP_PDO_DBLIB/include/freetds/tds.h; then
68
 
+    elif test -f $PHP_PDO_DBLIB/include/freetds/sybdb.h; then
69
 
       PDO_FREETDS_INSTALLATION_DIR=$PHP_PDO_DBLIB
70
 
       PDO_FREETDS_INCLUDE_DIR=$PHP_PDO_DBLIB/include/freetds
71
 
     else
72
 
@@ -45,8 +45,8 @@
73
 
     PHP_LIBDIR=lib
74
 
   fi
75
 
 
76
 
-  if test ! -r "$PDO_FREETDS_INSTALLATION_DIR/$PHP_LIBDIR/libtds.a" && test ! -r "$PDO_FREETDS_INSTALLATION_DIR/$PHP_LIBDIR/libtds.so"; then
77
 
-     AC_MSG_ERROR(Could not find $PDO_FREETDS_INSTALLATION_DIR/$PHP_LIBDIR/libtds.[a|so])
78
 
+  if test ! -r "$PDO_FREETDS_INSTALLATION_DIR/$PHP_LIBDIR/libsybdb.a" && test ! -r "$PDO_FREETDS_INSTALLATION_DIR/$PHP_LIBDIR/libsybdb.so"; then
79
 
+     AC_MSG_ERROR(Could not find $PDO_FREETDS_INSTALLATION_DIR/$PHP_LIBDIR/libsybdb.[a|so])
80
 
   fi
81
 
 
82
 
   PHP_ADD_INCLUDE($PDO_FREETDS_INCLUDE_DIR)