~james-page/ubuntu/precise/openmpi1.5/new

« back to all changes in this revision

Viewing changes to debian/patches/alpha_build

  • Committer: Bazaar Package Importer
  • Author(s): Manuel Prinz
  • Date: 2009-04-23 14:01:21 UTC
  • mfrom: (1.1.8 upstream)
  • Revision ID: james.westby@ubuntu.com-20090423140121-vsi3pqa6g30j4qiy
Tags: 1.3.2-1
* New upstream release. (Closes: #520597, #515116)
  - Manpage and VampirTrace patches removed, included upstream.
* Fixed build issues on Alpha. Huge thanks to Arthur Loiret for providing
  access to his machines for testing! (Closes: #510845, #517543)
* Fixed build issues on Sparc. (Closes: #519725)
* Fixed manpage-has-errors-from-man lintian warnings.
* Faked SONAME change by renaming library package. (Closes: #512616)
* Made libopenmpi-dev depend on libibverbs-dev. (Closes: #522153)
* Support for "nocheck" build option in debian/rules.
* Updated Standards-Version in debian/control.
* Changed section of libopenmpi-dbg to "debug".
* Updated debian/copyright.

* Dirk Eddelbuettel removed himself from Uploaders. The team thanks Dirk
  for his long-term contribution and effort to get Open MPI back to life.
  I personally thank Dirk for encouraging me to become a Debian Developer
  and his support and mentoring on that way and beyond.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- a/ompi/contrib/vt/vt/vtlib/vt_pform_linux.c
 
2
+++ b/ompi/contrib/vt/vt/vtlib/vt_pform_linux.c
 
3
@@ -170,6 +170,8 @@
 
4
 # elif defined(__ia64__)
 
5
     /* ... ITC */
 
6
     clock_value = __getReg(_IA64_REG_AR_ITC);
 
7
+# elif defined(__alpha__)
 
8
+    asm volatile ("rpcc %0" : "=r" (clock_value));
 
9
 # else
 
10
     /* ... TSC */
 
11
     {
 
12
--- a/opal/asm/base/ALPHA.asm
 
13
+++ b/opal/asm/base/ALPHA.asm
 
14
@@ -197,3 +197,28 @@
 
15
        addl $31,$0,$0
 
16
        ret $31,($26),1
 
17
        .end opal_atomic_cmpset_rel_64
 
18
+       .align 2
 
19
+       .align 4
 
20
+       .globl opal_sys_timer_get_cycles
 
21
+       .ent opal_sys_timer_get_cycles
 
22
+$opal_sys_timer_get_cycles..ng:
 
23
+opal_sys_timer_get_cycles:
 
24
+       .eflag 48
 
25
+       .frame $30,0,$26,0
 
26
+       .prologue 0
 
27
+       .set    macro
 
28
+       wmb
 
29
+       1:  ldq_l $0, 0($16)     
 
30
+       cmpeq $0, $17, $0     
 
31
+       beq $0, 2f           
 
32
+       mov $18, $0           
 
33
+       stq_c $0, 0($16)         
 
34
+       beq $0, 1b           
 
35
+       jmp 3f               
 
36
+2:  mov $31, $0      
 
37
+3:                   
 
38
+
 
39
+       .set    nomacro
 
40
+       rpcc $0
 
41
+       ret
 
42
+       .end opal_sys_timer_get_cycles
 
43
--- a/opal/asm/generated/atomic-alpha-linux.s
 
44
+++ b/opal/asm/generated/atomic-alpha-linux.s
 
45
@@ -197,5 +197,30 @@
 
46
        addl $31,$0,$0
 
47
        ret $31,($26),1
 
48
        .end opal_atomic_cmpset_rel_64
 
49
+       .align 2
 
50
+       .align 4
 
51
+       .globl opal_sys_timer_get_cycles
 
52
+       .ent opal_sys_timer_get_cycles
 
53
+$opal_sys_timer_get_cycles..ng:
 
54
+opal_sys_timer_get_cycles:
 
55
+       .eflag 48
 
56
+       .frame $30,0,$26,0
 
57
+       .prologue 0
 
58
+       .set    macro
 
59
+       wmb
 
60
+       1:  ldq_l $0, 0($16)     
 
61
+       cmpeq $0, $17, $0     
 
62
+       beq $0, 2f           
 
63
+       mov $18, $0           
 
64
+       stq_c $0, 0($16)         
 
65
+       beq $0, 1b           
 
66
+       jmp 3f               
 
67
+2:  mov $31, $0      
 
68
+3:                   
 
69
+
 
70
+       .set    nomacro
 
71
+       rpcc $0
 
72
+       ret
 
73
+       .end opal_sys_timer_get_cycles
 
74
 
 
75
        .section        .note.GNU-stack,"",@progbits