~james-page/ubuntu/raring/dovecot/autopkgtest

« back to all changes in this revision

Viewing changes to debian/patches/dovecot-drac.patch

  • Committer: Package Import Robot
  • Author(s): James Page
  • Date: 2012-06-11 11:11:54 UTC
  • mfrom: (1.15.2) (4.1.27 sid)
  • Revision ID: package-import@ubuntu.com-20120611111154-678cwbdj6ktgsv1h
Tags: 1:2.1.7-1ubuntu1
* Merge from Debian unstable, remaining changes:
  + Add mail-stack-delivery package:
    - Update d/rules
    - d/control: convert existing dovecot-postfix package to a dummy
      package and add new mail-stack-delivery package.
    - Update maintainer scripts.
    - Rename d/dovecot-postfix.* to debian/mail-stack-delivery.*
    - d/mail-stack-delivery.preinst: Move previously installed backups and
      config files to a new package namespace.
    - d/mail-stack-delivery.prerm: Added to handle downgrades.
  + Use Snakeoil SSL certificates by default:
    - d/control: Depend on ssl-cert.
    - d/dovecot-core.postinst: Relax grep for SSL_* a bit.
  + Add autopkgtest to debian/tests/*.
  + Add ufw integration:
    - d/dovecot-core.ufw.profile: new ufw profile.
    - d/rules: install profile in dovecot-core.
    - d/control: dovecot-core - suggest ufw.
  + d/{control,rules}: enable PIE hardening.
  + d/dovecot-core.dirs: Added usr/share/doc/dovecot-core
  + Add apport hook:
    - d/rules, d/source_dovecot.py
  + Add upstart job:
    - d/rules, d/dovecot-core.dovecot.upstart, d/control,
      d/dovecot-core.dirs, dovecot-imapd.{postrm, postinst, prerm},
      d/dovecot-pop3d.{postinst, postrm, prerm}.
      d/mail-stack-deliver.postinst: Convert init script to upstart.
  + d/control: Added Pre-Depends: dpkg (>= 1.15.6) to dovecot-dbg to support
    xz compression in Ubuntu.
  + d/control: Demote dovecot-common Recommends: to Suggests: to prevent
    install of extra packages on upgrade.
  + d/patches/dovecot-drac.patch: Updated with version for dovecot >= 2.0.0.
  + d/control: Drop B-D on systemd.
* Dropped changes:
  + d/patches/fix-racey-restart.patch: part of 2.1.x, no longer required.

Show diffs side-by-side

added added

removed removed

Lines of Context:
5
5
Index: dovecot/src/plugins/drac/Makefile
6
6
===================================================================
7
7
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
8
 
+++ dovecot/src/plugins/drac/Makefile   2012-04-04 13:24:52.094602332 +0100
9
 
@@ -0,0 +1,18 @@
 
8
+++ dovecot/src/plugins/drac/Makefile   2012-06-11 12:11:31.637726803 +0100
 
9
@@ -0,0 +1,19 @@
10
10
+DOVDIR:=../../..
11
11
+LIBS:=-ldrac
12
12
+
13
 
+CFLAGS=-Wall -W -shared -fPIC -DHAVE_CONFIG_H -I$(DOVDIR) \
 
13
+local_CFLAGS=-Wall -W -shared -fPIC -DHAVE_CONFIG_H
 
14
+INC=-I$(DOVDIR) \
14
15
+       -I$(DOVDIR)/src/lib \
15
16
+       -I$(DOVDIR)/src/lib-index \
16
17
+       -I$(DOVDIR)/src/lib-mail \
21
22
+all: drac_plugin.so
22
23
+
23
24
+drac_plugin.so: drac-plugin.c
24
 
+       $(CC) $(CFLAGS) $(LDFLAGS) $< -o $@ $(LIBS)
 
25
+       $(CC) $(CFLAGS) $(local_CFLAGS) $(INC) $(LDFLAGS) $< -o $@ $(LIBS)
25
26
+
26
27
+clean:
27
28
+       @rm -f *.so *.o
28
29
Index: dovecot/src/plugins/drac/drac-plugin.c
29
30
===================================================================
30
31
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
31
 
+++ dovecot/src/plugins/drac/drac-plugin.c      2012-04-04 13:12:15.114933535 +0100
 
32
+++ dovecot/src/plugins/drac/drac-plugin.c      2012-06-11 11:23:20.632524345 +0100
32
33
@@ -0,0 +1,108 @@
33
34
+/*
34
35
+ *