~james-page/ubuntu/vivid/ceph/0.93

« back to all changes in this revision

Viewing changes to debian/patches/arch.patch

  • Committer: james.page at ubuntu
  • Date: 2015-03-02 08:41:36 UTC
  • Revision ID: james.page@ubuntu.com-20150302084136-pt6i3vanjmamkrkq
* New upstream release candidate for Hammer stable release (LP: #1423601).
  - d/control,python-*: Split out rbd, rados and cephfs bindings into
    separate python packages, move some bits into ceph/ceph-common.
  - d/control: Move python-flask dependency to ceph package, only required
    for REST API.
  - d/control: Add BD on yasm for amd64 only.

Show diffs side-by-side

added added

removed removed

Lines of Context:
6
6
 
7
7
--- a/configure.ac
8
8
+++ b/configure.ac
9
 
@@ -86,9 +86,9 @@
10
 
 
11
 
 # Check for yasm
12
 
 if yasm -f elf64 src/common/crc32c_intel_fast_asm.S -o /dev/null; then
13
 
    echo 'we have a modern and working yasm'
14
 
-   if test `arch` = "x86_64" ; then
15
 
+   if test `dpkg-architecture -qDEB_BUILD_GNU_CPU` = "x86_64" ; then
16
 
       echo 'we are x86_64'
17
 
       arch_x32=0
18
 
       AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [[
19
 
         #if defined(__x86_64__) && defined(__ILP32__)
 
9
@@ -91,7 +91,7 @@ AC_CHECK_PROG(YASM_CHECK, yasm, yes)
 
10
 if test x"$YASM_CHECK" = x"yes"; then
 
11
   if yasm -f elf64 src/common/crc32c_intel_fast_asm.S -o /dev/null; then
 
12
      echo 'we have a modern and working yasm'
 
13
-     if test `arch` = "x86_64" ; then
 
14
+     if test `dpkg-architecture -qDEB_BUILD_GNU_CPU` = "x86_64" ; then
 
15
         echo 'we are x86_64'
 
16
         arch_x32=0
 
17
         AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [[