~javier-lopez/ubuntu/vivid/ruby1.9.1/fix-1426828

« back to all changes in this revision

Viewing changes to debian/patches/2013-09-08-restore-rb_f_lambda-declaration.patch

  • Committer: Package Import Robot
  • Author(s): Marc Deslauriers
  • Date: 2013-11-25 09:59:41 UTC
  • mfrom: (21.1.13 sid)
  • Revision ID: package-import@ubuntu.com-20131125095941-aou3ymnwm79em09y
Tags: 1.9.3.448-1ubuntu1
* Merge from Debian. Remaining changes:
  - debian/control: Add ca-certificates to libruby1.9.1 depends so that
    rubygems can perform certificate verification
  - debian/rules: Don't install SSL certificates from upstream sources
  - debian/patches/20120927-rubygems_disable_upstream_certs.patch: Use
    /etc/ssl/certs/ca-certificates.crt for the trusted CA certificates.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- a/include/ruby/intern.h
 
2
+++ b/include/ruby/intern.h
 
3
@@ -351,6 +351,7 @@ void rb_obj_call_init(VALUE, int, VALUE*
 
4
 VALUE rb_class_new_instance(int, VALUE*, VALUE);
 
5
 VALUE rb_block_proc(void);
 
6
 VALUE rb_block_lambda(void);
 
7
+DEPRECATED(VALUE rb_f_lambda(void));
 
8
 VALUE rb_proc_new(VALUE (*)(ANYARGS/* VALUE yieldarg[, VALUE procarg] */), VALUE);
 
9
 VALUE rb_obj_is_proc(VALUE);
 
10
 VALUE rb_proc_call(VALUE, VALUE);