~jbicha/firefox/dont-depend-on-gtk2

« back to all changes in this revision

Viewing changes to debian/patches/ppc-no-static-sizes.patch

  • Committer: Rico Tzschichholz
  • Date: 2017-11-11 09:22:52 UTC
  • Revision ID: ricotz@ubuntu.com-20171111092252-wvf528q8spzj01px
* New upstream release from the beta channel (FIREFOX_58_0b2_BUILD1)
* Bump build-dep on rustc >= 1.21.0 and cargo >= 0.22
* Update patches
  - debian/patches/ppc-no-static-sizes.patch
  - debian/patches/unity-menubar.patch
  - debian/patches/allow-lockPref-everywhere.patch
  - debian/patches/revert-upstream-search-engine-changes.patch
  - debian/patches/warn-only-on-duplicates.patch
* Drop upstreamed/obsolete patches
  - debian/patches/build-ppc64-s390x-nss.patch
  - debian/patches/build-ppc64-s390x-rust.patch
* Update make-langpack-xpis target
  - debian/build/rules.mk
* Build language packs based on web extensions
  - debian/build/xpi-id.py
* Bump debhelper compat level to 9
* Drop 12.04/Precise specific changes
* Update copyright and license files
* Install watermark.svg from the onbording extension as symbolic icon
  - debian/build/rules.mk 
  - debian/firefox.dirs.in
* mozbuild/shellutil.py: Don't treat '~' character as special
  - debian/patches/dont-treat-tilde-as-special.patch
* Add Nepali language pack
  - update debian/config/locales.all
  - update debian/config/locales.shipped
  - update debian/control
* Don't pass -mfloat-abi=softfp when building webrtc on armhf
  - add debian/patches/webrtc-fix-compiler-flags-for-armhf.patch
  - update debian/patches/series
* Backport some skia fixes to fix a build failure on aarch64 against
  kernel headers that don't define HWCAP_CRC32
  - add debian/patches/skia-fix-aarch64-build-on-older-linux.patch
  - update debian/patches/series
* Refresh and re-enable unity-menubar.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
6
6
The PowerPC architecture allows various memory page sizes, making it impossible
7
7
to predict the runtime page size.
8
8
 
9
 
diff --git a/memory/build/mozjemalloc.cpp b/memory/build/mozjemalloc.cpp
10
 
--- a/memory/build/mozjemalloc.cpp
11
 
+++ b/memory/build/mozjemalloc.cpp
12
 
@@ -1083,17 +1083,18 @@ struct arena_s {
13
 
  * Data.
14
 
  */
15
 
 
16
 
 /*
17
 
  * When MALLOC_STATIC_SIZES is defined most of the parameters
18
 
  * controlling the malloc behavior are defined as compile-time constants
19
 
  * for best performance and cannot be altered at runtime.
20
 
  */
21
 
-#if !defined(__ia64__) && !defined(__sparc__) && !defined(__mips__) && !defined(__aarch64__)
22
 
+#if !defined(__ia64__) && !defined(__sparc__) && !defined(__mips__) && !defined(__aarch64__) && \
23
 
+    !defined(__powerpc__) && !defined(__powerpc64__)
24
 
 #define MALLOC_STATIC_SIZES 1
25
 
 #endif
26
 
 
27
 
 #ifdef MALLOC_STATIC_SIZES
28
 
 
29
 
 /*
30
 
  * VM page size. It must divide the runtime CPU page size or the code
31
 
  * will abort.
 
9
Index: firefox-trunk-58.0~a1~hg20171030r388986/memory/build/mozjemalloc.cpp
 
10
===================================================================
 
11
--- firefox-trunk-58.0~a1~hg20171030r388986.orig/memory/build/mozjemalloc.cpp
 
12
+++ firefox-trunk-58.0~a1~hg20171030r388986/memory/build/mozjemalloc.cpp
 
13
@@ -369,7 +369,7 @@
 
14
 // Debug builds are opted out too, for test coverage.
 
15
 #ifndef MOZ_DEBUG
 
16
 #if !defined(__ia64__) && !defined(__sparc__) && !defined(__mips__) &&         \
 
17
-  !defined(__aarch64__)
 
18
+  !defined(__aarch64__) && !defined(__powerpc__) && !defined(__powerpc64__)
 
19
 #define MALLOC_STATIC_PAGESIZE 1
 
20
 #endif
 
21
 #endif