~jbicha/firefox/update-dependencies

« back to all changes in this revision

Viewing changes to debian/patches/test-fixes/mochitest-browser-plugincrash-with-no-crashreporter.patch

  • Committer: Chris Coulson
  • Date: 2013-09-17 11:05:10 UTC
  • mto: This revision was merged to the branch mainline in revision 1023.
  • Revision ID: chris.coulson@canonical.com-20130917110510-chob2tiw2glco8b9
* New upstream release from the beta channel (FIREFOX_25_0b1_BUILD1)
* Refresh patches
  - update d/p/test-fixes/xpcshell-docshell-no-writes-to-appdir.patch
  - update d/p/test-integration/xpcshell-write-time-for-failed-test.patch
  - update debian/patches/ubuntu-ua-string-changes.patch
  - update d/p/test-fixes/xpcshell-exthandler-no-writes-to-appdir.patch
  - update d/p/test-integration/automation-output-junit-xml.patch
  - update d/p/test-integration/mochitest-allow-test-manifest-for-browser-chrome.patch
  - update d/p/test-integration/xpcshell-disable-tests-which-need-appdir-write-access.patch
  - update debian/patches/unity-menubar.patch
* Drop patches
  - remove d/p/test-fixes/xpcshell-docshell-no-writes-to-appdir.patch
  - remove d/p/test-fixes/xpcshell-contentprefs-no-writes-to-appdir.patch
  - remove d/p/test-fixes/mochitest-browser-plugincrash-with-no-crashreporter.patch
  - update debian/patches/series
* Refactor the test results post-process script a bit so that it can use
  regular expressions in the configuration
  - update debian/testing/filter_results
  - update debian/testing/results-filter-manifest.json
  - update debian/tests/post-process
* Run mochitest-plain in 5 chunks, similar to upstream. This should fix
  some test failures we see that seem to be caused by some tests not
  cleaning up properly (seems to fix LP: #1158781 and LP: #1194448)
  - update debian/testing/run_mochitest.in
  - update debian/tests/control
  - move debian/tests/mochitest => debian/tests/mochitest-1
  - add debian/tests/mochitest-2
  - add debian/tests/mochitest-3
  - add debian/tests/mochitest-4
  - add debian/tests/mochitest-5
* Drop d/p/test-integration/test-sameoriginpolicy-debug.patch now that
  we run mochitest-plain in chunks
* Add OCSPStaplingServer binary to testsuite
  - update debian/firefox-testsuite.install.in
  - update debian/build/rules.mk
* Don't let make check failures fail the build for now, as there are some
  jit test failures
  - update debian/build/testsuite.mk
* Try to stop the buildd's from terminating the build during long links
  (use a hack based on the one for the Chromium package)
  - add debian/build/keepalive-wrapper.py
  - update debian/build/rules.mk
* Disable no_neon_on_arm.patch for now

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Skip browser_pluginCrashCommentAndURL.js when the crash reporter
2
 
 is disabled
3
 
Author: Chris Coulson <chris.coulson@canonical.com>
4
 
Forwarded: no
5
 
 
6
 
Index: firefox-trunk-24.0~a1~hg20130623r136205/browser/base/content/test/Makefile.in
7
 
===================================================================
8
 
--- firefox-trunk-24.0~a1~hg20130623r136205.orig/browser/base/content/test/Makefile.in  2013-06-24 11:07:46.684414428 +0100
9
 
+++ firefox-trunk-24.0~a1~hg20130623r136205/browser/base/content/test/Makefile.in       2013-06-24 11:08:54.980415525 +0100
10
 
@@ -327,8 +327,6 @@
11
 
                  browser_pageInfo_plugins.js \
12
 
                  browser_pageInfo.js \
13
 
                  feed_tab.html \
14
 
-                 browser_pluginCrashCommentAndURL.js \
15
 
-                 pluginCrashCommentAndURL.html \
16
 
                  browser_private_no_prompt.js \
17
 
                  browser_blob-channelname.js \
18
 
                  browser_aboutHealthReport.js \
19
 
@@ -338,6 +336,13 @@
20
 
                  offlineQuotaNotification.cacheManifest \
21
 
                  $(NULL)
22
 
 
23
 
+ifdef MOZ_CRASHREPORTER
24
 
+MOCHITEST_BROWSER_FILES += \
25
 
+                browser_pluginCrashCommentAndURL.js \
26
 
+                pluginCrashCommentAndURL.html \
27
 
+                               $(NULL)
28
 
+endif
29
 
+
30
 
 # Disable tests on Windows due to frequent failures (bugs 825739, 841341)
31
 
 ifneq (windows,$(MOZ_WIDGET_TOOLKIT))
32
 
 MOCHITEST_BROWSER_FILES += \