~jbicha/firefox/update-dependencies

« back to all changes in this revision

Viewing changes to debian/patches/allow-lockPref-everywhere.patch

  • Committer: Rico Tzschichholz
  • Date: 2017-11-14 11:59:37 UTC
  • Revision ID: ricotz@ubuntu.com-20171114115937-eec02juysofd8419
* New upstream release from the beta channel (FIREFOX_58_0b3_BUILD2)
* Adapt to upstream and use ./mach
  - debian/build/rules.mk
* Install EmojiOneMozilla.ttf (LP: #1644021)
  - debian/firefox.install.in
* Update patches
  - debian/patches/allow-lockPref-everywhere.patch
  - debian/patches/revert-upstream-search-engine-changes.patch
* Update revert-upstream-search-engine-changes.patch to ensure we keep the
  region overrides for non-Google plugins
* Update AppArmor profile

Show diffs side-by-side

added added

removed removed

Lines of Context:
3
3
Bug: https://bugzilla.mozilla.org/show_bug.cgi?id=467738
4
4
Forwarded: https://bugzilla.mozilla.org/attachment.cgi?id=351145
5
5
 
6
 
Index: firefox-trunk-58.0~a1~hg20171027r388661/modules/libpref/Preferences.cpp
 
6
Index: firefox-trunk-58.0~a1~hg20171110r391326/modules/libpref/Preferences.cpp
7
7
===================================================================
8
 
--- firefox-trunk-58.0~a1~hg20171027r388661.orig/modules/libpref/Preferences.cpp
9
 
+++ firefox-trunk-58.0~a1~hg20171027r388661/modules/libpref/Preferences.cpp
10
 
@@ -1280,7 +1280,8 @@
 
8
--- firefox-trunk-58.0~a1~hg20171110r391326.orig/modules/libpref/Preferences.cpp
 
9
+++ firefox-trunk-58.0~a1~hg20171110r391326/modules/libpref/Preferences.cpp
 
10
@@ -1185,7 +1185,8 @@
11
11
                     PrefValue aValue,
12
12
                     PrefType aType,
13
13
                     bool aIsDefault,
17
17
 {
18
18
   uint32_t flags = 0;
19
19
   if (aIsDefault) {
20
 
@@ -1292,6 +1293,8 @@
 
20
@@ -1197,6 +1198,8 @@
21
21
     flags |= kPrefForceSet;
22
22
   }
23
 
   pref_HashPref(aPref, aValue, aType, flags);
 
23
   pref_SetPref(aPref, aValue, aType, flags);
24
24
+  if (aIsLocked)
25
25
+    PREF_LockPref(aPref, true);
26
26
 }
27
27
 
28
28
 //===========================================================================
29
 
@@ -1313,7 +1316,8 @@
 
29
@@ -1218,7 +1221,8 @@
30
30
                            PrefValue aValue,
31
31
                            PrefType aType,
32
32
                            bool aIsDefault,
36
36
 
37
37
 // Report any errors or warnings we encounter during parsing.
38
38
 typedef void (*PrefParseErrorReporter)(const char* aMessage,
39
 
@@ -1341,6 +1345,7 @@
 
39
@@ -1246,6 +1250,7 @@
40
40
   PrefType mVtype;       // PREF_{STRING,INT,BOOL}
41
41
   bool mIsDefault;       // true if (default) pref
42
42
   bool mIsStickyDefault; // true if (sticky) pref
44
44
 };
45
45
 
46
46
 // Pref parser states.
47
 
@@ -1370,6 +1375,7 @@
 
47
@@ -1275,6 +1280,7 @@
48
48
 #define BITS_PER_HEX_DIGIT 4
49
49
 
50
50
 static const char kUserPref[] = "user_pref";
52
52
 static const char kPref[] = "pref";
53
53
 static const char kPrefSticky[] = "sticky_pref";
54
54
 static const char kTrue[] = "true";
55
 
@@ -1517,6 +1523,7 @@
 
55
@@ -1422,6 +1428,7 @@
56
56
           aPS->mVtype = PrefType::Invalid;
57
57
           aPS->mIsDefault = false;
58
58
           aPS->mIsStickyDefault = false;
60
60
         }
61
61
         switch (c) {
62
62
           case '/': // begin comment block or line?
63
 
@@ -1527,11 +1534,14 @@
 
63
@@ -1432,11 +1439,14 @@
64
64
             break;
65
65
           case 'u': // indicating user_pref
66
66
           case 's': // indicating sticky_pref
75
75
             } else {
76
76
               aPS->mStrMatch = kPref;
77
77
             }
78
 
@@ -1580,8 +1590,9 @@
 
78
@@ -1485,8 +1495,9 @@
79
79
       case PREF_PARSE_UNTIL_NAME:
80
80
         if (c == '\"' || c == '\'') {
81
81
           aPS->mIsDefault =
86
86
           aPS->mQuoteChar = c;
87
87
           aPS->mNextState = PREF_PARSE_UNTIL_COMMA; // return here when done
88
88
           state = PREF_PARSE_QUOTED_STRING;
89
 
@@ -1910,7 +1921,8 @@
 
89
@@ -1815,7 +1826,8 @@
90
90
                        value,
91
91
                        aPS->mVtype,
92
92
                        aPS->mIsDefault,