~jbicha/gnome-games/3.1.91

« back to all changes in this revision

Viewing changes to debian/patches/01_lpi.patch

  • Committer: Sebastien Bacher
  • Date: 2011-07-27 16:15:45 UTC
  • mfrom: (101.1.2 oneiric)
  • Revision ID: seb128@ubuntu.com-20110727161545-qsqpdff2bxxbfy71
Tags: 1:3.1.4-0ubuntu1
releasing version 1:3.1.4-0ubuntu1

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Description: Add Launchpad integration
2
2
Forwarded: Not needed
3
 
Index: gnome-games-3.1.3/glines/glines.c
 
3
Index: gnome-games-3.1.4/glines/glines.c
4
4
===================================================================
5
 
--- gnome-games-3.1.3.orig/glines/glines.c      2011-06-21 17:41:58.000000000 -0400
6
 
+++ gnome-games-3.1.3/glines/glines.c   2011-07-20 04:13:37.211131899 -0400
 
5
--- gnome-games-3.1.4.orig/glines/glines.c      2011-07-26 20:24:28.332322154 -0400
 
6
+++ gnome-games-3.1.4/glines/glines.c   2011-07-26 20:24:37.242536497 -0400
7
7
@@ -33,6 +33,7 @@
8
8
 #include <glib/gi18n.h>
9
9
 #include <gtk/gtk.h>
30
30
   scoreitem = gtk_ui_manager_get_widget (ui_manager,
31
31
                                          "/MainMenu/GameMenu/Scores");
32
32
   menubar = gtk_ui_manager_get_widget (ui_manager, "/MainMenu");
33
 
Index: gnome-games-3.1.3/gnect/src/main.c
 
33
Index: gnome-games-3.1.4/gnect/src/main.c
34
34
===================================================================
35
 
--- gnome-games-3.1.3.orig/gnect/src/main.c     2011-06-20 15:25:48.000000000 -0400
36
 
+++ gnome-games-3.1.3/gnect/src/main.c  2011-07-20 04:13:37.211131899 -0400
 
35
--- gnome-games-3.1.4.orig/gnect/src/main.c     2011-07-26 20:24:28.392323591 -0400
 
36
+++ gnome-games-3.1.4/gnect/src/main.c  2011-07-26 20:24:37.242536497 -0400
37
37
@@ -27,6 +27,7 @@
38
38
 
39
39
 #include <glib/gi18n.h>
42
42
 
43
43
 #include <libgames-support/games-conf.h>
44
44
 #include <libgames-support/games-gridframe.h>
45
 
@@ -1294,6 +1295,7 @@
 
45
@@ -1224,6 +1225,7 @@
46
46
   "    </menu>"
47
47
   "    <menu action='HelpMenu'>"
48
48
   "      <menuitem action='Contents'/>"
50
50
   "      <menuitem action='About'/>" "    </menu>" "  </menubar>" "</ui>";
51
51
 
52
52
 
53
 
@@ -1313,6 +1315,9 @@
 
53
@@ -1243,6 +1245,9 @@
54
54
   gtk_ui_manager_insert_action_group (ui_manager, action_group, 0);
55
55
   gtk_ui_manager_add_ui_from_string (ui_manager, ui_description, -1, NULL);
56
56
 
60
60
   gtk_window_add_accel_group (GTK_WINDOW (app),
61
61
                              gtk_ui_manager_get_accel_group (ui_manager));
62
62
 
63
 
Index: gnome-games-3.1.3/gnibbles/main.c
 
63
Index: gnome-games-3.1.4/gnibbles/main.c
64
64
===================================================================
65
 
--- gnome-games-3.1.3.orig/gnibbles/main.c      2011-06-20 15:25:48.000000000 -0400
66
 
+++ gnome-games-3.1.3/gnibbles/main.c   2011-07-20 04:13:37.281133523 -0400
 
65
--- gnome-games-3.1.4.orig/gnibbles/main.c      2011-07-26 20:24:28.422324314 -0400
 
66
+++ gnome-games-3.1.4/gnibbles/main.c   2011-07-26 20:24:37.242536497 -0400
67
67
@@ -29,6 +29,7 @@
68
68
 #include <glib/gi18n.h>
69
69
 #include <gtk/gtk.h>
72
72
 
73
73
 #include <libgames-support/games-conf.h>
74
74
 #include <libgames-support/games-gridframe.h>
75
 
@@ -732,6 +733,7 @@
 
75
@@ -635,6 +636,7 @@
76
76
   "    </menu>"
77
77
   "    <menu action='HelpMenu'>"
78
78
   "      <menuitem action='Contents'/>"
80
80
   "      <menuitem action='About'/>"
81
81
   "    </menu>"
82
82
   "  </menubar>"
83
 
@@ -751,6 +753,9 @@
 
83
@@ -654,6 +656,9 @@
84
84
   gtk_ui_manager_insert_action_group (ui_manager, action_group, 0);
85
85
   gtk_ui_manager_add_ui_from_string (ui_manager, ui_description, -1, NULL);
86
86
 
90
90
   new_game_action = gtk_action_group_get_action (action_group, "NewGame");
91
91
   scores_action = gtk_action_group_get_action (action_group, "Scores");
92
92
   end_game_action = gtk_action_group_get_action (action_group, "EndGame");
93
 
Index: gnome-games-3.1.3/gnobots2/menu.c
 
93
Index: gnome-games-3.1.4/gnobots2/menu.c
94
94
===================================================================
95
 
--- gnome-games-3.1.3.orig/gnobots2/menu.c      2011-06-20 15:25:48.000000000 -0400
96
 
+++ gnome-games-3.1.3/gnobots2/menu.c   2011-07-20 04:13:37.321134459 -0400
 
95
--- gnome-games-3.1.4.orig/gnobots2/menu.c      2011-07-26 20:24:28.252320220 -0400
 
96
+++ gnome-games-3.1.4/gnobots2/menu.c   2011-07-26 20:24:37.242536497 -0400
97
97
@@ -25,6 +25,7 @@
98
98
 
99
99
 #include <glib/gi18n.h>
120
120
   scores_action = gtk_action_group_get_action (action_group, "Scores");
121
121
   teleport_action = gtk_action_group_get_action (action_group, "Teleport");
122
122
   random_action = gtk_action_group_get_action (action_group, "Random");
123
 
Index: gnome-games-3.1.3/quadrapassel/tetris.cpp
 
123
Index: gnome-games-3.1.4/quadrapassel/tetris.cpp
124
124
===================================================================
125
 
--- gnome-games-3.1.3.orig/quadrapassel/tetris.cpp      2011-06-20 15:25:49.000000000 -0400
126
 
+++ gnome-games-3.1.3/quadrapassel/tetris.cpp   2011-07-20 04:13:37.321134459 -0400
 
125
--- gnome-games-3.1.4.orig/quadrapassel/tetris.cpp      2011-07-26 20:24:28.342322388 -0400
 
126
+++ gnome-games-3.1.4/quadrapassel/tetris.cpp   2011-07-26 20:24:37.242536497 -0400
127
127
@@ -28,6 +28,7 @@
128
128
 
129
129
 #include <gdk/gdkkeysyms.h>
151
151
        accel_group = gtk_ui_manager_get_accel_group (ui_manager);
152
152
        gtk_window_add_accel_group (GTK_WINDOW (w), accel_group);
153
153
 
154
 
Index: gnome-games-3.1.3/gnomine/gnomine.c
 
154
Index: gnome-games-3.1.4/gnomine/gnomine.c
155
155
===================================================================
156
 
--- gnome-games-3.1.3.orig/gnomine/gnomine.c    2011-06-20 15:25:48.000000000 -0400
157
 
+++ gnome-games-3.1.3/gnomine/gnomine.c 2011-07-20 04:13:37.321134459 -0400
 
156
--- gnome-games-3.1.4.orig/gnomine/gnomine.c    2011-07-26 20:24:28.412324076 -0400
 
157
+++ gnome-games-3.1.4/gnomine/gnomine.c 2011-07-26 20:24:37.252536741 -0400
158
158
@@ -31,6 +31,7 @@
159
159
 #include <glib/gi18n.h>
160
160
 #include <gtk/gtk.h>
182
182
   hint_action = gtk_action_group_get_action (action_group, "Hint");
183
183
 
184
184
   fullscreen_action = GTK_ACTION (games_fullscreen_action_new ("Fullscreen", GTK_WINDOW (window)));
185
 
Index: gnome-games-3.1.3/gnotski/gnotski.c
 
185
Index: gnome-games-3.1.4/gnotski/gnotski.c
186
186
===================================================================
187
 
--- gnome-games-3.1.3.orig/gnotski/gnotski.c    2011-06-20 15:25:49.000000000 -0400
188
 
+++ gnome-games-3.1.3/gnotski/gnotski.c 2011-07-20 04:13:37.321134459 -0400
 
187
--- gnome-games-3.1.4.orig/gnotski/gnotski.c    2011-07-26 20:24:28.442324808 -0400
 
188
+++ gnome-games-3.1.4/gnotski/gnotski.c 2011-07-26 20:24:37.252536741 -0400
189
189
@@ -24,6 +24,7 @@
190
190
 #include <string.h>
191
191
 #include <stdlib.h>
213
213
   add_puzzle_menu (ui_manager);
214
214
 
215
215
   accel_group = gtk_ui_manager_get_accel_group (ui_manager);
216
 
Index: gnome-games-3.1.3/gtali/gyahtzee.c
 
216
Index: gnome-games-3.1.4/gtali/gyahtzee.c
217
217
===================================================================
218
 
--- gnome-games-3.1.3.orig/gtali/gyahtzee.c     2011-06-20 15:25:49.000000000 -0400
219
 
+++ gnome-games-3.1.3/gtali/gyahtzee.c  2011-07-20 04:13:37.321134459 -0400
 
218
--- gnome-games-3.1.4.orig/gtali/gyahtzee.c     2011-07-26 20:24:28.242319985 -0400
 
219
+++ gnome-games-3.1.4/gtali/gyahtzee.c  2011-07-26 20:24:37.252536741 -0400
220
220
@@ -43,6 +43,7 @@
221
221
 #include <glib/gi18n.h>
222
222
 #include <gtk/gtk.h>
244
244
   scores_action = gtk_action_group_get_action (action_group, "Scores");
245
245
   undo_action   = gtk_action_group_get_action (action_group, "Undo");
246
246
   update_undo_sensitivity();
247
 
Index: gnome-games-3.1.3/iagno/gnothello.c
 
247
Index: gnome-games-3.1.4/iagno/gnothello.c
248
248
===================================================================
249
 
--- gnome-games-3.1.3.orig/iagno/gnothello.c    2011-06-20 15:25:49.000000000 -0400
250
 
+++ gnome-games-3.1.3/iagno/gnothello.c 2011-07-20 04:13:37.331134686 -0400
 
249
--- gnome-games-3.1.4.orig/iagno/gnothello.c    2011-07-26 20:24:28.312321667 -0400
 
250
+++ gnome-games-3.1.4/iagno/gnothello.c 2011-07-26 20:24:37.252536741 -0400
251
251
@@ -47,6 +47,8 @@
252
252
 #include <ggz-embed.h>
253
253
 #endif /* WITH GGZ_CLIENT */
275
275
   table = gtk_table_new (1, 8, FALSE);
276
276
 
277
277
   black_score = gtk_label_new (_("Dark:"));
278
 
Index: gnome-games-3.1.3/mahjongg/mahjongg.c
 
278
Index: gnome-games-3.1.4/mahjongg/mahjongg.c
279
279
===================================================================
280
 
--- gnome-games-3.1.3.orig/mahjongg/mahjongg.c  2011-06-20 15:25:49.000000000 -0400
281
 
+++ gnome-games-3.1.3/mahjongg/mahjongg.c       2011-07-20 04:13:37.331134686 -0400
 
280
--- gnome-games-3.1.4.orig/mahjongg/mahjongg.c  2011-07-26 20:24:28.372323116 -0400
 
281
+++ gnome-games-3.1.4/mahjongg/mahjongg.c       2011-07-26 20:24:37.252536741 -0400
282
282
@@ -24,6 +24,7 @@
283
283
 #include <glib/gi18n.h>
284
284
 #include <gtk/gtk.h>
306
306
   restart_action = gtk_action_group_get_action (action_group, "RestartGame");
307
307
   pause_action = GTK_ACTION (games_pause_action_new ("PauseGame"));
308
308
   gtk_action_set_is_important (pause_action, TRUE);
309
 
Index: gnome-games-3.1.3/gnotravex/gnotravex.c
 
309
Index: gnome-games-3.1.4/gnotravex/gnotravex.c
310
310
===================================================================
311
 
--- gnome-games-3.1.3.orig/gnotravex/gnotravex.c        2011-06-20 17:13:25.000000000 -0400
312
 
+++ gnome-games-3.1.3/gnotravex/gnotravex.c     2011-07-20 04:13:37.331134686 -0400
 
311
--- gnome-games-3.1.4.orig/gnotravex/gnotravex.c        2011-07-26 20:24:28.262320462 -0400
 
312
+++ gnome-games-3.1.4/gnotravex/gnotravex.c     2011-07-26 20:24:37.252536741 -0400
313
313
@@ -27,6 +27,7 @@
314
314
 #include <glib/gi18n.h>
315
315
 #include <gtk/gtk.h>
336
336
   new_game_action = gtk_action_group_get_action (action_group, "NewGame");
337
337
   hint_action = gtk_action_group_get_action (action_group, "Hint");
338
338
   solve_action = gtk_action_group_get_action (action_group, "Solve");
339
 
Index: gnome-games-3.1.3/configure.in
 
339
Index: gnome-games-3.1.4/configure.in
340
340
===================================================================
341
 
--- gnome-games-3.1.3.orig/configure.in 2011-07-05 17:51:33.000000000 -0400
342
 
+++ gnome-games-3.1.3/configure.in      2011-07-20 04:13:37.331134686 -0400
 
341
--- gnome-games-3.1.4.orig/configure.in 2011-07-26 20:24:28.352322629 -0400
 
342
+++ gnome-games-3.1.4/configure.in      2011-07-26 20:24:37.252536741 -0400
343
343
@@ -355,7 +355,7 @@
344
344
 AC_SUBST([GOBJECT_CFLAGS])
345
345
 AC_SUBST([GOBJECT_LIBS])
349
349
 AC_SUBST([GTK_CFLAGS])
350
350
 AC_SUBST([GTK_LIBS])
351
351
 
352
 
Index: gnome-games-3.1.3/glchess/src/Makefile.am
 
352
Index: gnome-games-3.1.4/glchess/src/Makefile.am
353
353
===================================================================
354
 
--- gnome-games-3.1.3.orig/glchess/src/Makefile.am      2011-06-20 15:25:48.000000000 -0400
355
 
+++ gnome-games-3.1.3/glchess/src/Makefile.am   2011-07-20 04:13:37.331134686 -0400
 
354
--- gnome-games-3.1.4.orig/glchess/src/Makefile.am      2011-07-26 20:24:28.282320952 -0400
 
355
+++ gnome-games-3.1.4/glchess/src/Makefile.am   2011-07-26 20:24:37.252536741 -0400
356
356
@@ -74,6 +74,7 @@
357
357
     --pkg gtk+-3.0 \
358
358
     --pkg gdk-x11-3.0 \
361
361
     --pkg librsvg-2.0 \
362
362
     --pkg posix \
363
363
     --pkg sqlite3
364
 
Index: gnome-games-3.1.3/glchess/src/glchess.vala
 
364
Index: gnome-games-3.1.4/glchess/src/glchess.vala
365
365
===================================================================
366
 
--- gnome-games-3.1.3.orig/glchess/src/glchess.vala     2011-06-20 15:25:48.000000000 -0400
367
 
+++ gnome-games-3.1.3/glchess/src/glchess.vala  2011-07-20 04:13:37.331134686 -0400
 
366
--- gnome-games-3.1.4.orig/glchess/src/glchess.vala     2011-07-26 20:24:28.302321426 -0400
 
367
+++ gnome-games-3.1.4/glchess/src/glchess.vala  2011-07-26 20:24:37.252536741 -0400
368
368
@@ -92,6 +92,9 @@
369
369
         view_container = (Gtk.Container) builder.get_object ("view_container");
370
370
         builder.connect_signals (this);
375
375
         info_bar = new Gtk.InfoBar ();
376
376
         var content_area = (Gtk.Container) info_bar.get_content_area ();
377
377
         view_box.pack_start (info_bar, false, true, 0);
 
378
Index: gnome-games-3.1.4/gnome-sudoku/src/lib/main.py
 
379
===================================================================
 
380
--- gnome-games-3.1.4.orig/gnome-sudoku/src/lib/main.py 2011-07-26 20:28:55.718665857 -0400
 
381
+++ gnome-games-3.1.4/gnome-sudoku/src/lib/main.py      2011-07-26 20:32:11.663227436 -0400
 
382
@@ -6,6 +6,7 @@
 
383
 gi.require_version("Gtk", "3.0")
 
384
 
 
385
 from gi.repository import Gtk,GdkPixbuf,GObject,Pango,Gdk
 
386
+from gi.repository import LaunchpadIntegration
 
387
 from gettext import gettext as _
 
388
 from gettext import ngettext
 
389
 
 
390
@@ -95,6 +96,7 @@
 
391
       </menu>
 
392
       <menu action="Help">
 
393
         <menuitem action="ShowHelp"/>
 
394
+        <placeholder name='LaunchpadItems'/>
 
395
         <menuitem action="About"/>
 
396
       </menu>
 
397
     </menubar>
 
398
@@ -191,6 +193,9 @@
 
399
         self.setup_undo()
 
400
         self.setup_autosave()
 
401
         self.w.add_accel_group(self.uimanager.get_accel_group())
 
402
+        # Add launchpad integration
 
403
+        LaunchpadIntegration.set_sourcepackagename("gnome-sudoku")
 
404
+        LaunchpadIntegration.add_ui(self.uimanager, "/MenuBar/Help/LaunchpadItems")
 
405
         self.setup_main_boxes()
 
406
         self.setup_tracker_interface()
 
407
         self.setup_toggles()