~jorge/+junk/fix-for-790821

« back to all changes in this revision

Viewing changes to debian/patches/90_configure_ac.patch

  • Committer: Bazaar Package Importer
  • Author(s): Andreas Moog
  • Date: 2008-09-22 23:26:43 UTC
  • mfrom: (1.1.13 upstream)
  • Revision ID: james.westby@ubuntu.com-20080922232643-tt0aohjh2dfc5sr6
Tags: 1:0.24.0-0ubuntu1
* New upstream release: (LP: #273328)
  - Bug fixes (#431785, #551515)
  - Translation updates
* debian/patches:
  - Remove 90_configure_ac.patch, merged upstream
  - Updated 98_autoconf.patch to apply cleanly
  - Added 95_apturl-support.patch for apturl integration (LP: #217611)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff -Nur -x '*.orig' -x '*~' xchat-gnome-0.23.92/configure.ac xchat-gnome-0.23.92.new/configure.ac
2
 
--- xchat-gnome-0.23.92/configure.ac    2008-09-09 16:42:46.000000000 +0200
3
 
+++ xchat-gnome-0.23.92.new/configure.ac        2008-09-09 16:43:42.000000000 +0200
4
 
@@ -123,7 +123,7 @@
5
 
   AC_SUBST([LIBNOTIFY_LIBS])
6
 
 fi
7
 
 
8
 
-AM_CONDITIONAL([ENABLE_LIBNOTIFY],[test "$enable_notification" = "yes"])
9
 
+AM_CONDITIONAL([ENABLE_LIBNOTIFY],[test "x$enable_notification" = "xyes"])
10
 
 
11
 
 # libcanberra-gtk
12
 
 AC_MSG_CHECKING([whether to enable notification sounds using libcanberra])
13
 
@@ -138,7 +138,7 @@
14
 
   AC_SUBST([LIBCANBERRAGTK_LIBS])
15
 
 fi
16
 
 
17
 
-AM_CONDITIONAL([ENABLE_LIBCANBERRA],[test "$enable_canberra" = "yes"])
18
 
+AM_CONDITIONAL([ENABLE_LIBCANBERRA],[test "x$enable_canberra" = "xyes"])
19
 
 
20
 
 # GConf
21
 
 AM_GCONF_SOURCE_2
22
 
@@ -360,7 +360,7 @@
23
 
 DIST_PLUGINS="$ALL_PLUGINS $CANBERRA_PLUGINS $DBUS_PLUGINS $LIBNOTIFY_PLUGINS $PYTHON_PLUGINS $PERL_PLUGINS $TCL_PLUGINS"
24
 
 
25
 
 # canberra specific plugins
26
 
-if test "x$libcanberra" = "xyes"; then
27
 
+if test "x$enable_canberra" = "xyes"; then
28
 
        ALL_PLUGINS="$ALL_PLUGINS $CANBERRA_PLUGINS"
29
 
 else
30
 
        AC_MSG_WARN([xchat-gnome compiled without libcanberra support, plugins $CANBERRA_PLUGINS will not be available])
31
 
@@ -374,7 +374,7 @@
32
 
 fi
33
 
 
34
 
 # libnotify-specific plugins
35
 
-if test "x$libnotify" = "xyes"; then
36
 
+if test "x$enable_notification" = "xyes"; then
37
 
        ALL_PLUGINS="$ALL_PLUGINS $LIBNOTIFY_PLUGINS"
38
 
 else
39
 
        AC_MSG_WARN([xchat-gnome compiled without libnotify support, plugins $LIBNOTIFY_PLUGINS will not be available])