~ken-vandine/shotwell/no_unity_no_uoa

« back to all changes in this revision

Viewing changes to debian/patches/format_string.patch

  • Committer: Robert Ancell
  • Date: 2014-11-03 01:37:38 UTC
  • mfrom: (168.1.2 ubuntu)
  • Revision ID: robert.ancell@canonical.com-20141103013738-jzjs9u6wiigpw5wu
* Merge from Debian unstable.  Remaining changes:
  - debian/control, debian/test/*:
    + Add autopilot autopkgtest to check import from a libgphoto2
      camera (simulated with umockdev, recorded from a Canon
      PowerShot SX200).
      debian/tests/import will run under a local session D-BUS
      and xvfb, but you can also run the test interactively with
      "cd debian/tests; autopilot run autopilot_tests".
  - debian/control:
    + Suggest account plugins.
    + Bump breaks/replaces since we didn't take the package
      split until now.
  - debian/control, debian/rules:
    + Run intltool-update on build.
    + Build-Depends on intltool.
  - debian/patches/02_desktop_translations.patch:
    + Don't translate the .desktop files, they work with gettext
      and the build system translates them all into English.
  - debian/patches/06_uoa.patch, debian/control:
    + Add Ubuntu Online Accounts support.
    + Build-Depends on libaccounts-glib-dev and libsignon-glib-dev.
  - debian/patches/update_translation_list.patch: 
    + Don't list deprecated source to translate.
  - debian/patches/libexec.patch, debian/rules:
    + Dropped, upstream supports libexecdir now.
    + Set libexec to /usr/lib/shotwell.
  - debian/control, debian/rules:
    + Build with Unity support.
    + Build-Depends on libunity-dev.
    + configure --disable-icon-update
  - debian/control, debian/rules:
    + Build with scour for SVG optimization.
    + Build-Depends on python-scour.
* Drop following change, already fixed in Debian:
  - debian/watch: Update to GNOME FTP location.
* Refresh patches.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Fix FTBFS with missing format string parameter
2
 
Author: Luca Falavigna <dktrkranz@debian.org>
3
 
 
4
 
Index: shotwell-0.12.2/src/Dialogs.vala
5
 
===================================================================
6
 
--- shotwell-0.12.2.orig/src/Dialogs.vala       2012-04-11 20:18:19.000000000 +0200
7
 
+++ shotwell-0.12.2/src/Dialogs.vala    2012-05-06 19:47:46.625600885 +0200
8
 
@@ -31,7 +31,7 @@
9
 
 
10
 
 public bool confirm_warn_developer_changed(int number) {
11
 
     Gtk.MessageDialog dialog = new Gtk.MessageDialog.with_markup(AppWindow.get_instance(),
12
 
-        Gtk.DialogFlags.MODAL, Gtk.MessageType.WARNING, Gtk.ButtonsType.NONE,
13
 
+        Gtk.DialogFlags.MODAL, Gtk.MessageType.WARNING, Gtk.ButtonsType.NONE, "%s",
14
 
         "<span weight=\"bold\" size=\"larger\">%s</span>".printf(ngettext("Switching developers will undo all changes you have made to this photo in Shotwell",
15
 
         "Switching developers will undo all changes you have made to these photos in Shotwell", number)));
16