~ken-vandine/shotwell/no_unity_no_uoa

« back to all changes in this revision

Viewing changes to debian/patches/hardening.patch

  • Committer: Robert Ancell
  • Date: 2014-11-03 01:37:38 UTC
  • mfrom: (168.1.2 ubuntu)
  • Revision ID: robert.ancell@canonical.com-20141103013738-jzjs9u6wiigpw5wu
* Merge from Debian unstable.  Remaining changes:
  - debian/control, debian/test/*:
    + Add autopilot autopkgtest to check import from a libgphoto2
      camera (simulated with umockdev, recorded from a Canon
      PowerShot SX200).
      debian/tests/import will run under a local session D-BUS
      and xvfb, but you can also run the test interactively with
      "cd debian/tests; autopilot run autopilot_tests".
  - debian/control:
    + Suggest account plugins.
    + Bump breaks/replaces since we didn't take the package
      split until now.
  - debian/control, debian/rules:
    + Run intltool-update on build.
    + Build-Depends on intltool.
  - debian/patches/02_desktop_translations.patch:
    + Don't translate the .desktop files, they work with gettext
      and the build system translates them all into English.
  - debian/patches/06_uoa.patch, debian/control:
    + Add Ubuntu Online Accounts support.
    + Build-Depends on libaccounts-glib-dev and libsignon-glib-dev.
  - debian/patches/update_translation_list.patch: 
    + Don't list deprecated source to translate.
  - debian/patches/libexec.patch, debian/rules:
    + Dropped, upstream supports libexecdir now.
    + Set libexec to /usr/lib/shotwell.
  - debian/control, debian/rules:
    + Build with Unity support.
    + Build-Depends on libunity-dev.
    + configure --disable-icon-update
  - debian/control, debian/rules:
    + Build with scour for SVG optimization.
    + Build-Depends on python-scour.
* Drop following change, already fixed in Debian:
  - debian/watch: Update to GNOME FTP location.
* Refresh patches.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Description: pass compiler flags set in debian/rules to compiler
2
2
Author: Devid Antonio Filoni <d.filoni@ubuntu.com>
3
3
 
4
 
Index: shotwell-0.18.0/Makefile
 
4
Index: trunk/Makefile
5
5
===================================================================
6
 
--- shotwell-0.18.0.orig/Makefile       2014-03-21 18:03:14.175717595 +0100
7
 
+++ shotwell-0.18.0/Makefile    2014-03-21 18:03:14.171717595 +0100
 
6
--- trunk.orig/Makefile 2014-10-09 12:18:23.260829459 +0200
 
7
+++ trunk/Makefile      2014-10-09 12:18:23.252829340 +0200
8
8
@@ -35,7 +35,7 @@
9
9
 LOCAL_LANG_DIR=locale-langpack
10
10
 SYSTEM_LANG_DIR := $(DESTDIR)$(PREFIX)/share/locale
11
11
 
12
12
-VALAFLAGS := -g --enable-checking --target-glib=2.32 --thread --fatal-warnings --enable-experimental --enable-deprecated $(USER_VALAFLAGS)
13
 
+VALAFLAGS := $(foreach w,$(CPPFLAGS) $(CFLAGS) $(LDFLAGS),-X $(w)) --enable-checking --target-glib=2.32 --thread --fatal-warnings --enable-deprecated --enable-experimental $(USER_VALAFLAGS)
 
13
+VALAFLAGS := $(foreach w,$(CPPFLAGS) $(CFLAGS) $(LDFLAGS),-X $(w)) --enable-checking --target-glib=2.32 --thread --enable-experimental --enable-deprecated $(USER_VALAFLAGS)
14
14
 ifdef UNITY_SUPPORT
15
15
 VALAFLAGS := $(VALAFLAGS) --define UNITY_SUPPORT
16
16
 endif
17
 
@@ -673,7 +673,7 @@
 
17
@@ -671,7 +671,7 @@
18
18
        @
19
19
 
20
20
 $(EXPANDED_OBJ_FILES): %.o: %.c $(CONFIG_IN) Makefile
23
23
 
24
24
 $(PROGRAM): $(EXPANDED_OBJ_FILES) $(RESOURCES) $(LANG_STAMP) $(THUMBNAILER_BIN) misc/gschemas.compiled $(DOC_LANG_STAMP)
25
25
        $(CC) $(EXPANDED_OBJ_FILES) $(CFLAGS) $(LDFLAGS) $(RESOURCES) $(VALA_LDFLAGS) $(EXPORT_FLAGS) -o $@
 
26
Index: trunk/plugins/Makefile.plugin.mk
 
27
===================================================================
 
28
--- trunk.orig/plugins/Makefile.plugin.mk       2014-10-09 12:18:23.260829459 +0200
 
29
+++ trunk/plugins/Makefile.plugin.mk    2014-10-09 12:19:22.945701585 +0200
 
30
@@ -41,7 +41,7 @@
 
31
 all: $(PLUGIN).so
 
32
 
 
33
 .stamp: $(SRC_FILES) $(MAKE_FILES) $(HEADER_FILES)
 
34
-       $(VALAC) --target-glib=$(MIN_GLIB_VERSION) -g --enable-checking --fatal-warnings --save-temps --compile --enable-deprecated \
 
35
+       $(VALAC) --target-glib=$(MIN_GLIB_VERSION) -g --enable-checking --save-temps --compile --enable-deprecated \
 
36
                --vapidir=../ $(foreach pkg,$(PKGS),--pkg=$(pkg)) $(foreach pkg,$(CUSTOM_VAPI_PKGS),--pkg=$(pkg)) \
 
37
                -X -I../.. -X -fPIC \
 
38
                $(foreach dfn,$(DEFINES),-X $(dfn)) \