~kroq-gar78/ubuntu/precise/ace-of-penguins/fix-978446

« back to all changes in this revision

Viewing changes to debian/patches/90-autoreconf-ldflags-am_ldflags.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Jari Aalto
  • Date: 2009-08-05 11:39:32 UTC
  • Revision ID: james.westby@ubuntu.com-20090805113932-5u4zxr5hoh38pu3o
Tags: 1.2-9
* GENRAL INFORMATION:
  - Summary: the whole package is now patch based.
  - The orginal sources were restored and patches accumulated
    to it were extracted and moved to /debian/patches
  - The original sources were upgraded to latest automake by
    re-libtoolizing with 'autoreconf -fi'. The results were then
    turned into patches. See debian/README.source
* debian/*.desktop:
  - New files. Files submitted by Daniel Dickinson <cshore@wightman.ca>.
    Closes: #478847.
* debian/*.pod
  - Fix incorrect =item tag.
* debian/*.lintian-overrides:
  - Ignore autoreconf and library notes.
* debian/copyright:
  - Update to new dh-make layout.
  - Add Debian packaging copyrights.
  - Change upstream URL to point to freshmeat.
  - Explicitly spell v2 or any later version (lintian).
* debian/compat:
  - update to 7.
* debian/control:
  - (Build-Depends): debhelper (>= 7), was 4. Add dpatch.
  - (Description): Replace term 'Unix/X' with 'graphical'.
  - (Vcs-*): Add new fields.
  - (Homepage): Add new field.
  - (Standards-Version): Update to 3.8.2.
  - (Build-Depends): Remove non-used dpatch.
* debian/debian-vars.mk:
  - Many new variables like CFLAGS, MAKE_FLAGS
  - By default use -j<CPU_COUNT> for make.
* debian/rules:
  - Add dpatch.
  - (binary-arch): Add dh_compress and adjust the manual page
    installation. Remove obsolete dh_desktop.
  - (build-man): New.
  - (clean): Fix lintian checks about -$(MAKE). Clean editors' temporary
    files.
  - (clean-man): New.
  - (install): install *.desktop files. Change programs' prefix form
    ace_* to ace-*. Change 'dh_clean -k' with dh_prep. Install lintian
    override file.
  - (test): New target.
* debian/README.source:
  - Explain autconf 2.64 re-libtoolize process
  - Explain debian/rules specifics concerning libtoolize.
* games/taipei.html:
  - Revert Bug#327185. According to the upstream,
    every game can be won. Explain this in page.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 0001-.am-LDFLAGS-AM_LDFLAGS.patch.dpatch by  <jari.aalto@cante.net>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: libtoolize: autoreconf fixes
 
6
 
 
7
@DPATCH@
 
8
 
 
9
From cc67e66843a70d82ca0b74ec39c4b0ccc6f0a1ab Mon Sep 17 00:00:00 2001
 
10
From: Jari Aalto <jari.aalto@cante.net>
 
11
Date: Tue, 4 Aug 2009 21:20:24 +0300
 
12
Subject: [PATCH] */*.am: LDFLAGS => AM_LDFLAGS
 
13
 
 
14
Signed-off-by: Jari Aalto <jari.aalto@cante.net>
 
15
---
 
16
 games/Makefile.am |    2 +-
 
17
 lib/Makefile.am   |    2 +-
 
18
 tests/Makefile.am |    2 +-
 
19
 3 files changed, 3 insertions(+), 3 deletions(-)
 
20
 
 
21
diff --git a/games/Makefile.am b/games/Makefile.am
 
22
index a66a48e..bbeb537 100644
 
23
--- a/games/Makefile.am
 
24
+++ b/games/Makefile.am
 
25
@@ -29,7 +29,7 @@ CLEANFILES = \
 
26
 STRIP = @STRIP@
 
27
 
 
28
 INCLUDES = -I$(srcdir)/../lib $(X_CFLAGS) @PDA@
 
29
-LDFLAGS = $(X_LIBS)
 
30
+AM_LDFLAGS = $(X_LIBS)
 
31
 
 
32
 canfield_SOURCES = canfield.c canfield-img.c
 
33
 freecell_SOURCES = freecell.c freecell-help.c freecell-img.c
 
34
diff --git a/lib/Makefile.am b/lib/Makefile.am
 
35
index 28e6eed..385a9ab 100644
 
36
--- a/lib/Makefile.am
 
37
+++ b/lib/Makefile.am
 
38
@@ -6,7 +6,7 @@ noinst_HEADERS = cards.h
 
39
 CLEANFILES = images.c images.d
 
40
 
 
41
 INCLUDES = $(X_CFLAGS) @PDA@
 
42
-LDFLAGS = $(X_LIBS)
 
43
+AM_LDFLAGS = $(X_LIBS)
 
44
 
 
45
 BUILD_CC = @BUILD_CC@
 
46
 AR = @AR@
 
47
diff --git a/tests/Makefile.am b/tests/Makefile.am
 
48
index cef7a6e..530b037 100644
 
49
--- a/tests/Makefile.am
 
50
+++ b/tests/Makefile.am
 
51
@@ -3,7 +3,7 @@ bin_PROGRAMS = penguins
 
52
 test6_SOURCES = test6.c test6c.c
 
53
 
 
54
 INCLUDES = -I$(srcdir)/../lib $(X_CFLAGS) @PDA@
 
55
-LDFLAGS = $(X_LIBS)
 
56
+AM_LDFLAGS = $(X_LIBS)
 
57
 LDADD = ../lib/libcards.la -lpng -lz -lX11 -lm
 
58
 
 
59
 EXTRA_DIST = test6.png
 
60
-- 
 
61
1.6.3.3
 
62