~laney/ubuntu/quantal/swig2.0/guile-2.0

« back to all changes in this revision

Viewing changes to debian/patches/fix-cleaning.diff

  • Committer: Bazaar Package Importer
  • Author(s): Torsten Landschoff
  • Date: 2010-08-28 22:59:01 UTC
  • Revision ID: james.westby@ubuntu.com-20100828225901-2yifvahf27uulttt
Tags: 2.0.0-1
* New upstream release (closes: #584324).
* Create a new swig2.0 package for unstable. Most packages should be
  able to build with 2.0 instead of 1.3 but the version detection
  in most configure scripts is flawed.
* Fix the most important lintian complaints:
  + debian/control:
    o Update Standards-Version to 3.9.0 (no changes).
    o Add ${misc:Depends} to all binary dependencies.
  + debian/rules:
    o Fix invocation order for dh_makeshlibs.
    o Replace "dh_clean -k" with dh_prep.
  + debian/swig2.0-doc.doc-base: Fixed references into wrong package.
  + debian/swig.1: Renamed to swig2.0-1 to match with the binary.
* Use dh-autoreconf for cleaning up after autotools.
* Fixed "make distclean" in upstream Makefile.in. The first time for
  years that "debian/rules clean" actually completes successfully.
* debian/control: Bump Standards-Version to 3.9.1 (no changes).
* debian/copyright: Update for upstream license change to GPLv3.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Fix "make distclean" to not try to rebuild SWIG.
 
2
 .
 
3
 The comment explains it all: A variable substition ended up empty, causing
 
4
 make to invoke the default rule. This patch fixes it using a conditional
 
5
 to only call make recursively if there is anything to do.
 
6
 
 
7
Author: Torsten Landschoff <torsten@debian.org>
 
8
Last-Update: 2010-08-06
 
9
Forwarded: http://article.gmane.org/gmane.comp.programming.swig.devel/20143
 
10
 
 
11
--- swig2.0-2.0.0.orig/Makefile.in
 
12
+++ swig2.0-2.0.0/Makefile.in
 
13
@@ -164,11 +164,20 @@ check-%-examples :
 
14
          echo $* unknown;                                      \
 
15
          exit 1;                                               \
 
16
        fi
 
17
+
 
18
+# This conditional makes sure that make is actually called with a list of
 
19
+# targets below. If the $($*_examples) results in an empty list (as in
 
20
+# check-clisp-examples at this time), make will be called without a
 
21
+# target below, invoking the default target - building SWIG. Quite
 
22
+# unhelpful when actually running make clean...  -- Torsten
 
23
+
 
24
+ifneq ($(strip $($*_examples:=.actionexample)),)
 
25
        @if $(skip-$*); then                                    \
 
26
          echo skipping $* $(ACTION);                           \
 
27
        else                                                    \
 
28
          $(MAKE) -k -s $($*_examples:=.actionexample) LANGUAGE=$* ACTION=$(ACTION); \
 
29
        fi
 
30
+endif
 
31
 
 
32
 # individual example
 
33
 %.actionexample: