~larsu/evince/restore-zoom-popup

« back to all changes in this revision

Viewing changes to debian/patches/0001-Port-to-GMenuModel-and-add-menu-bar.patch

  • Committer: Sebastien Bacher
  • Date: 2014-03-03 11:41:50 UTC
  • mfrom: (235.1.1 evince-ubuntu)
  • Revision ID: seb128@ubuntu.com-20140303114150-rb0d5q0hyb8gljro
* debian/patches/0001-Port-to-GMenuModel-and-add-menu-bar.patch:
  - don't show menubar in presentation mode, thanks Lars (lp: #1283235)

Show diffs side-by-side

added added

removed removed

Lines of Context:
30
30
 
31
31
Index: evince-3.10.3/shell/Makefile.am
32
32
===================================================================
33
 
--- evince-3.10.3.orig/shell/Makefile.am        2014-02-13 16:16:42.917954976 +0100
34
 
+++ evince-3.10.3/shell/Makefile.am     2014-02-13 16:16:42.901954977 +0100
 
33
--- evince-3.10.3.orig/shell/Makefile.am        2014-03-03 12:17:53.199442435 +0100
 
34
+++ evince-3.10.3/shell/Makefile.am     2014-03-03 12:17:53.183442435 +0100
35
35
@@ -75,6 +75,8 @@
36
36
        ev-sidebar-page.h               \
37
37
        ev-sidebar-thumbnails.c         \
59
59
        $(AM_V_GEN) XMLLINT=$(XMLLINT) $(GLIB_COMPILE_RESOURCES) --target $@ --sourcedir $(srcdir) --generate-source --c-name ev $<
60
60
Index: evince-3.10.3/shell/ev-application.c
61
61
===================================================================
62
 
--- evince-3.10.3.orig/shell/ev-application.c   2014-02-13 16:16:42.917954976 +0100
63
 
+++ evince-3.10.3/shell/ev-application.c        2014-02-13 16:16:45.000000000 +0100
 
62
--- evince-3.10.3.orig/shell/ev-application.c   2014-03-03 12:17:53.199442435 +0100
 
63
+++ evince-3.10.3/shell/ev-application.c        2014-03-03 12:18:09.000000000 +0100
64
64
@@ -42,6 +42,9 @@
65
65
 #include "ev-application.h"
66
66
 #include "ev-file-helpers.h"
447
447
+}
448
448
Index: evince-3.10.3/shell/ev-application.h
449
449
===================================================================
450
 
--- evince-3.10.3.orig/shell/ev-application.h   2014-02-13 16:16:42.917954976 +0100
451
 
+++ evince-3.10.3/shell/ev-application.h        2014-02-13 16:16:42.905954977 +0100
 
450
--- evince-3.10.3.orig/shell/ev-application.h   2014-03-03 12:17:53.199442435 +0100
 
451
+++ evince-3.10.3/shell/ev-application.h        2014-03-03 12:17:53.183442435 +0100
452
452
@@ -81,6 +81,14 @@
453
453
                                                       GdkScreen       *screen,
454
454
                                                       const char      *topic);
466
466
 #endif /* !EV_APPLICATION_H */
467
467
Index: evince-3.10.3/shell/ev-bookmarks.c
468
468
===================================================================
469
 
--- evince-3.10.3.orig/shell/ev-bookmarks.c     2014-02-13 16:16:42.917954976 +0100
470
 
+++ evince-3.10.3/shell/ev-bookmarks.c  2014-02-13 16:16:42.905954977 +0100
 
469
--- evince-3.10.3.orig/shell/ev-bookmarks.c     2014-03-03 12:17:53.199442435 +0100
 
470
+++ evince-3.10.3/shell/ev-bookmarks.c  2014-03-03 12:17:53.183442435 +0100
471
471
@@ -224,6 +224,14 @@
472
472
         return g_list_copy (bookmarks->items);
473
473
 }
485
485
                   EvBookmark  *bookmark)
486
486
Index: evince-3.10.3/shell/ev-bookmarks.h
487
487
===================================================================
488
 
--- evince-3.10.3.orig/shell/ev-bookmarks.h     2014-02-13 16:16:42.917954976 +0100
489
 
+++ evince-3.10.3/shell/ev-bookmarks.h  2014-02-13 16:16:42.905954977 +0100
 
488
--- evince-3.10.3.orig/shell/ev-bookmarks.h     2014-03-03 12:17:53.199442435 +0100
 
489
+++ evince-3.10.3/shell/ev-bookmarks.h  2014-03-03 12:17:53.183442435 +0100
490
490
@@ -43,6 +43,7 @@
491
491
 GType        ev_bookmarks_get_type      (void) G_GNUC_CONST;
492
492
 EvBookmarks *ev_bookmarks_new           (EvMetadata *metadata);
498
498
Index: evince-3.10.3/shell/ev-recent-menu-model.c
499
499
===================================================================
500
500
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
501
 
+++ evince-3.10.3/shell/ev-recent-menu-model.c  2014-02-13 16:16:42.905954977 +0100
 
501
+++ evince-3.10.3/shell/ev-recent-menu-model.c  2014-03-03 12:17:53.183442435 +0100
502
502
@@ -0,0 +1,108 @@
503
503
+/*
504
504
+ * Copyright 2014 Canonical Ltd
611
611
Index: evince-3.10.3/shell/ev-recent-menu-model.h
612
612
===================================================================
613
613
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
614
 
+++ evince-3.10.3/shell/ev-recent-menu-model.h  2014-02-13 16:16:42.909954976 +0100
 
614
+++ evince-3.10.3/shell/ev-recent-menu-model.h  2014-03-03 12:17:53.183442435 +0100
615
615
@@ -0,0 +1,30 @@
616
616
+/*
617
617
+ * Copyright 2014 Canonical Ltd
645
645
+#endif
646
646
Index: evince-3.10.3/shell/ev-sidebar-bookmarks.c
647
647
===================================================================
648
 
--- evince-3.10.3.orig/shell/ev-sidebar-bookmarks.c     2014-02-13 16:16:42.917954976 +0100
649
 
+++ evince-3.10.3/shell/ev-sidebar-bookmarks.c  2014-02-13 16:16:42.909954976 +0100
 
648
--- evince-3.10.3.orig/shell/ev-sidebar-bookmarks.c     2014-03-03 12:17:53.199442435 +0100
 
649
+++ evince-3.10.3/shell/ev-sidebar-bookmarks.c  2014-03-03 12:17:53.187442435 +0100
650
650
@@ -40,11 +40,6 @@
651
651
         N_COLUMNS
652
652
 };
716
716
 GtkWidget *
717
717
Index: evince-3.10.3/shell/ev-toolbar.c
718
718
===================================================================
719
 
--- evince-3.10.3.orig/shell/ev-toolbar.c       2014-02-13 16:16:42.917954976 +0100
720
 
+++ evince-3.10.3/shell/ev-toolbar.c    2014-02-13 16:16:42.909954976 +0100
 
719
--- evince-3.10.3.orig/shell/ev-toolbar.c       2014-03-03 12:17:53.199442435 +0100
 
720
+++ evince-3.10.3/shell/ev-toolbar.c    2014-03-03 12:17:53.187442435 +0100
721
721
@@ -24,9 +24,12 @@
722
722
 
723
723
 #include "ev-toolbar.h"
984
984
 static void
985
985
Index: evince-3.10.3/shell/ev-utils.c
986
986
===================================================================
987
 
--- evince-3.10.3.orig/shell/ev-utils.c 2014-02-13 16:16:42.917954976 +0100
988
 
+++ evince-3.10.3/shell/ev-utils.c      2014-02-13 16:16:42.909954976 +0100
 
987
--- evince-3.10.3.orig/shell/ev-utils.c 2014-03-03 12:17:53.199442435 +0100
 
988
+++ evince-3.10.3/shell/ev-utils.c      2014-03-03 12:17:53.187442435 +0100
989
989
@@ -22,6 +22,7 @@
990
990
 
991
991
 #include "ev-utils.h"
1087
1087
+}
1088
1088
Index: evince-3.10.3/shell/ev-utils.h
1089
1089
===================================================================
1090
 
--- evince-3.10.3.orig/shell/ev-utils.h 2014-02-13 16:16:42.917954976 +0100
1091
 
+++ evince-3.10.3/shell/ev-utils.h      2014-02-13 16:16:42.909954976 +0100
 
1090
--- evince-3.10.3.orig/shell/ev-utils.h 2014-03-03 12:17:53.199442435 +0100
 
1091
+++ evince-3.10.3/shell/ev-utils.h      2014-03-03 12:17:53.187442435 +0100
1092
1092
@@ -42,6 +42,13 @@
1093
1093
 void                           file_chooser_dialog_add_writable_pixbuf_formats (GtkFileChooser *chooser);
1094
1094
 GdkPixbufFormat*       get_gdk_pixbuf_format_by_extension (const gchar *uri);
1105
1105
 #endif /* __EV_VIEW_H__ */
1106
1106
Index: evince-3.10.3/shell/ev-window.c
1107
1107
===================================================================
1108
 
--- evince-3.10.3.orig/shell/ev-window.c        2014-02-13 16:16:42.917954976 +0100
1109
 
+++ evince-3.10.3/shell/ev-window.c     2014-02-13 16:16:57.333954467 +0100
 
1108
--- evince-3.10.3.orig/shell/ev-window.c        2014-03-03 12:17:53.199442435 +0100
 
1109
+++ evince-3.10.3/shell/ev-window.c     2014-03-03 12:18:34.127444106 +0100
1110
1110
@@ -87,10 +87,10 @@
1111
1111
 #include "ev-print-operation.h"
1112
1112
 #include "ev-progress-message-area.h"
1351
1351
 }
1352
1352
 
1353
1353
 static void
1354
 
@@ -892,7 +887,7 @@
 
1354
@@ -593,6 +588,8 @@
 
1355
        set_widget_visibility (priv->toolbar, toolbar);
 
1356
        set_widget_visibility (priv->find_bar, findbar);
 
1357
        set_widget_visibility (priv->sidebar, sidebar);
 
1358
+
 
1359
+       gtk_application_window_set_show_menubar (GTK_APPLICATION_WINDOW (window), !presentation);
 
1360
 }
 
1361
 
 
1362
 static void
 
1363
@@ -892,7 +889,7 @@
1355
1364
 view_selection_changed_cb (EvView   *view,
1356
1365
                           EvWindow *window)
1357
1366
 {
1360
1369
                                        ev_view_get_has_selection (view));
1361
1370
 }
1362
1371
 
1363
 
@@ -1436,27 +1431,6 @@
 
1372
@@ -1436,27 +1433,6 @@
1364
1373
 }
1365
1374
 #endif
1366
1375
 
1388
1397
 static gboolean
1389
1398
 ev_window_setup_document (EvWindow *ev_window)
1390
1399
 {
1391
 
@@ -1471,8 +1445,6 @@
 
1400
@@ -1471,8 +1447,6 @@
1392
1401
        ev_window_title_set_document (ev_window->priv->title, document);
1393
1402
        ev_window_title_set_uri (ev_window->priv->title, ev_window->priv->uri);
1394
1403
 
1397
1406
 #ifdef HAVE_DESKTOP_SCHEMAS
1398
1407
        if (!ev_window->priv->lockdown_settings) {
1399
1408
                ev_window->priv->lockdown_settings = g_settings_new (GS_LOCKDOWN_SCHEMA_NAME);
1400
 
@@ -1563,8 +1535,9 @@
 
1409
@@ -1563,8 +1537,9 @@
1401
1410
 ev_window_document_changed (EvWindow *ev_window,
1402
1411
                            gpointer  user_data)
1403
1412
 {
1409
1418
                ev_window_reload_document (ev_window, NULL);
1410
1419
 }
1411
1420
 
1412
 
@@ -2410,124 +2383,10 @@
 
1421
@@ -2410,124 +2385,10 @@
1413
1422
        }
1414
1423
 }
1415
1424
 
1535
1544
 }
1536
1545
 
1537
1546
 static void
1538
 
@@ -2545,26 +2404,13 @@
 
1547
@@ -2545,26 +2406,13 @@
1539
1548
 }
1540
1549
 
1541
1550
 static void
1567
1576
 }
1568
1577
 
1569
1578
 static void
1570
 
@@ -2583,185 +2429,6 @@
 
1579
@@ -2583,185 +2431,6 @@
1571
1580
        gtk_recent_manager_add_item (window->priv->recent_manager, filename);
1572
1581
 }
1573
1582
 
1753
1762
 static gboolean 
1754
1763
 show_saving_progress (GFile *dst)
1755
1764
 {
1756
 
@@ -2952,8 +2619,8 @@
 
1765
@@ -2952,8 +2621,8 @@
1757
1766
                return;
1758
1767
        }
1759
1768
 
1764
1773
 
1765
1774
        uri = gtk_file_chooser_get_uri (GTK_FILE_CHOOSER (fc));
1766
1775
 
1767
 
@@ -2975,7 +2642,7 @@
 
1776
@@ -2975,7 +2644,7 @@
1768
1777
 }
1769
1778
 
1770
1779
 static void
1773
1782
 {
1774
1783
        GtkWidget *fc;
1775
1784
        gchar *base_name;
1776
 
@@ -3003,9 +2670,9 @@
 
1785
@@ -3003,9 +2672,9 @@
1777
1786
        g_object_unref (file);
1778
1787
        g_free (base_name);
1779
1788
 
1786
1795
 
1787
1796
        g_signal_connect (fc, "response",
1788
1797
                          G_CALLBACK (file_save_dialog_response_cb),
1789
 
@@ -3015,9 +2682,21 @@
 
1798
@@ -3015,9 +2684,21 @@
1790
1799
 }
1791
1800
 
1792
1801
 static void
1810
1819
        GAppInfo   *app_info;
1811
1820
        gchar      *command;
1812
1821
        const char *uri;
1813
 
@@ -3052,8 +2731,11 @@
 
1822
@@ -3052,8 +2733,11 @@
1814
1823
 }
1815
1824
 
1816
1825
 static void
1823
1832
        GtkWidget *ev_window_widget;
1824
1833
        GFile *file;
1825
1834
        GFile *parent;
1826
 
@@ -3589,14 +3271,22 @@
 
1835
@@ -3589,14 +3273,22 @@
1827
1836
 }
1828
1837
 
1829
1838
 static void
1848
1857
        if (ev_window->priv->properties == NULL) {
1849
1858
                ev_window->priv->properties = ev_properties_dialog_new ();
1850
1859
                ev_properties_dialog_set_document (EV_PROPERTIES_DIALOG (ev_window->priv->properties),
1851
 
@@ -3622,7 +3312,7 @@
 
1860
@@ -3622,7 +3314,7 @@
1852
1861
 
1853
1862
        switch (response) {
1854
1863
        case GTK_RESPONSE_YES:
1857
1866
                break;
1858
1867
        case GTK_RESPONSE_NO:
1859
1868
                gtk_widget_destroy (GTK_WIDGET (ev_window));
1860
 
@@ -3823,64 +3513,81 @@
 
1869
@@ -3823,64 +3515,81 @@
1861
1870
 }
1862
1871
 
1863
1872
 static void
1963
1972
 }
1964
1973
 
1965
1974
 static void
1966
 
@@ -3897,9 +3604,27 @@
 
1975
@@ -3897,9 +3606,27 @@
1967
1976
 }
1968
1977
 
1969
1978
 static void
1994
2003
 }
1995
2004
 
1996
2005
 static void
1997
 
@@ -3916,12 +3641,6 @@
 
2006
@@ -3916,12 +3643,6 @@
1998
2007
 }
1999
2008
 
2000
2009
 static void
2007
2016
 ev_window_cmd_view_zoom_automatic (GtkAction *action,
2008
2017
                                   EvWindow  *ev_window)
2009
2018
 {
2010
 
@@ -3957,29 +3676,28 @@
 
2019
@@ -3957,29 +3678,28 @@
2011
2020
 }
2012
2021
 
2013
2022
 static void
2047
2056
 }
2048
2057
 
2049
2058
 static void
2050
 
@@ -4004,8 +3722,11 @@
 
2059
@@ -4004,8 +3724,11 @@
2051
2060
 }
2052
2061
 
2053
2062
 static void
2060
2069
        gboolean find_bar_hidden;
2061
2070
 
2062
2071
        if (EV_WINDOW_IS_PRESENTATION (ev_window))
2063
 
@@ -4029,8 +3750,11 @@
 
2072
@@ -4029,8 +3752,11 @@
2064
2073
 }
2065
2074
 
2066
2075
 static void
2073
2082
        gboolean find_bar_hidden;
2074
2083
 
2075
2084
        if (EV_WINDOW_IS_PRESENTATION (ev_window))
2076
 
@@ -4047,9 +3771,11 @@
 
2085
@@ -4047,9 +3773,11 @@
2077
2086
 }
2078
2087
 
2079
2088
 static void
2087
2096
 
2088
2097
        ev_view_copy (EV_VIEW (ev_window->priv->view));
2089
2098
 }
2090
 
@@ -4067,15 +3793,12 @@
 
2099
@@ -4067,15 +3795,12 @@
2091
2100
 static void
2092
2101
 ev_window_update_fullscreen_action (EvWindow *window)
2093
2102
 {
2108
2117
 }
2109
2118
 
2110
2119
 static void
2111
 
@@ -4292,16 +4015,19 @@
 
2120
@@ -4292,16 +4017,19 @@
2112
2121
 }
2113
2122
 
2114
2123
 static void
2132
2141
 }
2133
2142
 
2134
2143
 static void
2135
 
@@ -4336,15 +4062,11 @@
 
2144
@@ -4336,15 +4064,11 @@
2136
2145
 static void
2137
2146
 ev_window_update_presentation_action (EvWindow *window)
2138
2147
 {
2152
2161
 }
2153
2162
 
2154
2163
 static void
2155
 
@@ -4459,14 +4181,17 @@
 
2164
@@ -4459,14 +4183,17 @@
2156
2165
 }
2157
2166
 
2158
2167
 static void
2174
2183
 }
2175
2184
 
2176
2185
 static gboolean
2177
 
@@ -4530,10 +4255,12 @@
 
2186
@@ -4530,10 +4257,12 @@
2178
2187
        ev_window_update_actions_sensitivity (window);
2179
2188
 }
2180
2189
 
2189
2198
        gint rotation;
2190
2199
 
2191
2200
        if (EV_WINDOW_IS_PRESENTATION (ev_window)) {
2192
 
@@ -4548,8 +4275,11 @@
 
2201
@@ -4548,8 +4277,11 @@
2193
2202
 }
2194
2203
 
2195
2204
 static void
2202
2211
        gint rotation;
2203
2212
 
2204
2213
        if (EV_WINDOW_IS_PRESENTATION (ev_window)) {
2205
 
@@ -4564,16 +4294,23 @@
 
2214
@@ -4564,16 +4296,23 @@
2206
2215
 }
2207
2216
 
2208
2217
 static void
2230
2239
        EvWindowPrivate *priv = ev_window->priv;
2231
2240
        EvDocumentModel *model = priv->model;
2232
2241
        GSettings       *settings = priv->default_settings;
2233
 
@@ -4582,7 +4319,7 @@
 
2242
@@ -4582,7 +4321,7 @@
2234
2243
        g_settings_set_boolean (settings, "continuous",
2235
2244
                                ev_document_model_get_continuous (model));
2236
2245
        g_settings_set_boolean (settings, "dual-page",
2239
2248
        g_settings_set_boolean (settings, "dual-page-odd-left",
2240
2249
                                ev_document_model_get_dual_page_odd_pages_left (model));
2241
2250
        g_settings_set_boolean (settings, "fullscreen",
2242
 
@@ -4607,59 +4344,78 @@
 
2251
@@ -4607,59 +4346,78 @@
2243
2252
 }
2244
2253
 
2245
2254
 static void
2336
2345
        int n_pages, current_page;
2337
2346
        
2338
2347
         g_return_if_fail (EV_IS_WINDOW (ev_window));
2339
 
@@ -4673,11 +4429,14 @@
 
2348
@@ -4673,11 +4431,14 @@
2340
2349
 }
2341
2350
 
2342
2351
 static void
2354
2363
 
2355
2364
        current_page = ev_document_model_get_page (ev_window->priv->model);
2356
2365
        
2357
 
@@ -4686,15 +4445,6 @@
 
2366
@@ -4686,15 +4447,6 @@
2358
2367
        }
2359
2368
 }
2360
2369
 
2370
2379
 static gint
2371
2380
 compare_bookmarks (EvBookmark *a,
2372
2381
                   EvBookmark *b)
2373
 
@@ -4705,59 +4455,33 @@
 
2382
@@ -4705,59 +4457,33 @@
2374
2383
 static void
2375
2384
 ev_window_setup_bookmarks (EvWindow *window)
2376
2385
 {
2445
2454
        EvBookmark bm;
2446
2455
        gchar     *page_label;
2447
2456
 
2448
 
@@ -4771,32 +4495,41 @@
 
2457
@@ -4771,32 +4497,41 @@
2449
2458
 }
2450
2459
 
2451
2460
 static void
2499
2508
        ev_view_autoscroll_stop (EV_VIEW (window->priv->view));
2500
2509
 
2501
2510
        if (gtk_widget_get_visible (window->priv->find_bar))
2502
 
@@ -4890,29 +4623,20 @@
 
2511
@@ -4890,29 +4625,20 @@
2503
2512
 }
2504
2513
 
2505
2514
 static void
2537
2546
 }
2538
2547
 
2539
2548
 static void
2540
 
@@ -4930,27 +4654,16 @@
 
2549
@@ -4930,27 +4656,16 @@
2541
2550
 }
2542
2551
 
2543
2552
 static void
2569
2578
 
2570
2579
        if (window->priv->metadata && !ev_window_is_empty (window))
2571
2580
                ev_metadata_set_boolean (window->priv->metadata, "inverted-colors",
2572
 
@@ -4960,43 +4673,20 @@
 
2581
@@ -4960,43 +4675,20 @@
2573
2582
 }
2574
2583
 
2575
2584
 static void
2620
2629
 }
2621
2630
 
2622
2631
 static void
2623
 
@@ -5004,119 +4694,36 @@
 
2632
@@ -5004,119 +4696,36 @@
2624
2633
                                               GParamSpec      *pspec,
2625
2634
                                               EvWindow        *ev_window)
2626
2635
 {
2755
2764
        update_chrome_visibility (ev_window);
2756
2765
 }
2757
2766
 
2758
 
@@ -5137,14 +4744,11 @@
 
2767
@@ -5137,14 +4746,11 @@
2759
2768
                                         GParamSpec *pspec,
2760
2769
                                         EvWindow   *ev_window)
2761
2770
 {
2772
2781
 
2773
2782
                if (ev_window->priv->metadata)
2774
2783
                        ev_metadata_set_boolean (ev_window->priv->metadata, "sidebar_visibility",
2775
 
@@ -5542,21 +5146,6 @@
 
2784
@@ -5542,21 +5148,6 @@
2776
2785
 }
2777
2786
 
2778
2787
 static void
2794
2803
 ev_window_show_find_bar (EvWindow *ev_window)
2795
2804
 {
2796
2805
        if (gtk_widget_get_visible (ev_window->priv->find_bar)) {
2797
 
@@ -5583,7 +5172,7 @@
 
2806
@@ -5583,7 +5174,7 @@
2798
2807
        update_chrome_flag (ev_window, EV_CHROME_FINDBAR, TRUE);
2799
2808
        update_chrome_visibility (ev_window);
2800
2809
        gtk_widget_grab_focus (ev_window->priv->find_bar);
2803
2812
 }
2804
2813
 
2805
2814
 static void
2806
 
@@ -5601,7 +5190,7 @@
 
2815
@@ -5601,7 +5192,7 @@
2807
2816
        update_chrome_flag (ev_window, EV_CHROME_FINDBAR, FALSE);
2808
2817
        update_chrome_visibility (ev_window);
2809
2818
        gtk_widget_grab_focus (ev_window->priv->view);
2812
2821
 
2813
2822
        ev_history_thaw (ev_window->priv->history);
2814
2823
 }
2815
 
@@ -5651,10 +5240,15 @@
 
2824
@@ -5651,10 +5242,15 @@
2816
2825
 ev_window_set_caret_navigation_enabled (EvWindow *window,
2817
2826
                                        gboolean enabled)
2818
2827
 {
2828
2837
 }
2829
2838
 
2830
2839
 static void
2831
 
@@ -5668,7 +5262,7 @@
 
2840
@@ -5668,7 +5264,7 @@
2832
2841
 
2833
2842
        /* Turn the confirmation dialog off if the user has requested not to show it again */
2834
2843
        if (gtk_toggle_button_get_active (GTK_TOGGLE_BUTTON (window->priv->ask_caret_navigation_check))) {
2837
2846
                g_settings_apply (window->priv->settings);
2838
2847
        }
2839
2848
 
2840
 
@@ -5678,9 +5272,11 @@
 
2849
@@ -5678,9 +5274,11 @@
2841
2850
 }
2842
2851
 
2843
2852
 static void
2851
2860
        GtkWidget *message_area;
2852
2861
        GtkWidget *box;
2853
2862
        GtkWidget *hbox;
2854
 
@@ -5689,7 +5285,7 @@
 
2863
@@ -5689,7 +5287,7 @@
2855
2864
        /* Don't ask for user confirmation to turn the caret navigation off when it is active,
2856
2865
         * or to turn it on when the confirmation dialog is not to be shown per settings */
2857
2866
        enabled = ev_view_is_caret_navigation_enabled (EV_VIEW (window->priv->view));
2860
2869
                ev_window_set_caret_navigation_enabled (window, !enabled);
2861
2870
                return;
2862
2871
        }
2863
 
@@ -5805,28 +5401,15 @@
 
2872
@@ -5805,28 +5403,15 @@
2864
2873
 
2865
2874
        g_clear_object (&priv->zoom_selector_popup_action_group);
2866
2875
 
2889
2898
        if (priv->default_settings) {
2890
2899
                g_settings_apply (priv->default_settings);
2891
2900
                g_object_unref (priv->default_settings);
2892
 
@@ -5838,8 +5421,6 @@
 
2901
@@ -5838,8 +5423,6 @@
2893
2902
                priv->lockdown_settings = NULL;
2894
2903
        }
2895
2904
 
2898
2907
        if (priv->model) {
2899
2908
                g_signal_handlers_disconnect_by_func (priv->model,
2900
2909
                                                      ev_window_page_changed_cb,
2901
 
@@ -5955,7 +5536,6 @@
 
2910
@@ -5955,7 +5538,6 @@
2902
2911
        G_OBJECT_CLASS (ev_window_parent_class)->dispose (object);
2903
2912
 }
2904
2913
 
2906
2915
 /*
2907
2916
  * GtkWindow catches keybindings for the menu items _before_ passing them to
2908
2917
  * the focused widget. This is unfortunate and means that pressing Ctrl+a,
2909
 
@@ -6012,184 +5592,10 @@
 
2918
@@ -6012,184 +5594,10 @@
2910
2919
        g_type_class_add_private (g_object_class, sizeof (EvWindowPrivate));
2911
2920
 }
2912
2921
 
3092
3101
          NULL, G_CALLBACK (ev_view_popup_cmd_open_link) },
3093
3102
        { "GoLink", GTK_STOCK_GO_FORWARD, N_("_Go To"), NULL,
3094
3103
          NULL, G_CALLBACK (ev_view_popup_cmd_open_link) },
3095
 
@@ -6206,7 +5612,7 @@
 
3104
@@ -6206,7 +5614,7 @@
3096
3105
 };
3097
3106
 
3098
3107
 static const GtkActionEntry attachment_popup_entries [] = {
3101
3110
          NULL, G_CALLBACK (ev_attachment_popup_cmd_open_attachment) },
3102
3111
        { "SaveAttachmentAs", GTK_STOCK_SAVE_AS, N_("_Save Attachment As…"), NULL,
3103
3112
          NULL, G_CALLBACK (ev_attachment_popup_cmd_save_attachment_as) },
3104
 
@@ -6276,13 +5682,6 @@
 
3113
@@ -6276,13 +5684,6 @@
3105
3114
 }
3106
3115
 
3107
3116
 static void
3115
3124
 zoom_action_activated_cb (EvZoomAction *action,
3116
3125
                          EvWindow     *window)
3117
3126
 {
3118
 
@@ -6378,42 +5777,6 @@
 
3127
@@ -6378,42 +5779,6 @@
3119
3128
 }
3120
3129
 
3121
3130
 static void
3158
3167
 sidebar_widget_model_set (EvSidebarLinks *ev_sidebar_links,
3159
3168
                          GParamSpec     *pspec,
3160
3169
                          EvWindow       *ev_window)
3161
 
@@ -6647,21 +6010,21 @@
 
3170
@@ -6647,21 +6012,21 @@
3162
3171
        const gchar *name = ev_link_action_get_name (action);
3163
3172
 
3164
3173
        if (g_ascii_strcasecmp (name, "FirstPage") == 0) {
3188
3197
        } else {
3189
3198
                g_warning ("Unimplemented named action: %s, please post a "
3190
3199
                           "bug report in Evince bugzilla "
3191
 
@@ -6782,8 +6145,8 @@
 
3200
@@ -6782,8 +6147,8 @@
3192
3201
                return;
3193
3202
        }
3194
3203
 
3199
3208
 
3200
3209
        uri = gtk_file_chooser_get_uri (GTK_FILE_CHOOSER (fc));
3201
3210
        filter = gtk_file_chooser_get_filter (GTK_FILE_CHOOSER (fc));
3202
 
@@ -6887,9 +6250,9 @@
 
3211
@@ -6887,9 +6252,9 @@
3203
3212
        gtk_file_chooser_set_do_overwrite_confirmation (GTK_FILE_CHOOSER (fc), TRUE);
3204
3213
        
3205
3214
        file_chooser_dialog_add_writable_pixbuf_formats (GTK_FILE_CHOOSER (fc));
3212
3221
 
3213
3222
        g_signal_connect (fc, "response",
3214
3223
                          G_CALLBACK (image_save_dialog_response_cb),
3215
 
@@ -7023,8 +6386,8 @@
 
3224
@@ -7023,8 +6388,8 @@
3216
3225
                return;
3217
3226
        }
3218
3227
 
3223
3232
 
3224
3233
        uri = gtk_file_chooser_get_uri (GTK_FILE_CHOOSER (fc));
3225
3234
        target_file = g_file_new_for_uri (uri);
3226
 
@@ -7122,8 +6485,8 @@
 
3235
@@ -7122,8 +6487,8 @@
3227
3236
                gtk_file_chooser_set_current_name (GTK_FILE_CHOOSER (fc),
3228
3237
                                                   ev_attachment_get_name (attachment));
3229
3238
 
3234
3243
 
3235
3244
        g_signal_connect (fc, "response",
3236
3245
                          G_CALLBACK (attachment_save_dialog_response_cb),
3237
 
@@ -7154,16 +6517,16 @@
 
3246
@@ -7154,16 +6519,16 @@
3238
3247
                if (EV_WINDOW_IS_PRESENTATION (window))
3239
3248
                        ev_view_presentation_previous_page (EV_VIEW_PRESENTATION (window->priv->presentation_view));
3240
3249
                else
3255
3264
        }
3256
3265
 }
3257
3266
 
3258
 
@@ -7278,8 +6641,72 @@
 
3267
@@ -7278,8 +6643,72 @@
3259
3268
 }
3260
3269
 
3261
3270
 static void
3328
3337
        GtkActionGroup *action_group;
3329
3338
        GtkAccelGroup *accel_group;
3330
3339
        GtkCssProvider *css_provider;
3331
 
@@ -7343,6 +6770,8 @@
 
3340
@@ -7343,6 +6772,8 @@
3332
3341
                          G_CALLBACK (activate_link_cb),
3333
3342
                          ev_window);
3334
3343
 
3337
3346
        app_info = g_app_info_get_default_for_uri_scheme ("mailto");
3338
3347
        ev_window->priv->has_mailto_handler = app_info != NULL;
3339
3348
        g_clear_object (&app_info);
3340
 
@@ -7351,15 +6780,13 @@
 
3349
@@ -7351,15 +6782,13 @@
3341
3350
        gtk_container_add (GTK_CONTAINER (ev_window), ev_window->priv->main_box);
3342
3351
        gtk_widget_show (ev_window->priv->main_box);
3343
3352
 
3357
3366
        register_custom_actions (ev_window, action_group);
3358
3367
 
3359
3368
        ev_window->priv->ui_manager = gtk_ui_manager_new ();
3360
 
@@ -7415,12 +6842,6 @@
 
3369
@@ -7415,12 +6844,6 @@
3361
3370
        g_object_unref (css_provider);
3362
3371
 
3363
3372
        ev_window->priv->recent_manager = gtk_recent_manager_get_default ();
3370
3379
 
3371
3380
        ev_window->priv->toolbar = ev_toolbar_new (ev_window);
3372
3381
        gtk_widget_set_no_show_all (ev_window->priv->toolbar, TRUE);
3373
 
@@ -7526,10 +6947,6 @@
 
3382
@@ -7526,10 +6949,6 @@
3374
3383
 
3375
3384
        sidebar_widget = ev_sidebar_bookmarks_new ();
3376
3385
        ev_window->priv->sidebar_bookmarks = sidebar_widget;
3381
3390
        gtk_widget_show (sidebar_widget);
3382
3391
        ev_sidebar_add_page (EV_SIDEBAR (ev_window->priv->sidebar),
3383
3392
                             sidebar_widget);
3384
 
@@ -7565,7 +6982,7 @@
 
3393
@@ -7565,7 +6984,7 @@
3385
3394
        g_object_set(ev_window->priv->view, "enable-gestures",
3386
3395
                     _oif_ev_application_get_gestures_enabled (EV_APP), NULL);
3387
3396
 #endif
3390
3399
                                             GS_PAGE_CACHE_SIZE);
3391
3400
        ev_view_set_page_cache_size (EV_VIEW (ev_window->priv->view),
3392
3401
                                     page_cache_mb * 1024 * 1024);
3393
 
@@ -7731,9 +7148,6 @@
 
3402
@@ -7731,9 +7150,6 @@
3394
3403
        g_settings_delay (ev_window->priv->default_settings);
3395
3404
        ev_window_setup_default (ev_window);
3396
3405
 
3400
3409
        gtk_window_set_default_size (GTK_WINDOW (ev_window), 600, 600);
3401
3410
 
3402
3411
         ev_window_sizing_mode_changed_cb (ev_window->priv->model, NULL, ev_window);
3403
 
@@ -7762,7 +7176,6 @@
 
3412
@@ -7762,7 +7178,6 @@
3404
3413
        ev_window = GTK_WIDGET (g_object_new (EV_TYPE_WINDOW,
3405
3414
                                              "type", GTK_WINDOW_TOPLEVEL,
3406
3415
                                               "application", g_application_get_default (),
3408
3417
                                              NULL));
3409
3418
 
3410
3419
        return ev_window;
3411
 
@@ -7801,3 +7214,11 @@
 
3420
@@ -7801,3 +7216,11 @@
3412
3421
 
3413
3422
        return ev_window->priv->zoom_selector_popup_action_group;
3414
3423
 }
3422
3431
+}
3423
3432
Index: evince-3.10.3/shell/ev-window.h
3424
3433
===================================================================
3425
 
--- evince-3.10.3.orig/shell/ev-window.h        2014-02-13 16:16:42.917954976 +0100
3426
 
+++ evince-3.10.3/shell/ev-window.h     2014-02-13 16:16:42.913954976 +0100
 
3434
--- evince-3.10.3.orig/shell/ev-window.h        2014-03-03 12:17:53.199442435 +0100
 
3435
+++ evince-3.10.3/shell/ev-window.h     2014-03-03 12:17:53.191442435 +0100
3427
3436
@@ -89,7 +89,7 @@
3428
3437
 GtkUIManager   *ev_window_get_ui_manager                 (EvWindow       *ev_window);
3429
3438
 GtkActionGroup *ev_window_get_main_action_group          (EvWindow       *ev_window);
3435
3444
 
3436
3445
Index: evince-3.10.3/shell/evince-appmenu.ui
3437
3446
===================================================================
3438
 
--- evince-3.10.3.orig/shell/evince-appmenu.ui  2014-02-13 16:16:42.917954976 +0100
3439
 
+++ evince-3.10.3/shell/evince-appmenu.ui       2014-02-13 16:16:42.913954976 +0100
 
3447
--- evince-3.10.3.orig/shell/evince-appmenu.ui  2014-03-03 12:17:53.199442435 +0100
 
3448
+++ evince-3.10.3/shell/evince-appmenu.ui       2014-03-03 12:17:53.191442435 +0100
3440
3449
@@ -20,6 +20,16 @@
3441
3450
   <menu id="appmenu">
3442
3451
     <section>
3456
3465
         <attribute name="accel">F1</attribute>
3457
3466
Index: evince-3.10.3/shell/evince-ui.xml
3458
3467
===================================================================
3459
 
--- evince-3.10.3.orig/shell/evince-ui.xml      2014-02-13 16:16:42.917954976 +0100
3460
 
+++ evince-3.10.3/shell/evince-ui.xml   2014-02-13 16:16:42.913954976 +0100
 
3468
--- evince-3.10.3.orig/shell/evince-ui.xml      2014-03-03 12:17:53.199442435 +0100
 
3469
+++ evince-3.10.3/shell/evince-ui.xml   2014-03-03 12:17:53.191442435 +0100
3461
3470
@@ -1,70 +1,10 @@
3462
3471
 <ui>
3463
3472
-  <popup name="ActionMenu" accelerators="true">
3571
3580
 </ui>
3572
3581
Index: evince-3.10.3/shell/evince.gresource.xml
3573
3582
===================================================================
3574
 
--- evince-3.10.3.orig/shell/evince.gresource.xml       2014-02-13 16:16:42.917954976 +0100
3575
 
+++ evince-3.10.3/shell/evince.gresource.xml    2014-02-13 16:16:42.913954976 +0100
 
3583
--- evince-3.10.3.orig/shell/evince.gresource.xml       2014-03-03 12:17:53.199442435 +0100
 
3584
+++ evince-3.10.3/shell/evince.gresource.xml    2014-03-03 12:17:53.195442435 +0100
3576
3585
@@ -19,6 +19,7 @@
3577
3586
   <gresource prefix="/org/gnome/evince/shell">
3578
3587
     <file alias="ui/evince.xml" compressed="true" preprocess="xml-stripblanks">evince-ui.xml</file>
3585
3594
Index: evince-3.10.3/shell/menus.ui
3586
3595
===================================================================
3587
3596
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
3588
 
+++ evince-3.10.3/shell/menus.ui        2014-02-13 16:16:45.000000000 +0100
 
3597
+++ evince-3.10.3/shell/menus.ui        2014-03-03 12:18:09.000000000 +0100
3589
3598
@@ -0,0 +1,188 @@
3590
3599
+<?xml version="1.0" encoding="UTF-8"?>
3591
3600
+<!--
3778
3787
Index: evince-3.10.3/shell/traditional-menus.ui
3779
3788
===================================================================
3780
3789
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
3781
 
+++ evince-3.10.3/shell/traditional-menus.ui    2014-02-13 16:16:42.913954976 +0100
 
3790
+++ evince-3.10.3/shell/traditional-menus.ui    2014-03-03 12:17:53.195442435 +0100
3782
3791
@@ -0,0 +1,230 @@
3783
3792
+<?xml version="1.0" encoding="UTF-8"?>
3784
3793
+<!--
4012
4021
+</interface>
4013
4022
Index: evince-3.10.3/po/POTFILES.in
4014
4023
===================================================================
4015
 
--- evince-3.10.3.orig/po/POTFILES.in   2014-02-13 16:16:42.917954976 +0100
4016
 
+++ evince-3.10.3/po/POTFILES.in        2014-02-13 16:16:42.913954976 +0100
 
4024
--- evince-3.10.3.orig/po/POTFILES.in   2014-03-03 12:17:53.199442435 +0100
 
4025
+++ evince-3.10.3/po/POTFILES.in        2014-03-03 12:17:53.195442435 +0100
4017
4026
@@ -56,3 +56,6 @@
4018
4027
 shell/ev-window-title.c
4019
4028
 shell/main.c